Subject: RE: [DNA] Definition of "Link Up" and "Link Down" events?

From: "McCann, Stephen" <[email-masked]>
Date: Fri, 27 May 2005 09:34:49 +0100

Dear all,
	Generalising this conversation, it appears to me that some sort of L2 
media specific "Link Up" indication is a potential requirement for DNA.

Hence is it a potential issue for the current work in the IEEE 802.11u and IEEE 802.16g groups, to name but two?

Kind regards

Stephen

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]] 
> Sent: Thursday, May 26, 2005 5:12 PM
> To: Brett Pentland
> Cc: Bernard Aboba; [email-masked]
> Subject: Re: [DNA] Definition of "Link Up" and "Link Down" events?
> 
> 
> Brett,
> 
> > > If the L2 software hides the L2 handover latency, then 
> "Link Up" and
> Link
> > > Down" never occur during handover, although they may 
> occur at other
> times,
> > > for example, if the terminal moves out of range of any base 
> > > stations.
> >
> > If such a handover involves changing L3 links, then for DNA 
> it would 
> > be really good to have "Link Up" or at least some kind of signal to 
> > trigger the DNA process.
> >
> 
> Yes, but I think that a radio protocol that supports 
> make-before-break would have to support that independently of 
> DNA. Even if it uses RFC 2461, it still needs some way to 
> trigger the RS.
> 
> But I'm speculating. Is Hesham or George on this list? They 
> are at Flarion, which has a make-before-break radio protocol, 
> perhaps they could tell us how IP link handover is triggered.
> 
>             jak
> 
> 

-- 

Visit our website at www.roke.co.uk

Roke Manor Research Ltd, Roke Manor, Romsey, Hampshire SO51 0ZN, UK.

The information contained in this e-mail and any attachments is proprietary to
Roke Manor Research Ltd and must not be passed to any third party without
permission. This communication is for information only and shall not create or
change any contractual relationship.

---

From: Greg Daley <[email-masked]>
Date: Mon, 30 May 2005 13:10:15 +1000

Hi Stephen,

Thanks for speaking up.

I guess that within 802.11u, there's a good chance of being able
to distinguish between change within the DS and between DS's.

Personally, I think that sort of distinction can be very helpful
in DNAv6, since it would be possible to defer some reachability
and configuration change tests until after IPv6 Neighbour Discovery
timers expire (5-30 seconds or more:- potentially never).

There's also potential interactions with 802.21 MIH, for similar
reasons.

Greg
(Speaking personally, rather than as a chair).