Subject: [DNA] MLD JOIN Questions?

From: Sathya Narayanan <[email-masked]>
Date: Wed, 09 Nov 2005 13:23:29 -0500

Before I forget, I just wanted to capture the questions and post them. The questions are:

1) When should the host do MLD join solicited node multicast group(s)?
  - After marking the IPv6 addresses as optimistic, or
  - Just before sending RS message or
  - someother time

2) Do we have to make any recommendation regarding MLD joins when layer-2 hints are received whether there is a link change or not? (due to the presence snooping switches)

Please comment.

thanks,
Sathya

---

From: Greg Daley <[email-masked]>
Date: Tue, 15 Nov 2005 03:57:28 +1100

Hi Sathya.

I've written some answers to your questions, in the rough
form of a text proposal:

>   - Just before sending RS message or

The host SHOULD send the MLD group join report for the solicited node's
multicast group when it becomes optimistic.  Note that this may precede
transmission of the DAD NS probe by some time, although the optimistic
node's ability to receive DAD NS's is limited until it does so.

In any case, the MLD report message MUST be sent before transmission of
either an RS, otherwise responding routers may not be able to resolve
the host's link-layer address.

> 2) Do we have to make any recommendation regarding MLD joins when layer-2
 > hints are received whether there is a link change or not? (due to the
> presence snooping switches)

A host SHOULD always join MLD groups, after it receives a link-UP hint
on a new point-of-attachment.

Until it does so there is no guarantee that it can receive packets
addressed to its solicited nodes' addresses.  This means that it
may not be able to see DAD NS probes or neighbour resolution attempts
until it has done so.

Comments?

Greg

---

From: Christian Vogt <[email-masked]>
Date: Mon, 14 Nov 2005 22:32:50 +0100

Hi Sathya, hi Greg.

> The host SHOULD send the MLD group join report for the solicited
> node's multicast group when it becomes optimistic.  [...]

Note that Nick mentioned that he'll modify the OptiDAD draft so that the 
optimistic address will be available for use even before the initial NS, 
and thus the MLD report, is sent.  (See thread starting at [1].)

This would allow an RS with a TSLLAO option to be sent even before the 
mobile node joins the solicited-node multicast group corresponding to 
the optimistic address.

Does this have an impact on the DNA Protocol 3?

Regards,
- Christian

[1] http://www1.ietf.org/mail-archive/web/ipv6/current/msg05777.html

-- 
Christian Vogt, Institute of Telematics, University of Karlsruhe
www.tm.uka.de/~chvogt/pubkey/

Greg Daley wrote:
> Hi Sathya.
> 
> I've written some answers to your questions, in the rough form of a
> text proposal:
> 
> 
> Sathya Narayanan wrote:
> 
>> 1) When should the host do MLD join solicited node multicast
>> group(s)? - After marking the IPv6 addresses as optimistic, or -
>> Just before sending RS message or - someother time
> 
> 
> The host SHOULD send the MLD group join report for the solicited
> node's multicast group when it becomes optimistic.  Note that this
> may precede transmission of the DAD NS probe by some time, although
> the optimistic node's ability to receive DAD NS's is limited until it
> does so.
> 
> In any case, the MLD report message MUST be sent before transmission
> of either an RS, otherwise responding routers may not be able to
> resolve the host's link-layer address.
> 
> A host SHOULD always join MLD groups, after it receives a link-UP
> hint on a new point-of-attachment.
> 
> addressed to its solicited nodes' addresses.  This means that it may
> not be able to see DAD NS probes or neighbour resolution attempts 
> until it has done so.
> 
> 
> Comments?
> 
> Greg

---

From: Brett Pentland <[email-masked]>
Date: Tue, 15 Nov 2005 10:19:22 +1100

> the host's link-layer address.

s/either//

Brett

---

From: Brett Pentland <[email-masked]>
Date: Tue, 15 Nov 2005 10:22:21 +1100

> Does this have an impact on the DNA Protocol 3?

I think it's the desired behaviour (being able to perform the RS/RA
exchange without the need for any prior or interleaved packets).

Brett.

---

From: Greg Daley <[email-masked]>
Date: Tue, 15 Nov 2005 10:29:39 +1100

>> the host's link-layer address.

Oh Yeah...

I orignally had DAD NS in my text, and removed it but forgot to
remove the either.

Greg

---

From: Greg Daley <[email-masked]>
Date: Tue, 15 Nov 2005 12:08:49 +1100

> Does this have an impact on the DNA Protocol 3?

While this is ideal, there's a problem if the router doesn't
support TSLLAO, in that it will neighbour resolve (if it doesn't
multicastRA).

If there's no MLD message sent before the RS, then an NS back to
the host will be lost on a snooping network.

That's why the MUST is in the text I wrote.

Greg