Subject: Re: [DNA] draft-ietf-dna-cpl-02.txt

From: Greg Daley <[email-masked]>
Date: Thu, 02 Feb 2006 11:36:33 -0500

Hi Brett, 

The first part (technical) is personal opinion.
I'll be tackling the procedural issues with
explicit "hat" notification.

----- Original Message -----
From: Brett Pentland <[email-masked]>
Date: Thursday, February 2, 2006 6:18 am
Subject: Re: [DNA] draft-ietf-dna-cpl-02.txt
> > OK. Could the authors please indicate what their plans are for
> > reissuing this document and what changes it will contain? (I've 
read
> > protocol3, but if another version is coming soone, I should 
probably
> > wait before commenting.)
> 
> I've been trying to incorporate the feedback that we've had so 
> far. It's
> in the process of being checked to see if the changes I've made are
> consistent, but you're welcome to see where it's at right now.  See
> 
> http://www.ctie.monash.edu.au/dna-dt/draft-ietf-dna-protocol-
pre00.txt
> 
> And a diff from protocol3 can be seen at:
> 
> http://www.ctie.monash.edu.au/dna-dt/draft-ietf-dna-protocol-pre00-
> from-draft-pentland-dna-protocol3-00.diff.html
> 
> There's a few issues that have come up while making the edits:
> 
> - Should the explicit linkid always be in the LPO or can it be a 
> flag in a PIO (the latter is in the draft)?

Personally, I prefer having  as this means there's no need to include
an LPO if all routers advertise the same prefix (which is also,
naturally the prefix linkid)
Of course this means the host needs to check each of the LPO and
PIO options for the flag, but it needed to parse the options anyway.

> - What order do the hosts treat the indications (land mark option,
>   prefixes, linkid in the draft at present)

I think that we should note that there could be conflicts between
these indications, either in a transition associated with 
router arrival or departure, or as an error condition.

If that's the case, we should recommend a safe course of action:
I'd suggest to act as if change has occurred (if there's sufficient
trust of the RA).

Does that make sense?

> - Given that we now have an explicit linkid, should we get rid of 
> all of the flags in the landmark option - the no flag is not really
> needed and since taking that out would leave only one, we can
> probably get rid of that as well - LO in RA = yes (at present the
> flags are still there)

I agree (so long as the prefix matches that from the LO in the RS),
but others may wish to state their position.

> Regards,
> Brett.
> 
> PS. I'm still not clear on procedure:
> since draft-pentland-dna-protocol3-00.txt is what the WG accepted, 
> doesthat have to become draft-ietf-dna-protocol-00.txt as is, or 
> can the
> edited version become the -00 if there are no objections to the 
edits?

<chair hat on>
I think that the current version is (draft-pentland-dna-protocol3-00)
is accepted, and at the same time you're accepted as the editor.

As the editor, you can start to make reasonable changes in accordance
with the WG's opinion, from the time you receive that role.
draft-ietf-dna-protocol-00 doesn't have to be a carbon copy of
the accepted document, so long as the changes are in line
with what the WG's direction is.

So if you've already got some minor changes (like in the diff)
that's fine.

For the three issues you raised, please note and track them,
and incorporate their solutions into -01.

Does that make sense?

If others need to discuss this please e-mail Suresh and I
(on or off-list).
<chair hat off>

Greg.

I'm in New Jersey now, and may start using my new work
e-mail address (Panasonic) for list postings.

---

From: Brett Pentland <[email-masked]>
Date: Sat, 04 Feb 2006 09:56:04 +1100

Hi Greg,

> PIO options for the flag, but it needed to parse the options anyway.

I agree.

> I'd suggest to act as if change has occurred (if there's sufficient

Yes.  There's a much bigger penalty for failing to detect link change
than for mistakenly assuming change and reconfiguring (which fairly
quickly recovers the old configuration).

> but others may wish to state their position.

You agree that the flags should go?

Good luck with the new job.
Brett.