Subject: Re: [DNA] CONSENSUS CALL : Document merges

From: Sathya Narayanan <[email-masked]>
Date: Sat, 24 Jun 2006 07:57:07 -0400

> > As I mentioned earlier, I think option A is the more practical
> > option.
> 
> Can you clarify? Does more practical   mean "less work for the current authors", or does it mean something else?

Yes - it means "less work for the current authors ang the group". But, my intention is not to reduce work alone, I am just concerned that more work may lead to the work not getting done in a timely manner.

> Personally, I think we should go the route that makes the most sense
> for implementors who will be implementing from the RFCs, long after this WG goes away. Even if this is somewhat more work for the WG. 

I agree that we should do what makes the most sense for implementors. I am just not sure "option B" is that much more sensible compared to "option A", hence my  preference for "option A".

- Sathya

> 
> > > Option A:
> > > =========
> > > Combine
> > > 1) Detecting Network Attachment in IPv6 Networks (DNAv6)
> > > and
> > > 2) Tentative Options for Link-Layer Addresses in IPv6 
> Neighbour Discovery
> > > (draft-ietf-dna-protocol-00 + draft-ietf-dna-tentative-00)
> > >
> > > into one document.
> > >
> > > Merge
> > > 3) Detecting Network Attachment in IPv6 - Best Current 
> Practices for
> > > hosts
> > > and
> > > 4) DNA with unmodified routers: Prefix list based approach
> > > (draft-ietf-dna-hosts-03 + draft-ietf-dna-cpl-02)
> 
> IMO, there should be one single document that tells implementors what
> to implement. I don't think it is helpful to have 2 different
> documents giving guidanace on this point. 
> 
> > > Option B:
> > > =========
> > >
> > > Merge all the above mentioned documents
> > >
> > > * draft-ietf-dna-protocol-00
> > > * draft-ietf-dna-tentative-00
> > > * draft-ietf-dna-hosts-03
> > > * draft-ietf-dna-cpl-02
> > >
> > > into a single document.
> 
> That would be my preference.
> 
> Thomasu
>

---

From: Thomas Narten <[email-masked]>
Date: Sun, 25 Jun 2006 08:42:49 +0000

> Yes - it means "less work for the current authors ang the
> group".

OK

> But, my intention is not to reduce work alone, I am just concerned
> that more work may lead to the work not getting done in a timely
> manner.

Personally, I'm already concerned about the progress this WG is
making. IMO, not a lot has happened in the last 6+ months or so. In
terms of what needs to be done (technology wise), I think that is
pretty well understood. But we have too many documents, they overlap
in confusing/contradictory ways, but we aren't actually seeing much
progress in getting those documents cleaned up. IMO, anyway. As one
crude example, how many times have the various IDs been revved in the
last 2-3 IETF cycles? if the answer is one revision per IETF cycle,
that's not fast enough and indicates slow progress.

I would encourage the chairs to take stock of the situation and put
together a plan covering the next 3-6 months (with concrete milestones
and commitments from document editors) that show us getting done and
shipping documents to the IESG.

Thomas

---

From: Greg Daley <[email-masked]>
Date: Mon, 26 Jun 2006 08:27:59 -0400

Hi Thomas, 

The problem you highlighted with regard to the document 
proliferation has been one of the contributory factors
which has slowed advancement.

The progress had slowed before that though, as you pointed
out.  

I think everyone is at the stage where they would just like to
see the documents come out.  Suresh and I have talked to
Jari about realistic milestones, and will release them as soon
as we know what the result of the consensus call is.

The new milestones will require an increase in work rate, but
not in advance of anything reasonable for a group of this size.
Essentially though, the WG and chairs have to put in more
effort if we actually want to see the documents come out.

Thanks for your input on this.

Greg

----- Original Message -----
From: Thomas Narten <[email-masked]>
Date: Sunday, June 25, 2006 4:47 am
Subject: Re: [DNA] CONSENSUS CALL : Document merges
To: Sathya Narayanan <[email-masked]>
Cc: [email-masked], Dna <[email-masked]>, "Suresh
Krishnan (QB/EMC)" <[email-masked]>, Greg Daley
<[email-masked]>, Jari Arkko <[email-masked]>