Subject: [DNA] Re: Neighbour Solicitations?

From: Sathya Narayanan <[email-masked]>
Date: Sat, 18 Nov 2006 08:47:38 -0500

Brett -

My understanding of this is that the TO section is not meant for DNA only. Since, the only known use of TO at the moment is DNA, it was decided to include TO in DNA to keep the number of documents to a minimum (1), but we need to make sure that we cover all relevant issues w.r.t. TO. So, for completeness sake imo we need to keep those sections.

I would like to hear others opinion, particularly the authors of the original TO draft.

thanks,
Sathya

----- Original Message -----
From: Brett Pentland <[email-masked]>
Date: Saturday, November 18, 2006 5:07 am
Subject: Neighbour Solicitations?

> Hi Sathya,
> 
> Sections 6.1.1 and 6.2.1 talk about Tentative Options in Neighbour 
> Solicitations.  While this makes sense in a general description of 
> Tentative Source Link Layer Address Options, the fact that this is 
> in 
> the DNA solution document seems to suggest that they are only for 
> DNA. 
> In this case, describing their use in Neighbour Solicitations 
> seems 
> unnecessary since NSs aren't mentioned anywhere else in the 
> document as 
> far as I can tell.
> 
> Do you think it's worth removing the text about Tentative Options 
> in 
> Neighbour Solicitations (while leaving the text relating to 
> Tentative 
> Options in Router Solicitations)?
> 
> Cheers,
> Brett.
>

---

From: Greg Daley <[email-masked]>
Date: Tue, 21 Nov 2006 10:07:17 +1100

Hi Sathya, 

I am happy to defer the use of the tentative option in NS to another
draft if needed.

Operations on the Neighbour Cache are what's important.

We can specify the router behaviour for reception of a Router or Neighbour
Solicitation saying, that the:

"...solicitation must otherwise be a valid message,
containing all mandatory fields and options...."

Then we can drop the specification of the NS operations so that the document
can focus on the RS operations which are those critical for DNA Protocol
operation.

The next document which wishes to use the NS operation can specify host
behaviour.

Greg

----- Original Message -----
From: Sathya Narayanan <[email-masked]>
Date: Sunday, November 19, 2006 0:50 am
Subject: [DNA] Re: Neighbour Solicitations?
To: Brett Pentland <[email-masked]>
Cc: Dna <[email-masked]>

> Brett -
> 
> My understanding of this is that the TO section is not meant for 
> DNA only. Since, the only known use of TO at the moment is DNA, it 
> was decided to include TO in DNA to keep the number of documents to 
> a minimum (1), but we need to make sure that we cover all relevant 
> issues w.r.t. TO. So, for completeness sake imo we need to keep 
> those sections.
>