Subject: [dns-privacy] I-D Action: draft-ietf-dprive-edns0-padding-02.txt

From: [email-masked]
Date: Mon, 25 Jan 2016 09:12:26 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the DNS PRIVate Exchange Working Group of the IETF.

        Title           : The EDNS(0) Padding Option
        Author          : Alexander Mayrhofer
	Filename        : draft-ietf-dprive-edns0-padding-02.txt
	Pages           : 6
	Date            : 2016-01-25

Abstract:
   This document specifies the EDNS(0) 'Padding' option, which allows
   DNS clients and servers to pad request and response messages by a
   variable number of octets.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dprive-edns0-padding/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dprive-edns0-padding-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dprive-edns0-padding-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Alex Mayrhofer <[email-masked]>
Date: Mon, 25 Jan 2016 22:56:59 +0530

Hi,

This version addresses comments received since the publication of the last draft version, including the WGLC comments. 

The only bigger change is that (in line with the comments received) I've generalized the text about Non-0x00 padding octects, based on text suggested by Andreas Gustaffson 

Alex 

---- [email-masked] schrieb ----

>_______________________________________________
>dns-privacy mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dns-privacy

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Mon, 25 Jan 2016 12:40:40 -0500

On Mon 2016-01-25 12:26:59 -0500, Alex Mayrhofer <[email-masked]> wrote:

> This version addresses comments received since the publication of the
> last draft version, including the WGLC comments.
>
> The only bigger change is that (in line with the comments received)
> I've generalized the text about Non-0x00 padding octects, based on
> text suggested by Andreas Gustaffson

Thanks for the update, Alex.  I think the new revision looks fine.

nit-pick: the Introduction now has the phrase "meta data of could
          still", which looks like an editing error.  i think you can
          just drop the word "of".

regards,

     --dkg

---

From: Alex Mayrhofer <[email-masked]>
Date: Tue, 26 Jan 2016 09:14:50 +0530

Hi,

Thanks for spotting that..  Again, this draft was edited from a mobile phone.   I'll note that for a future revision ( I'm sure there will be comments during iesg review as well).

Thanks :-)
Alex

---

From: Andreas Gustafsson <[email-masked]>
Date: Thu, 28 Jan 2016 12:44:50 +0200

> last draft version, including the WGLC comments.

Looks good to me.  Just a couple of nits:

In Section 6, Security Considerations, "provides only a benefit"
should be "only provides a benefit".

In section 7, Acknowledgements, "Gustaffson" should be "Gustafsson".
-- 
Andreas Gustafsson, [email-masked]

---

From: Alex Mayrhofer <[email-masked]>
Date: Thu, 28 Jan 2016 18:42:25 +0530

Andreas, 

Thanks for reviewing. Sorry for the typo in your name - I will address this together with changes from iesg processing before publication of the rfc.

Thanks,
Alex