Subject: [dns-privacy] [Editorial Errata Reported] RFC7858 (5375)

From: RFC Errata System <[email-masked]>
Date: Fri, 1 Jun 2018 04:57:01 -0700 (PDT)

The following errata report has been submitted for RFC7858,
"Specification for DNS over Transport Layer Security (TLS)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5375

--------------------------------------
Type: Editorial
Reported by: Jelte Jansen <[email-masked]>

Section: 9.2

Original Text
-------------
   [DNSCRYPT-WEBSITE]
              Denis, F., "DNSCrypt", December 2015,
              <https://www.dnscrypt.org/>.

Corrected Text
--------------
   [DNSCRYPT-WEBSITE]
              Denis, F., "DNSCrypt", December 2015,
              <https://www.dnscrypt.info/>.

Notes
-----
Not sure if an informative reference to a website is worth an erratum, but www.dnscrypt.org leads to a parking page. The official website is now at www.dnscrypt.info.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7858 (draft-ietf-dprive-dns-over-tls-09)
--------------------------------------
Title               : Specification for DNS over Transport Layer Security (TLS)
Publication Date    : May 2016
Author(s)           : Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. Hoffman
Category            : PROPOSED STANDARD
Source              : DNS PRIVate Exchange
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Brian Haberman <[email-masked]>
Date: Fri, 1 Jun 2018 14:45:34 -0400

Terry,
     Unless the authors state otherwise, this looks like an error at
publication time and the erratum can be marked Verified.

Regards,
Brian

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 1 Jun 2018 20:13:47 +0000

> publication time and the erratum can be marked Verified.

I'm pretty sure it was correct at publication time (I think I checked it); I suspect they changed it. Either way, is should be marked as Verified.

--Paul Hoffman

---

From: Brian Haberman <[email-masked]>
Date: Fri, 1 Jun 2018 16:28:48 -0400

> I'm pretty sure it was correct at publication time (I think I checked it); I suspect they changed it. Either way, is should be marked as Verified.

If the wayback machine is correct, then you are correct as well. It
looks like dnscrypt.org was valid after the publication date.

---

From: Brian Hartvigsen <[email-masked]>
Date: Fri, 01 Jun 2018 14:35:25 -0600

This is accurate.  https://twitter.com/jedisct1/status/928942292202860544  The .org domain was allowed to lapse the end of last year, .info was registered as a replacement after .org was registered by a Parked Domain service.

-- Brian

On 6/1/18, 2:30 PM, "dns-privacy on behalf of Brian Haberman" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    _______________________________________________
    dns-privacy mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/dns-privacy

---

From: Warren Kumari <[email-masked]>
Date: Fri, 1 Jun 2018 16:46:23 -0400

[ Top-post:  -Brian Hartvigsen, -Brian Haberman, -terry, -tim, -jelte,
-liangzhu, -allison]

Hi all,
As list admin, I have removed a number of people from the direct To: line
as I know that they also get this mail via the dns-privacy@ list.

I did this because each reply was causing mailman to hold the message
with "Reason:
Too many recipients to the message" and required me to manually go in and
approve it. This a: made me annoyed, but more importantly, b: delayed
messages hitting the list.

W

On Fri, Jun 1, 2018 at 4:37 PM Brian Hartvigsen <[email-masked]>
wrote:

> This is accurate.  https://twitter.com/jedisct1/status/928942292202860544
> The .org domain was allowed to lapse the end of last year, .info was
> registered as a replacement after .org was registered by a Parked Domain
> service.
>
> -- Brian
>
>
> On 6/1/18, 2:30 PM, "dns-privacy on behalf of Brian Haberman" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
>
>     > I'm pretty sure it was correct at publication time (I think I
> checked it); I suspect they changed it. Either way, is should be marked as
> Verified.
>     >
>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: John Heidemann <[email-masked]>
Date: Fri, 01 Jun 2018 14:30:53 -0700

>publication time and the erratum can be marked Verified.

I agree.
   -John

---

From: Paul Wouters <[email-masked]>
Date: Fri, 1 Jun 2018 16:40:57 -0400

> On Jun 1, 2018, at 16:28, Brian Haberman <[email-masked]> wrote:
> 
> 
>> 

We should be much more restrained with adding external references to an RFC document.

Paul