Subject: Re: [dns-privacy] Suresh Krishnan's No Objection on draft-ietf-dprive-bcp-op-08: (with COMMENT)

From: Sara Dickinson <[email-masked]>
Date: Wed, 4 Mar 2020 13:31:35 +0000

> On 6 Feb 2020, at 05:33, Suresh Krishnan via Datatracker <[email-masked]> wrote:
> 
> Suresh Krishnan has entered the following ballot position for
> draft-ietf-dprive-bcp-op-08: No Objection
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-dprive-bcp-op/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> * Section 5.2.3.
> 
> I found Table 1 to be extremely confusing. It is not clear from the table
> whether all of the properties are concurrently applicable to a certain
> technique when an "X" appears there. e.g. TC has marks for Format preserving,
> Prefix preserving, Reordering/Shuffling, and Random substitution. Some of these
> seem to be mutually exclusive. It would be good if you can clarify.

That was the intention of the table. TC (TCPdpriv - described in detail in Appendix B.3) preserves both the format and the longest prefix match but uses a random replacement for the remainder of the address.

Alissa suggested moving the table to Appendix B so it is in the context of the more detailed definitions of the categories and the individual techniques. I think that is a good idea - do you think that would address your concern?

> 
> I support Alissa and Ben's Discusses.
> 

Ack.

Best regards

Sara.

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 4 Mar 2020 13:54:40 +0000

> On Mar 4, 2020, at 8:31 AM, Sara Dickinson <[email-masked]> wrote:
> 
> 
> 

Thanks Sara. That would work.

Regards
Suresh

---

From: Sara Dickinson <[email-masked]>
Date: Thu, 5 Mar 2020 13:18:11 +0000

> On 4 Mar 2020, at 13:54, Suresh Krishnan <[email-masked]> wrote:
> 
> 
> 

Great - thank you!

Sara.