Subject: [dns-privacy] Call for Adoption: draft-huitema-dprive-dnsoquic

From: Tim Wicinski <[email-masked]>
Date: Wed, 8 Apr 2020 12:41:21 -0400

This starts a Call for Adoption for draft-huitema-dprive-dnsoquic

The draft is available here:
https://datatracker.ietf.org/doc/draft-huitema-dprive-dnsoquic/

Please review this draft to see if you think it is suitable for adoption
by DPRIVE, and comments to the list, clearly stating your view.

Please also indicate if you are willing to contribute text, review, etc.

This call for adoption ends: 22 April 2020

Thanks,
tim/brian

---

From: Jim Reid <[email-masked]>
Date: Wed, 8 Apr 2020 17:43:20 +0100

> On 8 Apr 2020, at 17:41, Tim Wicinski <[email-masked]> wrote:
> 

I support adoption of this ID and am willing to review and maybe contribute text.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 8 Apr 2020 16:55:51 +0000

On Apr 8, 2020, at 9:41 AM, Tim Wicinski <[email-masked]> wrote:
> The draft is available here: https://datatracker.ietf.org/doc/draft-huitema-dprive-dnsoquic/
> 

This draft is better than earlier versions, but still is missing something that seems crucial: detailed comparison between the protocol described here, DoT, and DoH. The suggestion in the text that the comparison would be added after there are implementations seems like the comparison would be about speed, but comparisons about protocol complexity, security, and privacy seem incredibly important as well.

The WG might delay adoption until this significant part is added to the document.

> Please also indicate if you are willing to contribute text, review, etc.

I would be happy to review and etc. after the needed comparisons are added.

--Paul Hoffman

---

From: Jim Reid <[email-masked]>
Date: Wed, 8 Apr 2020 18:03:43 +0100

> On 8 Apr 2020, at 17:55, Paul Hoffman <[email-masked]> wrote:
> 

I think those comparisons belong in a separate document. Which would leave this draft as just the spec for doing DNS over QUIC.

---

From: Brian Dickson <[email-masked]>
Date: Wed, 8 Apr 2020 10:09:03 -0700

On Wed, Apr 8, 2020 at 10:04 AM Jim Reid <[email-masked]> wrote:

> > This draft is better than earlier versions, but still is missing
> something that seems crucial: detailed comparison between the protocol
> described here, DoT, and DoH. The suggestion in the text that the
> comparison would be added after there are implementations seems like the
> comparison would be about speed, but comparisons about protocol complexity,
> security, and privacy seem incredibly important as well.
>
> I think those comparisons belong in a separate document. Which would leave
> this draft as just the spec for doing DNS over QUIC.
>

Yes, however that then begs the question of whether adopting this before
the other doc is complete, is a good idea.
At a minimum the other doc should be a blocker to publication of this one,
but I'd prefer to not adopt this until we have solid consensus around the
other (including anything particular that might inform the
design/implementation of this one).

Brian

>
> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy
>

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 8 Apr 2020 17:23:14 +0000

> I think those comparisons belong in a separate document. Which would leave this draft as just the spec for doing DNS over QUIC.

Would the WG still want to do the protocol work if the eventual comparison was "not noticeably better than DoT or DoH"?

--Paul Hoffman

---

From: Melinda Shore <[email-masked]>
Date: Wed, 8 Apr 2020 09:33:17 -0800

On 4/8/20 9:23 AM, Paul Hoffman wrote:
>> I think those comparisons belong in a separate document. Which
>> would leave this draft as just the spec for doing DNS over QUIC.
> 
> Would the WG still want to do the protocol work if the eventual
> comparison was "not noticeably better than DoT or DoH"?

While I think that's an interesting question in the abstract
I agree that it doesn't belong in this document, at least not
in quite those terms.  I also think that discussion is at least
partly implicit in the use case, largely because of the
question of defining "better for what?"

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 8 Apr 2020 17:54:48 +0000

> question of defining "better for what?"

Quite true. If the document specifies use cases, the WG would have a better idea of whether or not we want to adopt before or after we know if those use cases are already met approximately as well by DoT and/or DoH.

--Paul Hoffman

---

From: Ted Hardie <[email-masked]>
Date: Wed, 8 Apr 2020 11:18:43 -0700

I support adoption and I would be willing to review and contribute text.

Ted

---

From: Daniel Migault <[email-masked]>
Date: Wed, 8 Apr 2020 14:37:12 -0400

I am supporting the adoption and will review the document.
Yours,
Daniel

-- 
Daniel Migault
Ericsson

---

From: Rafael R Obelheiro <[email-masked]>
Date: Wed, 8 Apr 2020 18:20:32 -0300

(Borrowing Jim Reid's statement)
I support adoption of this ID and am willing to review and maybe 
contribute text.

Best regards,
Rafael

---

From: "Ralf Weber" <[email-masked]>
Date: Thu, 09 Apr 2020 07:49:55 +0200

Moin!

>> by DPRIVE, and comments to the list, clearly stating your view.
I support adoption of this draft and am willing to review and maybe 
contribute text

> comparison would be added after there are implementations seems like 
> the comparison would be about speed, but comparisons about protocol 
> complexity, security, and privacy seem incredibly important as well.
Ok let me try. DoT is based on TCP and thus the connection handling will 
have to put more bits on the wire. DoH being based on HTTP that has an 
arbitrary meta data layer in the protocol that is a privacy nightmare.

> The WG might delay adoption until this significant part is added to 
I don’t think the WG should delay this, especially as recent 
approaches to secure DNS transports (NS2) take different transports into 
account so having one more doesn’t hurt.

So long
-Ralf
—--
Ralf Weber

---

From: Loganaden Velvindron <[email-masked]>
Date: Thu, 9 Apr 2020 10:00:14 +0400

I'm

> I am supporting the adoption and will review the document.
I also support and will review the document.

---

From: Petr Špaček <[email-masked]>
Date: Thu, 9 Apr 2020 08:28:51 +0200

On 09. 04. 20 7:49, Ralf Weber wrote:
> I support adoption of this draft and am willing to review and maybe contribute text
> 
> Ok let me try. DoT is based on TCP and thus the connection handling will have to put more bits on the wire. DoH being based on HTTP that has an arbitrary meta data layer in the protocol that is a privacy nightmare.
> 
> I don’t think the WG should delay this, especially as recent approaches to secure DNS transports (NS2) take different transports into account so having one more doesn’t hurt.

I agree and also support adoption. Do not delay this.

-- 
Petr Špaček  @  CZ.NIC

---

From: Manu Bretelle <[email-masked]>
Date: Wed, 8 Apr 2020 23:37:49 -0700

I support adoption and I am willing to review.

Manu

---

From: Alexander Mayrhofer <[email-masked]>
Date: Thu, 9 Apr 2020 09:13:03 +0200

I support adoption of the document and will provide review (and, if appropriate, text).

Best,
Alex

Von: dns-privacy <[email-masked]> Im Auftrag von Tim Wicinski
Gesendet: Mittwoch, 8. April 2020 18:41
An: DNS Privacy Working Group <[email-masked]>
Cc: [email-masked]
Betreff: [dns-privacy] Call for Adoption: draft-huitema-dprive-dnsoquic

Thanks,
tim/brian

---

From: "Chris Box (BT)" <[email-masked]>
Date: Thu, 9 Apr 2020 17:50:13 +0100

In my view DoQ is a valuable addition to the set of IETF protocols, and
clearly has benefit over DoH for some use cases, as Ralf has explained. In
particular it would seem to be very useful in recursive to authoritative;
Christian referred to this in the presentation. I know the document is
focussed on stub to recursive but even here the simplicity achieved by
removing the HTTP layer has got to be attractive for some subset of
deployments.
I therefore support adoption, and am happy to review.

Chris

On Thu, 9 Apr 2020 at 08:13, Alexander Mayrhofer <[email-masked]>
wrote:

> *Von:* dns-privacy <[email-masked]> *Im Auftrag von *Tim
> Wicinski
> *Gesendet:* Mittwoch, 8. April 2020 18:41
> *An:* DNS Privacy Working Group <[email-masked]>
> *Cc:* [email-masked]
> *Betreff:* [dns-privacy] Call for Adoption: draft-huitema-dprive-dnsoquic
>
>
>
>

---

From: Geoff Huston <[email-masked]>
Date: Fri, 10 Apr 2020 17:26:01 +1000

> On 9 Apr 2020, at 2:41 am, Tim Wicinski <[email-masked]> wrote:
> 
> 

I support adoption of this document. 

I do _not_ believe that this document should incorporate a comparison with other DNS encapsulation methods, nor should await any such comparison document were it to be developed.

I am willing to review.

Geoff

---

From: Rob Sayre <[email-masked]>
Date: Fri, 10 Apr 2020 00:38:51 -0700

I oppose adoption of this document.

I don't see any advantage over DoH, as that standard will accrue QUIC
benefits as HTTP stacks shift to HTTP/3.

Maybe it's possible to block a port and use QUIC with this draft? That
might be useful, but perhaps needs a little more running code.

thanks,
Rob

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 14 Apr 2020 10:47:34 +0100

I support adoption.

I think someone bemoaned the possibility of another surplus
DNS transport option, but I don't think the existence of
RFC 8094 has caused any harm, so I consider that argument
weak, in this case. I can also easily envisage a future
where DoQ becomes important, so it'd be good if it's well
defined. I don't think this draft ought be the one where
one finds the analysis of all the different DNS transport
options.

Cheers,
S.

---

From: Rob Sayre <[email-masked]>
Date: Tue, 14 Apr 2020 17:44:22 -0700

On Tue, Apr 14, 2020 at 2:47 AM Stephen Farrell <[email-masked]>
wrote:

> weak, in this case.

It doesn't seem like this idea will cause harm aside from repetitious
rework, but DoH shows that it is an effective abstraction here.

Agree that the comparisons should go, as they are not fact-based.

thanks,
Rob

---

From: Benno Overeinder <[email-masked]>
Date: Wed, 22 Apr 2020 12:18:39 +0200

I support the adoption of the draft and I am willing to contribute/review.

-- Benno

-- 
Benno J. Overeinder
NLnet Labs
https://www.nlnetlabs.nl/

---

From: Tim Wicinski <[email-masked]>
Date: Wed, 22 Apr 2020 08:29:17 -0400

All

The call for adoption has ended and strong consensus to adopt.  Thanks
for all the feedback.

tim