Subject: Re: [dns-privacy] I-D Action: draft-ietf-dprive-dnsoquic-00.txt

From: Jan Včelák <[email-masked]>
Date: Fri, 26 Jun 2020 20:09:52 +0200

Hello.

This is just a quick note that I've refreshed the DNS-over-QUIC proxy
and client code that we wrote at IETF 104 Hackathon. I believe it's
compatible with the current draft and hopefully will be useful for
testing. Please, let me know if you have another client/server and if
it cooperates with our implementation.

The code is available at https://github.com/ns1/doq-proxy

Cheers,

Jan

On Mon, Apr 27, 2020 at 8:05 PM <[email-masked]> wrote:
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the DNS PRIVate Exchange WG of the IETF.
>
>         Title           : Specification of DNS over Dedicated QUIC Connections
>         Authors         : Christian Huitema
>                           Allison Mankin
>                           Sara Dickinson
>         Filename        : draft-ietf-dprive-dnsoquic-00.txt
>         Pages           : 20
>         Date            : 2020-04-27
>
> Abstract:
>    This document describes the use of QUIC to provide transport privacy
>    for DNS.  The encryption provided by QUIC has similar properties to
>    that provided by TLS, while QUIC transport eliminates the head-of-
>    line blocking issues inherent with TCP and provides more efficient
>    error corrections than UDP.  DNS over QUIC (DoQ) has privacy
>    properties similar to DNS over TLS (DoT) specified in RFC7858, and
>    latency characteristics similar to classic DNS over UDP.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-dprive-dnsoquic/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-dprive-dnsoquic-00
> https://datatracker.ietf.org/doc/html/draft-ietf-dprive-dnsoquic-00
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
>
> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy

---

From: Christian Huitema <[email-masked]>
Date: Fri, 26 Jun 2020 12:29:00 -0700

Jan,

Should we organize an interop session for the hackathon?  I could set up
a page for that.

-- Christian Huitema

---

From: Jan Včelák <[email-masked]>
Date: Tue, 30 Jun 2020 11:10:20 +0200

Christian,

I'm not sure I will be participating in the hackathon this time. If
there is an interop session and people working on the topic, I will do
my best to join and help debugging.

Jan