Subject: [dns-privacy] [Errata Held for Document Update] RFC8932 (6629)

From: RFC Errata System <[email-masked]>
Date: Mon, 5 Jul 2021 06:11:18 -0700 (PDT)

The following errata report has been held for document update 
for RFC8932, "Recommendations for DNS Privacy Service Operators". 

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6629

--------------------------------------
Status: Held for Document Update
Type: Technical

Reported by: Joeri de Ruiter <[email-masked]>
Date Reported: 2021-07-05
Held by: Eric Vyncke (IESG)

Section: B.1.

Original Text
-------------
One example would be to replace all TCP/UDP port
numbers with one of two fixed values indicating whether the
original port was ephemeral (>=1024) or nonephemeral (>1024).

Corrected Text
--------------
One example would be to replace all TCP/UDP port
numbers with one of two fixed values indicating whether the
original port was ephemeral (>=1024) or nonephemeral (<1024).

Notes
-----
Nonephemeral port numbers are <1024

--- Verifier note ---
The errata is indeed a real typo. As it is in appendix, "held for document update" was selected.

--------------------------------------
RFC8932 (draft-ietf-dprive-bcp-op-14)
--------------------------------------
Title               : Recommendations for DNS Privacy Service Operators
Publication Date    : October 2020
Author(s)           : S. Dickinson, B. Overeinder, R. van Rijswijk-Deij, A. Mankin
Category            : BEST CURRENT PRACTICE
Source              : DNS PRIVate Exchange
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Paul Wouters <[email-masked]>
Date: Mon, 5 Jul 2021 09:33:39 -0400 (EDT)

> Original Text

I agree with the typo fix, but I think it is also wrong to call all
ports > 1024 ephemeral. This is not the case. According to

https://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xhtml

 	Port numbers are assigned in various ways, based on three ranges: System
 	Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
 	Ports (49152-65535); the difference uses of these ranges is described in
 	[RFC6335]

Operating systems have used a different definition though, as can be
seen at: https://en.wikipedia.org/wiki/Ephemeral_port#Range

Perhaps instead of ephemeral/non-ephemeral, a fix would be:

 	One example would be to replace all TCP/UDP port
 	numbers with one of two fixed values indicating whether the
 	original port was a system port (<=1024) or non-system port (>1024).

Paul

---

From: Peter van Dijk <[email-masked]>
Date: Tue, 06 Jul 2021 17:04:51 +0200

>  	original port was a system port (<=1024) or non-system port (>1024).

system port (<1024) or non-system port (>=1024)

Kind regards,
-- 
Peter van Dijk
PowerDNS.COM BV - https://www.powerdns.com/

---

From: Paul Wouters <[email-masked]>
Date: Tue, 6 Jul 2021 13:44:46 -0400 (EDT)

> system port (<1024) or non-system port (>=1024)

Peter is correct :)

Paul