Subject: [dns-privacy] Datatracker State Update Notice: <draft-ietf-dprive-dnsoquic-10.txt>

From: IETF Secretariat <[email-masked]>
Date: Thu, 10 Mar 2022 07:21:33 -0800

IESG state changed:

New State: Approved-announcement to be sent::Revised I-D Needed

(The previous state was IESG Evaluation)

Datatracker URL: https://datatracker.ietf.org/doc/draft-ietf-dprive-dnsoquic/

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 15 Mar 2022 15:59:08 +0000

Dear authors,

The revised I-D should mainly address Francesca Palombini's 2nd COMMENT point (which was also raised by Alvaro Retana). Both of them told me that they were about to raise a blocking DISCUSS on this specific point, so let's address is. It is mainly about either changing a SHOULD into a MUST or explaining when the SHOULD can be ignored.

Of course, addressing the other points would improve the quality of the documents.

Once a revised I-D addressing Francesca's point, I am approving the document and sending it to the RFC Editor.

Regards

-éric

-----Original Message-----
From: IETF Secretariat <[email-masked]>
Date: Thursday, 10 March 2022 at 16:21
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Eric Vyncke <[email-masked]>
Subject: Datatracker State Update Notice: <draft-ietf-dprive-dnsoquic-10.txt>

    IESG state changed:

---

From: Christian Huitema <[email-masked]>
Date: Tue, 15 Mar 2022 11:39:17 -0700

I have entered issues in our repo for all the reviews by IESG members.

Ben Kaduk submitted an editorial PR, and it was accepted.
There is another PR being processed to address the clarification on 
usage of 0RTT required by Ben and Lars -- 
https://github.com/huitema/dnsoquic/pull/158. Please review.
I will start another PR addressing Francesca and Alvaro's point.
After that, we may need an editorial pass for the other comments.
The goal should be to have a draft ready when the publishing window reopens.

-- Christian Huitema

---

From: Christian Huitema <[email-masked]>
Date: Tue, 15 Mar 2022 15:40:17 -0700

Pull request https://github.com/huitema/dnsoquic/pull/159 addresses the 
second comment from Francesca's review, and the similar comment from 
Alvaro's review. It provides an alternative to "SHOULD forcibly abort 
the connection using QUIC's CONNECTION_CLOSE mechanism", by specifying 
that peers encountering fatal errors MAY silently abandon the 
connection. This is in fact always an option, peers may silently hang up 
at any time. In the case of such fatal errors, there is a trade-off 
between silent close and explicit close, which provides more information 
to the offending node but uses more of the local resource.

-- Christian Huitema

On 3/15/2022 11:39 AM, Christian Huitema wrote:
>> The revised I-D should mainly address Francesca Palombini's 2nd 
>> COMMENT point (which was also raised by Alvaro Retana). Both of them 
>> told me that they were about to raise a blocking DISCUSS on this 
>> specific point, so let's address is. It is mainly about either 
>> changing a SHOULD into a MUST or explaining when the SHOULD can be 
>> ignored.
>>
>> Once a revised I-D addressing Francesca's point, I am approving the 
>> document and sending it to the RFC Editor.
>>
>> Regards
>>
>> -éric
>>
>>
>> To: "[email-masked]" <[email-masked]>, 
>> "[email-masked]" <[email-masked]>, 
>> "[email-masked]" <[email-masked]>, 
>> "[email-masked]" 
>> <[email-masked]>, Eric Vyncke <[email-masked]>
>>      Datatracker URL: 
>> https://datatracker.ietf.org/doc/draft-ietf-dprive-dnsoquic/
>>
>>
>>
>
> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy

---

From: Christian Huitema <[email-masked]>
Date: Mon, 21 Mar 2022 15:03:35 -0700

We just published a new version of the draft, 
https://datatracker.ietf.org/doc/draft-ietf-dprive-dnsoquic/. We believe 
this new version addresses the comments received during IESG review. The 
changes were done in a series of pull request in our depot, visible 
here: https://github.com/huitema/dnsoquic/pulls?q=is%3Apr. We collected 
all the ballot reports, isolated the issues, and in most cases just 
fixed them. There were just very exceptions, in which case we contacted 
the individual IESG members and got them to agree that no change was 
actually requested. As eric wrote, "addressing [ these points ] improved 
the quality of the documents." Thanks to the IESG members for all the 
feedback.

-- Christian Huitema

On 3/15/2022 3:40 PM, Christian Huitema wrote:
> Pull request https://github.com/huitema/dnsoquic/pull/159 addresses 
> the second comment from Francesca's review, and the similar comment 
> from Alvaro's review. It provides an alternative to "SHOULD forcibly 
> abort the connection using QUIC's CONNECTION_CLOSE mechanism", by 
> specifying that peers encountering fatal errors MAY silently abandon 
> the connection. This is in fact always an option, peers may silently 
> hang up at any time. In the case of such fatal errors, there is a 
> trade-off between silent close and explicit close, which provides more 
> information to the offending node but uses more of the local resource.
>
> -- Christian Huitema
>