Subject: Re: [dns-privacy] Measurement & Padding Policy document

From: Sara Dickinson <[email-masked]>
Date: Mon, 4 Apr 2022 11:10:00 +0100

> On 25 Mar 2022, at 07:46, Alexander Mayrhofer <[email-masked]> wrote:
> 
> All,
> 
> as mentioned in DPRIVE yesterday,
> https://datatracker.ietf.org/doc/html/rfc8467 describes an
> (experimental) padding policy that was based on measurements performed
> by Daniel, and presented at NDSS in 2017.
> 
> Unfortunately, the original link to the paper doesn't work anymore:
> https://dns.cmrg.net/ndss2017-dprive-empirical-DNS-traffic-size.pdf
> 
> Future measurements could base on that work. Also, those future
> measurements would probably lead to more insight regarding appropriate
> padding sizes, so we could update RFC 8467.

Hi All, 

A late follow up but there is also a minor outstanding task to work on padding for Zone transfer over TLS.

> 
> Daniel, do you still have the paper from the link mentioned above?
> 

(The paper does not seem to be available but for reference a set of slides presented on this work at NDSS 2017 are here: https://drive.google.com/file/d/0B5gNT4RRJ0xPWTNfanYtUFU1bHc/view?resourcekey=0-mo33xmSnmfgc9N412adgvQ)

This topic came up in response to a question about future work for DPRIVE - just to mention that I’m aware of hackathon work and a WIP draft (not yet published) on the topic of encrypting Dynamic Updates that would potentially be new work for the WG. 

Best regards

Sara.

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Tue, 05 Apr 2022 09:27:34 -0700

> (The paper does not seem to be available but for reference a set of slides presented on this work at NDSS 2017 are here: https://drive.google.com/file/d/0B5gNT4RRJ0xPWTNfanYtUFU1bHc/view?resourceke…

sorry, this link was down for unrelated reasons, but it's back up now.
i believe it's the same thing that sara posted on the google drive.

  --dkg