Subject: [dnsext] [Technical Errata Reported] RFC4470 (6734)

From: RFC Errata System <[email-masked]>
Date: Thu, 11 Nov 2021 19:08:37 -0800 (PST)

The following errata report has been submitted for RFC4470,
"Minimally Covering NSEC Records and DNSSEC On-line Signing".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6734

--------------------------------------
Type: Technical
Reported by: Mark Andrews <[email-masked]>

Section: 4

Original Text
-------------
   The first of these NSEC RRs proves that no exact match for
   foo.example.com exists, and the second proves that there is no
   wildcard in example.com.

Corrected Text
--------------
TBD

Notes
-----
"the second proves that there is no wildcard in example.com" is incorrect.

\)555555555555555
     555555555555555
     555555555555555
     555555555555555
     55.example.com 3600 IN NSEC RFCNOTES_TEXT0.*.example.com ( NSEC RRSIG )

Actually proves that *.example.com exists as it is part of the next field.  It is an empty non-terminal wildcard.  'RFCNOTES_TEXT0.domain' can only be used to prove no data  exists at 'domain', not that 'domain' doesn't exist.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4470 (draft-ietf-dnsext-dnssec-online-signing-02)
--------------------------------------
Title               : Minimally Covering NSEC Records and DNSSEC On-line Signing
Publication Date    : April 2006
Author(s)           : S. Weiler, J. Ihren
Category            : PROPOSED STANDARD
Source              : DNS Extensions
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Mark Andrews <[email-masked]>
Date: Fri, 12 Nov 2021 14:46:06 +1100

What turned \00 into RFCNOTES_TEXT in the two instanced of \000?
Also all the \255 seem to have been collapsed into 55 or 5.

> On 12 Nov 2021, at 14:08, RFC Errata System <[email-masked]> wrote:
> 

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742              INTERNET: [email-masked]