Subject: Re: DNS SRV for Kerberos

From: Jeffrey Altman <[email-masked]>
Date: Wed, 17 Nov 99 13:27:20 EST

> I counsel against finding the "quicker update" KDCs by means of any
> records stored at a node like foo._kerberos._udp.REALM, since by and
> by there's likely to be a standardized getsomethingbyname(...)
> function that will only put together _service and _transport.
> Instead, I'd suggest a new name which in an /etc/services file is
> just a nickname for the "kerberos" service, but which in DNS points
> to the desired subset of KDCs.  Perhaps kerberos-pri.
> 
> 			Matt
> 

You can't use a general get something by name function to find a
service on another host which is what is needed here.  Even so
in this case 

  service   = foo._kerberos
  transport = tcp
  host      = REALM

this is assuming that the function automatically adds the underscores.
so the final query becomes

  _foo._kerberos._tcp.REALM IN SRV

    Jeffrey Altman * Sr.Software Designer * Kermit-95 for Win32 and OS/2
                 The Kermit Project * Columbia University
              612 West 115th St #716 * New York, NY * 10025
  http://www.kermit-project.org/k95.html * [email-masked]

---

From: "Matt Crawford" <[email-masked]>
Date: Wed, 17 Nov 1999 16:00:10 -0600

> service on another host which is what is needed here.

Sure you can.  It might even be

	int fd = getstreamservicebyname(servicename, dnsname);
or
	int fd = getdatagramservicebyname(servicename, dnsname,
					  requestbuf, requestlen,
					  replybuf, &replybuflen);

> Even so in this case 

That's a lot of grody detail for the application to have to know.
(This objection may not be applicable to Kerberos, which is pretty
danged grody already.)
				Matt