Subject: Re: BIND8/9 interaction with zones with A6

From: Marc Blanchet <[email-masked]>
Date: Sun, 28 Jan 2001 15:17:31 -0500

interesting...

you should probably report that to the [email-masked] mailing lists.

Marc.

At/À 01:19 2001-01-29 +0900, [email-masked] you wrote/vous écriviez:
>         we noticed this recently so i thought i should report it...
>
>         assume that you are using BIND9 as the master server for a zone
>         (like foo.net), and BIND8 as the slave server(s).
>
>         once you put A6 records into database files in master server,
>         slaves become unable to zone-transfer the zone at all.
>         slaves will never be able to transfer zones, so they will have
>         zone database with older serial number (which was fetched in the 
> past)
>         or cannot server the zone (as a slave).
>
>         so, if you wish to use A6 in foo.net, you need to use BIND9 on all
>         masters and slaves.  does anyone have any workaround for this?
>
>         i guess DNAME and bit string label could present the same effect.
>
>itojun
>
>---------------------------------------------------------------------
>The IPv6 Users Mailing List
>Unsubscribe by sending "unsubscribe users" to [email-masked]

Marc Blanchet
Viagénie inc.
tel: 418-656-9254
http://www.viagenie.qc.ca

----------------------------------------------------------
Normos (http://www.normos.org): Internet standards portal:
IETF RFC, drafts, IANA, W3C, ATMForum, ISO, ... all in one place.

---

From: [email-masked]
Date: Mon, 29 Jan 2001 01:19:54 +0900

zone database with older serial number (which was fetched in the past)

itojun

---

From: Antonio Querubin <[email-masked]>
Date: Sun, 28 Jan 2001 08:55:58 -1000 (HST)

> 	masters and slaves.  does anyone have any workaround for this?

I ran into the same problem when BIND 9 first came out of beta into full
release and I tried playing around with A6.  I was unable to find a
workaround and ended up reverting back to AAAA records.

---

From: Bill Manning <[email-masked]>
Date: Sun, 28 Jan 2001 18:34:34 -0800 (PST)

True with -ANY- RR type that is not known by v8.  It will
	refuse to load the zone.  Known in the DNS community for 
	some time.  Something to do with needed to have coherence
	in the zone data.

% 
% 	we noticed this recently so i thought i should report it...
% 
% 	assume that you are using BIND9 as the master server for a zone
% 	(like foo.net), and BIND8 as the slave server(s).
% 
% 	once you put A6 records into database files in master server,
% 	slaves become unable to zone-transfer the zone at all.
% 	slaves will never be able to transfer zones, so they will have
% 	zone database with older serial number (which was fetched in the past)
% 	or cannot server the zone (as a slave).
% 
% 	so, if you wish to use A6 in foo.net, you need to use BIND9 on all
% 	masters and slaves.  does anyone have any workaround for this?
% 
% 	i guess DNAME and bit string label could present the same effect.
% 
% itojun
% 
% ---------------------------------------------------------------------
% The IPv6 Users Mailing List
% Unsubscribe by sending "unsubscribe users" to [email-masked]
% 

-- 
--bill

---

From: [email-masked]
Date: Mon, 29 Jan 2001 11:37:32 +0900

>	some time.  Something to do with needed to have coherence

	i see, then it is one of generic operational tips :-)

itojun