Subject: RE: (ngtrans) Re: IPv6 dns

From: Randy Bush <[email-masked]>
Date: Fri, 19 Jan 2001 11:11:47 -0800

> Well, IPv6 users who want to access the IPv4 only DNS server will need
> some form of solution.

i am confused.  why is this any different than any other client-server
interaction crossing the 4/6 border?  all protocols will need to do this
for the next decade(s) in a mixed 4/6 internet.

randy

---

From: "Joseph T. Klein" <[email-masked]>
Date: Fri, 19 Jan 2001 16:12:27 -0500

At some point here we need to bite the bullet and put IPv6 DNS in
the ".". Why not an equal but separate set of root name servers
for V6 under IANA control? The named.root file can be distributed
in three flavors. IPv4 only, 6 and 4, 6 only? This is a political
issue and perhaps off the mark here.

Should this be discussed with the DNS Root Server System Advisory
Committee or is the root servers status a political nightmare?

Perry E. Metzger wrote:

> "Christian Huitema" <[email-masked]> writes:
> 
>> some form of solution. There is indeed no particular problem in
>> deploying a relay-resolver -- we are doing that all the time.
> 
> 
> Ultimately, relay resolvers won't work. Our goal is to transition from
> v4 to v6. That means we have to at some point deploy native v6
> servers.
> 
> It is true that relay resolvers are a useful transition mechanism --
> we use them right now, in fact. I'm merely suggesting we should also
> be moving towards the long term solution as well.
> 
> Perry
> 
> --
> Perry E. Metzger		[email-masked]
> --
> Quality NetBSD CDs, Support & Service. http://www.wasabisystems.com/

---

From: "Perry E. Metzger" <[email-masked]>
Date: 19 Jan 2001 14:06:06 -0500

Perry

---

From: "Christian Huitema" <[email-masked]>
Date: Fri, 19 Jan 2001 11:02:14 -0800

Well, IPv6 users who want to access the IPv4 only DNS server will need
some form of solution. There is indeed no particular problem in
deploying a relay-resolver -- we are doing that all the time. The only
question is, how do IPv6 only resolvers find the nearest or most
adequate dual-mode relay? DNS server discovery may or may not be the
answer; are we ready to accept that "default server" and "IPv4 relay"
are the same function?

> -----Original Message-----
> From: Jim Bound [mailto:[email-masked]]
> Sent: Friday, January 19, 2001 6:53 AM
> To: Bill Manning
> Cc: Christian Huitema; Randy Bush; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: (ngtrans) Re: IPv6 dns
> 
> 
> What Christian suggests and the fix is not a protocol or IETF type 
> operational issue, but a deployment decision operators and users will
> have to make.
> 
> /jim
> 
> On Thu, 18 Jan 2001, Bill Manning wrote:
> 
> > % Randy also asked, what happens if an IPv6 only DNS 
> resolver tries to get
> > % information about an IPv4 domain. The obvious answer is 
> to use a dual
> > % mode server as proxy. However, this requires some 
> configuration, which
> > % Ngtrans should automatize. Now, that would would be a 
> work item for this
> > % group...
> > % 
> > % -- Christian Huitema
> > 
> > 	Perhaps. If this is a protocol issue, then I concur.
> > --bill
> > 
> 
>