Subject: Re: Comment on draft-jeong-hmipv6-dns-optimization-01.txt

From: "Jaehoon Jeong" <[email-masked]>
Date: Tue, 24 Jun 2003 14:02:18 +0900

Hi, Scott.
Thanks for your good comments.
Look at the inlines.

----- Original Message ----- 
From: "Scott Rose" <[email-masked]>
To: <[email-masked]>
Sent: Monday, June 23, 2003 11:00 PM
Subject: Comment on draft-jeong-hmipv6-dns-optimization-01.txt

> 
> I was reading over the draft and had a question regarding section 7
> Detection of RDNSS Failure:
> 
> Why does the MAP need to check the state of the recursive DNS servers?  If
> they are all part of the same administrative domain, an operator will make
> sure the DNS servers are up and running.
> 
   The reason MAP checks  recursive DNS servers' state is to let MAP announce
   only  the living or reachable DNS servers.
   As you say, network operator can make sure the DNS servers within the managed domain
   are working in order. But until some DNS servers are down or out of order and
   the network administrator handles the problem, MAP will continue to announce the invalid DNS servers.

> A client can also choose to ignore a recursive DNS server that it believes
> to be down.  If it sends out a DNS query, but does not recieve a reply, it
> can mark the server as "bad" or delete the server from its list of recursive
> servers to query.
> 
   Though a client can detect some DNS server, it will take a time to detect.
   I intended to reducing the detection time by MAP polling DNS servers regularly.

> I think it adds complexity for the MAP to ping every recursive DNS server
> unless there are a number of unstable DNS servers on a network.
> 
   Yes, you are right when MAP often checks the DNS servers.
   If MAP pings every DNS server at appropriate intervals, I think, 
   there is not much complexity.

   I'd like to listen to other opinions.
   Thanks :-)
    
   Regards,
   Jaehoon

> Scott
> =================================
> Scott Rose
> Adv. Network Technology Div., NIST
> http://www.antd.nist.gov/proj/dnssec
> 
> ph - 301-975-8439
> ==================================
> 

#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Thu, 26 Jun 2003 09:04:48 +0900

After thinking about your comments, I became to agree with you.
Right, I'll let it a part of network admin to maintain the list of RDNSS.
I will modify my draft, reflecting Scott's and Luc's comments.
Thanks a lot.

Jaehoon

----- Original Message ----- 
From: "Scott Rose" <[email-masked]>
To: "Jaehoon Jeong" <[email-masked]>
Sent: Tuesday, June 24, 2003 9:54 PM
Subject: Re: Comment on draft-jeong-hmipv6-dns-optimization-01.txt

> 
> My main concern is that maintaining the list of RDNSS seems to be an
> operational concern, and not really a part of the protocol extensions the
> draft describes.   It is not really important how a network keeps the list
> of DNS servers current, there are many options for a network admin to use
> depending on how the network is configured.
> 
> It would be enough to say that the MAP should take action to keep the list
> of RDNSS up to date, but not mandate how that is done.  That can be left as
> an operational concern for an individual network.
> 
> Scott
> 
> From: "Jaehoon Jeong" <[email-masked]>
> To: "Scott Rose" <[email-masked]>
> Cc: "DNSOP WG" <[email-masked]>
> Sent: Tuesday, June 24, 2003 1:02 AM
> Subject: Re: Comment on draft-jeong-hmipv6-dns-optimization-01.txt
> 
> 
> > Hi, Scott.