Subject: RE: IPv6 DNS Autoconfiguration

From: [email-masked]
Date: Mon, 14 Jul 2003 20:58:25 +0100

> At least, DNS discovery based on RA is easy and
> necessary in IPv6 wired and wireless networks
> connected to the Internet, I believe. 
> Especially, in the environments where IPv6 address
> configuration is performed by IPv6 stateless address
> autoconf, such as HMIPv6 and NEMO, RA-based DNS
> Discovery is faster than DHCPv6-based DNS Discovery.
> IMHO, both DHCPv6-based approach and RA-based approach
> are necessary, depending on the situations, just like
> IPv6 address autoconfiguration.

Having both mechanisms could work: if we assume that routers configured to
advertise recursive name server data will always do so when they send an RA
(i.e. there is no explicit request mechanism other than standard RS) then if
a node doesn't get the recursive name server data when it receives an RA, it
can infer it needs to do DHCPv6(lite).

Mat.
#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: Jaehoon Jeong <[email-masked]>
Date: Mon, 14 Jul 2003 19:27:36 -0700 (PDT)

> can infer it needs to do DHCPv6(lite).

IMHO, the RA and DHCPv6 approaches are not hostile,
but complentary each other. It is important that IPv6
basic protocol has the complete autoconfiguration,
including DNS discovery.
It is the time for us to decide RA-based DNS discovery
as working item. 
Four authors (Jaehoon, Daniel, Syam and Luc) agreed
that a united draft about RA-based DNS Discovery
should be published. If DNSOP wg allows our proposal,
we'll write a draft together.
How about?

/Jaehoon

> Mat.

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com
#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.