Subject: Re: Re: Stepping back on the DNS discovery discussion

From: 박수홍 <[email-masked]>
Date: Tue, 15 Jul 2003 20:59:03 +0900

> If we think that DNS discovery (for lack of a better term) is a 
> critical part of stateless autoconfiguration,
> it may makes sense for it to have the same properties as  the rest  of 
> the story, e.g. prefix discovery.

>>There was certainly a significant hum in this direction in the meeting.
>>Both DNS Lite and RA discovery methods can exist; each has an application 
>>domain/scope.

Exactly... dnsop WG must decide these consensus as soon as possible.

   Daniel
#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: [email-masked]
Date: Wed, 16 Jul 2003 10:07:12 +0100

To replicate only the functionality of the RA/ND approach, the DHCP client
required is very minimal indeed.

Mat.

> -----Original Message-----
> From: Jasminko Mulahusic [mailto:[email-masked]]
> Sent: 16 July 2003 10:41
> To: Ford,M,Mat,XGH5 FORDM5 R
> Cc: [email-masked]
> Subject: RE: Re: Stepping back on the DNS discovery discussion
> 
> 
> 
> 
> On Tue, 15 Jul 2003 [email-masked] wrote:
> 
> > the RA/ND approach is 'right'. It might help if you could 
> say why you
> > believe that, and specifically why you believe that using 
> RA/ND is better
> > than using DHCP.
> >
> 
> one argument that i have heard is that you don't have to have 
> a running
> dhcp client on you device.
> 
> jasminko
> 
> > Mat.
> >

---

From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
Date: Thu, 17 Jul 2003 11:29:19 +0200

Hi Tim, 

Thanks you to react., My coments below

> -----Message d'origine-----
> De : Tim Chown [mailto:[email-masked]] 
> Envoyé : mercredi 16 juillet 2003 19:04
> À : [email-masked]
> Objet : Re: TR : Stepping back on the DNS discovery discussion
> 
> 
> On Wed, Jul 16, 2003 at 02:31:14PM +0200, BELOEIL Luc 
> FTRD/DMI/CAE wrote:
> > 
> > As DNS is a critical service between "applications world" and "IP 
> > layer world", we might be careful on consequences. From application 
> > point of view, we might ask in the future to extende that 
> solution to 
> > other type of services (NTP, ...). In that way, RA-based solution 
> > might not be the good solution, because I do think that RA 
> must not be 
> > extended to any sort of service discovery. Any idea about that?
> 
> So where do you draw the boundary between "network device 
> autoconfiguration" 
> and "service discovery".   For IPv4, you (manually or via 
> DHCP) configure
> IPv4 address, netmask, gateway and DNS resolver(s) as the 
> "basic" four 
> components to be able to get up and running.   In IPv6, when 
> using stateless 
> autoconfiguration, the RA mechanism takes care of the first 
> three (because 
> the stateless mechanism implies the /64 "netmask"), but the 
> DNS resolver 
> address(es) cannot be learnt (although I believe WinXP implements the 
> well-known site local discovery method).
> 
Yes indeed

> So an interesting question is what we mean by "stateless 
> autoconfiguration".
> I think this term is causing some of the religion in the 
> discussion :)   It 
> seems that probably mean "autoconfiguration without servers 
> (i.e. DHCPv6)", since there would have to be state 
> (pre-configuration) in the router (the 
> prefix configuration).   The RA camp seems to want the 
> routers to be able to
> issue DNS resolver information, not a separate full-blown 
> DHCPv6 server.
>
Hum as far as I understand DHCP-lite solution,DHCP-lite is also a stateless solution.
 
> But it's not that clear cut as, for example, my home DSL 
> router includes a DHCP server (as well my DNS server and 
> print server and other stuff). The functionality is combined, 
> all in a very cheap (<100 Euro) commodity box.
> 
How much a solution is , is only one side of the issue, not all -it depends so much of the market ;+). I do not discuss that.

> So are we really concerned as to whether we need a separate 
> DHCPv6 server on our network (and the overhead of that in 
> ad-hoc networks), or that we would 
> like a router to be able to provide DNS resolver information 
> on link (such that
> we can plumb networks without needing a separate DHCPv6 box)? 
>   If the latter, 
> then does it matter if the router does that via RA piggybacks 
> or DHCPv6 Lite? What is the real difference in implementation cost?
> 
Good question, I don't still know.

> Of course the mode of operation is also an interesting issue, 
> but it's possible for DHCPv6(Lite) to have an unsolicited 
> response mode added, if that is felt to be important.
> 
That solution must be investigate also.

> Something has to configure the prefix information to the 
> router, likewise the DNS information has to be configured.  I 
> don't think we've discusse that much, but distributing the 
> DNS resolver information to multiple routers rather than one 
> (or a small number of) DHCPv6 servers may require more 
> thought.  But in my home network, it'll all be in my DSL router :)
>

Some questions must still be investigated so that I could have a better opinion. 
- Can DHCP-lite work on the same link were there is a DHCP server, or a DHCP-relay?
- is DHCLP-lite with multicast extension is still DHCP? ;+)
- is RA-base solution actually much easier to implement? 
- How RA-based wil be implement, within the kernel, as a separate daemon?
...
 
> Tim

Luc