Subject: Re: DNS discovery discussion

From: Ralph Droms <[email-masked]>
Date: Wed, 23 Jul 2003 05:35:22 -0400

Alain wrote:

>The RA camp keeps making the false assumption that using the
>DHCPv6-lite protocol to do this
>requires to have a big-iron DHCPv6 server on the network. This simply
>is not true.
>
>         - Alain.

Alain is correct - the machinery in a host and a router
to exchange DHCPv6 Information-request/Reply messages is
nowhere as complex as a full DHCPv6 implementation.

We can demonstrate "DHCPv6-lite" in Cisco routers (in IOS).
It was developed as a a samll part of a part-time project
to implement DHCPv6 prefix delegation by three of
us at Cisco (Ole Troan, Jun Xie and myself).

- Ralph

#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: Ralph Droms <[email-masked]>
Date: Wed, 23 Jul 2003 05:58:45 -0400

Regarding the development of a mechanism for multicast
in DHCPv6-lite...

The IPv4 community has been configuring hosts on IPv4
networks with DHCP on large networks for many years,
and there has not been, to date, a demand for any mechanism
to reduce the amount of DHCP traffic.  I don't have
specific figures, but I would imagine that - even in
the case of synchronized startup of all the hosts on
a link - the DHCP traffic would be no more than (and
probably significantly less than) ARP and similar traffic.

I wonder if the situation would be similar in an IPv6
network?  I don't have any operational or measurement
experience, so I don't know what the traffic looks
like on a link where, say, 10,000 hosts start at the
same time?  Can someone comment or speculate on what
the total traffic might look like and
whether multicast DHCPv6 would have a significant
impact on that traffic?

- Ralph

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 24 Jul 2003 13:46:31 +0859 ()

Ralph;

> whether multicast DHCPv6 would have a significant

Some protocol such as IPv6 intensively use (link local)
multicast.

The reason is merely that, at the time such protocols were
designed, some people believed, though they have been warned,
that the Internet must operate over large clouds of public ATM
networks, broadcast over which was impractical, which is true
because ATM is impractical, and that ATM were multicast capable.

By assuming large link layer, which violates the CATENET model,
many protocols, including but not limited to IPv6 and IGMP,
are damaged.

Now, we can simply say, broadcast.

						Masataka Ohta

---

From: "Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 24 Jul 2003 14:31:16 +0900

I agree partly with Alain and Ralph.
However, I think, RA camp including me suggest that
RA-based DNS Discovery is indispensible to ND. 
Of course, I believe that it can be used harmoniously with DHCPv6.
Why should both stateless (ND) and stateful (DHCP) mechanisms
not be developed and deployed  for DNS Discovery?

After the last ietf meeting, four authors (Daniel, Luc, Syam and me) has merged three drafts
regarding RA-based DNS Discovery to make a new draft as follows. 
  http://www.adhoc.6ants.net/~paul/data/draft-jeong-dnsop-ipv6-dns-discovery-00.txt

We would like to propose this draft as DNSOP wg draft for further discussion.
As open issues, the following are suggested;
   o  How to optimize bandwidth on the link? 
   o  How to implement RA-based DNS discovery? 
   o  How to interact with stateful mechanism? 
   o  What about several routers on the same link that could advertise 
      distinct parameters?

We welcome your comments and suggestions.
Thanks.

/Jaehoon Paul