Subject: RE: avoiding proxies

From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
Date: Thu, 31 Jul 2003 17:16:42 +0200

Hi Tim,

> -----Message d'origine-----
> De : Tim Chown [mailto:[email-masked]]
> Envoye : mercredi 30 juillet 2003 16:46
> 
> On Wed, Jul 30, 2003 at 09:05:35AM -0500, Eric A. Hall wrote:
> > 
> I note that in many enterprises DHCP is not used.  Hosts are manually
> configured, yet such enterprises have well known DNS resolvers.
> 
> At our own enterprise (university) where we have DHCP we use 
> it for the
> basic network config stuff (that is handled in v6 by RAs), 
> plus DNS, DNS
> search path, NTP, NIS and some boot parameters.   I don't 
> know how typical
> that is in a campus department.
>

At our own entreprise (operator R&D department), we have also DHCP. I do
think that is very common in our IPv4 world.
 
> The interesting question is how the DNS resolver (and/or 
> other) information
> is configured to the router, for the RA method to work.
>

To my mind, recursive DNS resolver information would be acquired through
uplink access in a SOHO environment (typically through DHCPv6 over PPP).
In a entreprise/university, such information would be configured by
network managers on routers where it is needed, in the same manner as
the configuration of DHCP-relay are configured.
 
> Tim

Luc

#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
Date: Thu, 31 Jul 2003 17:32:05 +0200

Hi Eric and Masataka

> De : Eric A. Hall [mailto:[email-masked]]
> Envoye : jeudi 31 juillet 2003 07:14
> A : Masataka Ohta
> 
> on 7/30/2003 11:10 PM Masataka Ohta wrote:
> 
> > I'm not sure what you mean "proxy".
> 
> I mean a third-party agent with knowledge of the application 
> and/or the
> environment. My examples were poorly formed but are valid in 
> the general
> sense, since we are still talking about relying upon extraneous agents
> which have to be managed explicitly and separately from the 
> application
> end-points themselves. Certainly there are advantages to doing so
> voluntarily (equitable benefit from the investment in resources), but
> requiring this model really needs to be avoided.
> 
> > On the Internet, the mechanism to relay requests to servers over
> > multiple links is called routing.
> 
> Exactly, let's let routing do the job it is supposed to be providing
> already anyway, rather than layering on even more mandatory services.
> 

Ok I may understand what do you wanna say. 
1- we could use multicast to transport DNS requests. But multicast is
not easy to deploy within access networks such as xDSL, RTC... (NBMA
links)
2- we could use anycast

But it is not clear for me how we could use DNSSEC in such scheme. There
is still and perhaps a bigger issue there if we need to distribute keys.
(I do not argue that RA-based solution is better there ;+)

Luc