Subject: Re: Policy of IPv6 DNS Discovery

From: "Jaehoon Paul Jeong" <[email-masked]>
Date: Sat, 2 Aug 2003 13:14:53 +0900

Hi Bill,

My mail is as follows;
Maybe, you can see mine, now.

/Jaehoon Paul

-----------------------------------------------------------------------------------------------
Hello all,

Thanks for your insightful suggestions and comments.
For DNS Discovery, we have been discussing much.
IMHO, every technology has its own application domain.
Until now, several propositions for DNS Discovery have been suggested and discussed.
A unique solution can not cover every environment, I think.
DHCPv6, RA, Anycast and Multicast approaches have their own domain.
If each applicability is reasonable, it is valuable to develop it and adopt it.
As one of RA camp, I think, RA-approach is useful in some of wireless networks,
such as HMIPv6, MANET connected to the Internet and NEMO.
You can refer to each application in the following links;

 - HMIPv6: 
   http://www.ietf.org/internet-drafts/draft-jeong-hmipv6-dns-optimization-01.txt
   http://www.adhoc.6ants.net/~paul/publications/international-conference/vtc2003-fall-jaehoon.pdf

 - MANET and NEMO:
   http://www.adhoc.6ants.net/~paul/publications/international-conference/pimrc2003-jaehoon.pdf

RA-based DNS Discovery is efficient when address autoconfiguration should be
performed through RA, because it needs not additional discovery.
For example, if MAP option and DNS option in an RA message are delivered in HMIPv6,
there is no delay to discover DNS information. This scheme leads to the optimization
of DNS name resolution owing to using the local recursive DNS server within the MAP domain.

In MANET connected to the Internet, the binding of global IPv6 address is needed
to communicate with an Internet node. RA-based approach is suggested as follows;
  http://people.nokia.net/~charliep/txt/aodvid/globalv6.txt

In this case, the address of recursive DNS server is needed for resolving the global DNS 
name. DNS option is also indispensible to this approach.

If we do not adopt RA-based DNS Discovery, there will be limitation in some domains.

Basically, in most of the current  IPv6 LANs, ND-based stateless address autoconfiguration
is used for address autoconfiguration rather than stateful DHCP approach.
In IPv6 stateless autoconfiguration, DNS discovery is a big lack in the basic IPv6 networking service. 
If DNS discovery is provided via RA message, I believe, most of IPv6 LANs will do without DHCPv6.
As you know, in most of IPv4 LANs, through DHCP, we get only IP address and DNS information,
although being able to get other important parameters.
Therefore, if ND provides IPv6 hosts with DNS information as well as IPv6 prefix,
the hosts will nearly have no inconvenience in basic IPv6 networking.
In the environment where there is need to autoconfigure more other parameters, 
such as NTP server and Web-proxy, DHCPv6 can be used well.

IMHO, the development of RA-based DNS Discovery belongs to IPv6 wg, not DNSOP wg,
because it is the extension of IPv6 protocol, not DNS protocol.
However, in my memory, Thomas Narten, Internet Area Director, said that IPv6 DNS Discovery
should be handled in DNSOP wg.
If so, I think, the extension of IPv6 protocol for DNS Discovery can be discussed in DNSOP wg.

In conclusion, I am sure, IPv6 protocol itself needs ND-based DNS autoconfiguration.
Let the autoconfiguration of other parameters except DNS information processed by DHCPv6. 

It seems be time for related ADs and Chairs to negotiate and decide the policy for DNS discovery.
After that, we engineers will be able to develop more practical solution mechanisms according to the direction.

Thanks.

/Jaehoon Paul

------------------------------------------------------------------------------------------------

----- Original Message ----- 
From: "Bill Manning" <[email-masked]>
To: "Jaehoon Paul Jeong" <[email-masked]>
Cc: "Bill Manning" <[email-masked]>
Sent: Saturday, August 02, 2003 1:05 PM
Subject: Re: Policy of IPv6 DNS Discovery

> 
> [Charset Windows-1252 unsupported, skipping...]
> 
> I think you were trying to say something, but it renders
> as a non-supported character set.  Sorry about that.
> 
> 
> --bill
> Opinions expressed may not even be mine by the time you read them, and
> certainly don't reflect those of any other entity (legal or otherwise).
> 

#----------------------------------------------------------------------
# To unsubscribe, send a message to <[email-masked]>.

---

From: Bill Manning <[email-masked]>
Date: Sat, 2 Aug 2003 09:09:43 -0700 (PDT)

% Hi Bill,
% 
% My mail is as follows;
% Maybe, you can see mine, now.
% 
% /Jaehoon Paul
% 
% -----------------------------------------------------------------------------------------------
% Hello all,
% 
% Thanks for your insightful suggestions and comments.
% For DNS Discovery, we have been discussing much.
% IMHO, every technology has its own application domain.

	In the case of Internet, I beg to differ.

% Until now, several propositions for DNS Discovery have been suggested and discussed.
% A unique solution can not cover every environment, I think.
% DHCPv6, RA, Anycast and Multicast approaches have their own domain.

	DNS, as a unique solution, covers all the environments
	you have currently specified, so perhaps more thought it 
	needed.  In any case...
	If you take this approach, you must also indicate which
	method takes priority when "domains" overlap.
	This also means you must define all possible domains.
	DHCPv4, DHCPv6, RA, Anycast, Multicast, LLMNR, TBDS,...
	how many are there?

% In conclusion, I am sure, IPv6 protocol itself needs ND-based DNS autoconfiguration.
% Let the autoconfiguration of other parameters except DNS information processed by DHCPv6. 

	It remains unclear to me how ND-based DNS autoconfiguration
	will be able decern the DNS admins policy profile and use
	ND-based DNS autoconfiguration accordingly.

% /Jaehoon Paul
% 
% ----- Original Message ----- 
% From: "Bill Manning" <[email-masked]>
% To: "Jaehoon Paul Jeong" <[email-masked]>
% Cc: "Bill Manning" <[email-masked]>
% Sent: Saturday, August 02, 2003 1:05 PM
% Subject: Re: Policy of IPv6 DNS Discovery
% 
% 
% > 
% > [Charset Windows-1252 unsupported, skipping...]
% > 
% > I think you were trying to say something, but it renders
% > as a non-supported character set.  Sorry about that.
% > 
% > --bill

--bill