Subject: [dnsop] req for adoption: draft-andrews-full-service-resolvers

From: Peter Koch <[email-masked]>
Date: Wed, 14 Jun 2006 18:49:41 +0200

Dear WG,

we have a request for adopting draft-andrews-full-service-resolvers (currently
in version -02) as a dnsop wg item. The Dallas minutes say we have 10
volunteers for review, the current author would act as document editor.
There was discussion in Dallas and on the list and the content and direction
of the draft looks stable, with some editorial work still to do. Given that
we have shortened our queue of open items, the document fits within our
charter and the amount of remaining work is moderate, I'd like to ask
for consent for adoption of this draft as a wg document.

If you disagree, please speak up asap, so we could have the draft as a -00
submitted by June 19th. With the reasoning above, I'll take silence as consent.

Thanks & apologies for the short notice!

-Peter
.
dnsop resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/dnsop.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/dnsop/index.html

---

From: Edward Lewis <[email-masked]>
Date: Wed, 14 Jun 2006 14:48:19 -0400

Looking at 
http://www.ietf.org/internet-drafts/draft-andrews-full-service-resolvers-02.txt

We need a much shorter title, especially as this is not about "full 
service" resolvers.  If we keep calling it that, it'll suffer the 
same fate as the draft we used to call in-addr-requred.

How about "Locally-served Zones" or some such name?

This draft affirms the role of split-DNS in operations.  (In that it says:
   "If using empty zones one should not use the same NS and SOA records
    as used on the public Internet servers as that will make it harder to
    detect leakage from the public Internet servers.")

I recall resistance to split-brain being voiced at this meeting: 
http://www3.ietf.org/proceedings/05mar/dnsop.html (which *still* does 
not have the minutes attached to it as appears here: 
http://darkwing.uoregon.edu/~llynch/dnsop/msg03378.html)

          draft-durand-dnsop-dont-publish-00.txt
              goals: restart talk on what should be published or
	     not in DNS. issues: ambiguity, unreachability, new
	     v6 stuff: transition phase, globally unique local
	     addrs recommendation: when publishing multiple
	     addresses take care to not publish at the same time
	     addrs designed to be globally unique and addrs that
	     are not

...
              keith moore: if you're seeing limited scope
	     addresses published in DNS then that's a sign of
	     other problems and it is not DNS' task to solve
	     these
              john schnizlein: split-DNS is ...
              rob austein: I declare split-DNS out of topic for
	     this one

              rob austein: i hear interest in this draft

(...the draft died of "no comments" at the Vancouver or Dallas meeting...)

and later:

          draft-krishnaswamy-dnsop-split-view...

              suresh krishnaswamy: documents a way to config
	     split-DNS with DNSSEC. This document is not about
	     information hiding. split-views and DNSSEC may seem
	     mutually conflicting.

              keith moore: example doesn't show apps
              rob austein: were not here to debate split dns in
	     general, this is limited to DNSSEC applied to split
	     DNS given that split DNS will be used regardless
              ed lewis: split-view is essential, good to get it
	     documented
              sam weiler: disagree with keith
              bill manning: advance it. the philosophical issues
	     are not a topic for this WG
              russ mundy: important to get modern documents on how
	     to get DNSSEC working in present environments

If we embrace this document, we embrace split-DNS.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis                                                +1-571-434-5468
NeuStar

Nothin' more exciting than going to the printer to watch the toner drain...