Subject: [DNSOP] /etc/hosts: "::1 localhost" or "::1 ip6-localhost" (or both and also make ip4-localhost) ?

From: Jeroen Massar <[email-masked]>
Date: Fri, 08 Jun 2007 08:14:17 +0100

(hmm not really a DNS thing but where else to put it ;)

Hi,

I've noted that on a variety of machines /etc/hosts finally do get
pre-configured with "::1 ip6-localhost", but should this not be "::1
localhost", so that any daemon doing getaddrinfo("localhost",...) and
binding to all the sockets that that produces correctly listens on both
127.0.0.1 and ::1 ?

I've grepped my drafts/rfc archives but, except for 4038 which shows a
"localhost. AAAA ::1 + A 127.0.0.1", I could not find a document
actually literally stating that "localhost" should both be for IPv6 and
IPv4. Also I can't seem to find any reference on ip6-localhost.

Any ideas?

Greets,
 Jeroen

_______________________________________________
DNSOP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dnsop

---

From: Mark Andrews <[email-masked]>
Date: Fri, 08 Jun 2007 17:29:38 +1000

> IPv4. Also I can't seem to find any reference on ip6-localhost.

	I suspect someone is worried about a application breaking if
	it tries to reach ::1.

	Mind you for the general health of the Internet such breakages
	should be found sooner rather than later.

> Any ideas?
> 
> Greets,
>  Jeroen
> 
> 
> --------------enigC23EBF9091E6CAA3F80B90F5
> Content-Type: application/pgp-signature; name="signature.asc"
> Content-Description: OpenPGP digital signature
> Content-Disposition: attachment; filename="signature.asc"
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.7 (MingW32)
> Comment: Jeroen Massar / http://unfix.org/~jeroen/
> 
> iHUEARECADUFAkZpAdAuFIAAAAAAFQAQcGthLWFkZHJlc3NAZ251cGcub3JnamVy
> b2VuQHVuZml4Lm9yZwAKCRApqihSMz58I3nJAKC0UAmMUDHKxOipIvaDCpjUX/z7
> +wCfbtEqN4g3576U64ph8xSD7sqdxL8=
> =pgSz
> -----END PGP SIGNATURE-----
> 
> --------------enigC23EBF9091E6CAA3F80B90F5--
> 
> 
> --===============0441596507==
> Content-Type: text/plain; charset="us-ascii"
> MIME-Version: 1.0
> Content-Transfer-Encoding: 7bit
> Content-Disposition: inline
> 
> --===============0441596507==--
> 
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Mark Andrews <[email-masked]>
Date: Fri, 08 Jun 2007 17:29:38 +1000

---

From: Antonio Querubin <[email-masked]>
Date: Thu, 7 Jun 2007 23:15:32 -1000 (HST)

> binding to all the sockets that that produces correctly listens on both

For consistency it should really have localhost defined and ip6-localhost 
be optional.  However, the distinction is not likely to be visible to most 
end users anyway so it shouldn't matter too much.  Anyone configuring an 
app to bind to 'localhost' explicitly should probably already be aware of 
what their system (or local DNS) considers 'localhost' to be and whether 
the local apps that are talking to each other can do so over IPv6 vs IPv4.

---

From: Antonio Querubin <[email-masked]>
Date: Thu, 7 Jun 2007 23:15:32 -1000 (HST)