Subject: Re: [DNSOP] suggestion for 4641bis: key algorithm rollover section

From: Jelte Jansen <[email-masked]>
Date: Fri, 05 Sep 2008 18:23:19 +0200

Resending my message because of the ietf mailing list problems

- -------- Original Message --------
Subject: Re: [DNSOP] suggestion for 4641bis: key algorithm rollover section
Date: Fri, 05 Sep 2008 10:32:35 +0200
From: Jelte Jansen <[email-masked]>
To: Mark Andrews <[email-masked]>
CC: [email-masked]
References: <[email-masked]>

Mark Andrews wrote:
>> 	No.  The DS / published trust anchor indicates support for
>> 	the algorithm.  Just having a DNSKEY at the apex does not
>> 	indicate support for a algorithm.
>

We must be reading this part differently...

   There MUST be an RRSIG for each RRset using at least one DNSKEY of
   each algorithm in the zone apex DNSKEY RRset.  The apex DNSKEY RRset
   itself MUST be signed by each algorithm appearing in the DS RRset
   located at the delegating parent (if any).

What I'm getting from this is that the keyset at the apex must (at
least) be signed by each algorithm in the DS referral, and every rrset
in the zone must be signed by each algorithm in the apex keyset.

Jelte
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Jelte Jansen <[email-masked]>
Date: Fri, 05 Sep 2008 18:23:19 +0200

Jelte

---

From: Jelte Jansen <[email-masked]>
Date: Fri, 05 Sep 2008 18:27:37 +0200

I'll take the liberty to resend Mark's messages too;

Resending Mark's reply to Dean Anderson's message

-------- Original Message --------
Subject: Re: [DNSOP] suggestion for 4641bis: key algorithm rollover section
Date: Fri, 05 Sep 2008 09:35:43 +1000
From: Mark Andrews <[email-masked]>
To: Dean Anderson <[email-masked]>
CC: Jelte Jansen <[email-masked]>, [email-masked]

> On Thu, 4 Sep 2008, Mark Andrews wrote:
> 
> > 
> > 	It's not a issue.  You remove the DS's which have that
> > 	algorithm then once they have expired from caches you can
> > 	remove the DNSKEY.
> 
> Of course, you can replay them, resulting in a DOS.  (I'll call 
> this attack 6)

	Wait for the signatures to also expire.  The replayed DS
	RRset will then be rejected.  Pick your paranoia level.

	Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Jelte Jansen <[email-masked]>
Date: Fri, 05 Sep 2008 18:27:37 +0200

-------- Original Message --------
Subject: Re: [DNSOP] suggestion for 4641bis: key algorithm rollover section
Date: Fri, 05 Sep 2008 09:35:43 +1000
From: Mark Andrews <[email-masked]>
To: Dean Anderson <[email-masked]>
CC: Jelte Jansen <[email-masked]>, [email-masked]

	Mark

---

From: Jelte Jansen <[email-masked]>
Date: Fri, 05 Sep 2008 18:28:51 +0200

And Mark's reply to my previous message:

-------- Original Message --------
Subject: Re: [DNSOP] suggestion for 4641bis: key algorithm rollover section
Date: Fri, 05 Sep 2008 18:39:49 +1000
From: Mark Andrews <[email-masked]>
To: Jelte Jansen <[email-masked]>
CC: [email-masked]

> in the zone must be signed by each algorithm in the apex keyset.
 	which is referred to by a DS / trust anchor.

 	DNSKEY's are never referenced in isolation.  There is always
 	a DS / trust anchor which specifies which algorithms are
 	in use.

 	Mark

---

From: Jelte Jansen <[email-masked]>
Date: Fri, 05 Sep 2008 18:28:51 +0200

-------- Original Message --------
Subject: Re: [DNSOP] suggestion for 4641bis: key algorithm rollover section
Date: Fri, 05 Sep 2008 18:39:49 +1000
From: Mark Andrews <[email-masked]>
To: Jelte Jansen <[email-masked]>
CC: [email-masked]

 	Mark