Subject: [DNSOP] about Designing DNS client for ipv6

From: "venkatesh.bs" <[email-masked]>
Date: Fri, 12 Sep 2008 14:42:34 +0530

Hi ,
           I am confused in implimenting  DNS  client  for  v6 /v4(it 
should support for both), Should I send AAAA records or A records for 
any request , is  it possible in a sigle qury to resolve(v4/v6) address.

Thanks and Regards
Venkatesh.

_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: "venkatesh.bs" <[email-masked]>
Date: Fri, 12 Sep 2008 14:42:34 +0530

Hi ,

Thanks and Regards
Venkatesh.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 12 Sep 2008 11:20:58 +0200

On Fri, Sep 12, 2008 at 02:42:34PM +0530,
 venkatesh.bs <[email-masked]> wrote 
 a message of 18 lines which said:

> I am confused in implimenting DNS client for v6 /v4(it should
> support for both), Should I send AAAA records or A records for any
> request ,

Yes. See RFCs 3364, 4074 and 4472 for some warnings.

> is  it possible in a sigle qury to resolve(v4/v6) address.

Unfortunately, no.

There have been some attempts to standardize request types for both
(the ADDR request type) but none went far enough.

Warning: using the request type ANY is a bad idea (see
<https://savannah.nongnu.org/bugs/?13035> for an example).
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 12 Sep 2008 11:20:58 +0200

Unfortunately, no.