Subject: [DNSOP] draft-dickinson-dnsop-nameserver-control-00

From: John Dickinson <[email-masked]>
Date: Mon, 27 Oct 2008 17:38:02 +0000

Hi,

Stephen Morris, Roy Arends and I have just submitted http://tools.ietf.org/html/draft-dickinson-dnsop-nameserver-control-00

This draft describes a design for a name server control protocol that  
addresses the requirements set out in draft-ietf-dnsop-name-server- 
management-reqs-01.txt.

John

Begin forwarded message:

> A new version of I-D, draft-dickinson-dnsop-nameserver- 
> control-00.txt has been successfuly submitted by John Dickinson and  
> posted to the IETF repository.
>
> Filename:	 draft-dickinson-dnsop-nameserver-control
> Revision:	 00
> Title:		 Design for a Nameserver Control Protocol
> Creation_date:	 2008-10-27
> WG ID:		 Independent Submission
> Number_of_pages: 39
>
> Abstract:
> This document presents a design for a nameserver control protocol
> (NSCP).
>
> A common data model for describing the configuration and operation of
> a basic, but usable, generic name server is defined.  This is
> expressed in a formal modeling language (YANG) and can be used as the
> basis of a set of NETCONF operations and capabilities.
>
> The data model described is extensible and will allow for the
> creation of additional capabilities, ensuring that the protocol can
> support all the features of a name server.
>
>
>
> The IETF Secretariat.
>
>

_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: John Dickinson <[email-masked]>
Date: Mon, 27 Oct 2008 17:38:02 +0000

Hi,

John

---

From: "TS Glassey" <[email-masked]>
Date: Thu, 27 Nov 2008 11:01:13 -0800

Yeah and like the other DNSSEC I-D's I dfound numerous things in it that 
would violate the controls put in place by US Patent 6,370,629 of which I am 
one of the two owners and controlling parties to that IP.

This was posted originally with IPR201 but evidently no one bothers to check 
and see what IPR Notices are in place BEFORE they start to publish work here 
in the IETF that is already patent controlled, and for which the IETF has 
been told in no uncertain terms that the IETF will NOT be granted use of 
this IP under any terms at this time.

Todd Glassey
Patent Rights Owner - US 6370629
----- Original Message ----- 
From: "John Dickinson" <[email-masked]>
To: <[email-masked]>
Sent: Monday, October 27, 2008 9:38 AM
Subject: [DNSOP] draft-dickinson-dnsop-nameserver-control-00

> Hi,
>
> Stephen Morris, Roy Arends and I have just submitted 
> http://tools.ietf.org/html/draft-dickinson-dnsop-nameserver-control-00
>

--------------------------------------------------------------------------------

Internal Virus Database is out of date.
Checked by AVG - http://www.avg.com
Version: 8.0.175 / Virus Database: 270.8.4/1749 - Release Date: 10/27/2008 
7:57 AM

---

From: "TS Glassey" <[email-masked]>
Date: Thu, 27 Nov 2008 11:01:13 -0800

Todd Glassey

---

From: bert hubert <[email-masked]>
Date: Mon, 27 Oct 2008 20:11:10 +0100

On Thu, Nov 27, 2008 at 11:01:13AM -0800, TS Glassey wrote:
> would violate the controls put in place by US Patent 6,370,629 of which I 
> am one of the two owners and controlling parties to that IP.

Please start litigating. I've looked at this patent and the other one you
mentioned in the context of DNSSEC, and based on earlier discussions with a
patent attorney, your claims don't look like they would stand up at least in
Dutch courts.

draft-dickinson-dnsop-nameserver-control does not even mention a
geographical location, nor does it mention anything that is time controlled.

If I recall correctly, making bogus IPR claims is a punishable offense at
least in Germany - SCO suffered that fate.

So either litigate or refrain from intimidating us.

	Bert

-- 
http://www.PowerDNS.com      Open source, database driven DNS Software 
http://netherlabs.nl              Open and Closed source services
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: bert hubert <[email-masked]>
Date: Mon, 27 Oct 2008 20:11:10 +0100

Bert

---

From: "TS Glassey" <[email-masked]>
Date: Thu, 27 Nov 2008 12:26:39 -0800

----- Original Message ----- 
From: "bert hubert" <[email-masked]>
To: "TS Glassey" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, October 27, 2008 11:11 AM
Subject: Re: [DNSOP] draft-dickinson-dnsop-nameserver-control-00

> patent attorney, your claims don't look like they would stand up at least 

Burt - as to litigating, lets get the general counsel of NETLABS into this 
convo RIGHT NOW because that is exactly my intent sir.

> So either litigate or refrain from intimidating us.

Be advised that the IETF process REQUIRES ME TO NOTICE THE IETF EACH TIME 
SOMETHING IS PUBLISHED WHICH INFRINGES ON THE PATENT, per the direct words 
of BCP78 and its supporting documents. So if you object take it up with the 
IPR WG and the IESG for making it mandatory for me to notify the IETF each 
time one of you does something to infringe on our patent rights.

---

From: "TS Glassey" <[email-masked]>
Date: Thu, 27 Nov 2008 12:26:39 -0800

---

From: bert hubert <[email-masked]>
Date: Mon, 27 Oct 2008 20:41:55 +0100

> convo RIGHT NOW because that is exactly my intent sir.

I suggest you calm down - at which point you might realise I'm not a party
in this. If you want to serve any papers on me, you'll find my address on
http://netherlabs.nl

	Bert

---

From: bert hubert <[email-masked]>
Date: Mon, 27 Oct 2008 20:41:55 +0100

Bert

---

From: Paul Wouters <[email-masked]>
Date: Mon, 27 Oct 2008 15:48:43 -0400 (EDT)

> patent attorney, your claims don't look like they would stand up at least in

I agree. The patent is irrelevant. One example of prior art I can come up
with already is Netscape restricting its SSL download in the 90's to US
citizens only, based on geogrpahical locations of IP addresses, back in
the early day before the Wassenaar Agreement relaxed US export controls,
a decade before the filing of this patent in 2002.

And last I looked, my DNSSEC servers and clients don't have a GPS, the only
part of the "invention" that might possible hold (IANAL)

But the Patent Holder seems to think using a physical key to lock out everyone
"geospatially located outside my house" seems to violate their patent.

I have no idea how DNSSEC possibly relates to this.

Paul

---

From: Paul Wouters <[email-masked]>
Date: Mon, 27 Oct 2008 15:48:43 -0400 (EDT)

Paul

---

From: Paul Wouters <[email-masked]>
Date: Mon, 27 Oct 2008 15:50:10 -0400 (EDT)

On Thu, 27 Nov 2008, TS Glassey wrote:

> SOMETHING IS PUBLISHED WHICH INFRINGES ON THE PATENT, per the direct words of

Is that why you are writing emails a month into the future?

Paul

---

From: Paul Wouters <[email-masked]>
Date: Mon, 27 Oct 2008 15:50:10 -0400 (EDT)

Paul

---

From: "TS Glassey" <[email-masked]>
Date: Mon, 27 Oct 2008 12:53:43 -0700

No that is because of microsoft's new security fixes. But since there is no 
time-stamping process used to insure the integrity of the IETF's posting it 
seems that you folks dont want anyone who is constrained by the IETF's MUST 
DISCLOSE PATENT CONTROLS to do that.

If you did then you would already know that this patent controls the use of 
a network-location as a crypto element of entitlement or authentication.

Todd Glassey

---

From: "TS Glassey" <[email-masked]>
Date: Mon, 27 Oct 2008 12:53:43 -0700

Todd Glassey

---

From: "TS Glassey" <[email-masked]>
Date: Mon, 27 Oct 2008 12:55:15 -0700

You know Bert, the IETF requires I formally disclose this same info each 
time a new infringing work is published, so take it up with them if you have 
an issue.

Todd Glassey

----- Original Message ----- 
From: "bert hubert" <[email-masked]>
To: "TS Glassey" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Monday, October 27, 2008 12:41 PM
Subject: Re: [DNSOP] draft-dickinson-dnsop-nameserver-control-00

>> >mentioned in the context of DNSSEC, and based on earlier discussions 
>> >with
>> >a
>> >patent attorney, your claims don't look like they would stand up at 
>> >least
>> >in
>> >Dutch courts.
>>

---

From: "TS Glassey" <[email-masked]>
Date: Mon, 27 Oct 2008 12:55:15 -0700

Todd Glassey

---

From: "TS Glassey" <[email-masked]>
Date: Mon, 27 Oct 2008 16:21:38 -0700

----- Original Message ----- 
From: "Paul Wouters" <[email-masked]>
To: "bert hubert" <[email-masked]>
Cc: <[email-masked]>; "TS Glassey" <[email-masked]>
Sent: Monday, October 27, 2008 12:48 PM
Subject: Re: [DNSOP] draft-dickinson-dnsop-nameserver-control-00

>> patFrom [email-masked]  Mon Oct 27 16:21:13 2008
From: "TS Glassey" <[email-masked]>
To: "Paul Wouters" <[email-masked]>,
	"bert hubert" <[email-masked]>
Date: Mon, 27 Oct 2008 16:21:38 -0700
Cc: [email-masked]
Subject: Re: [DNSOP] draft-dickinson-dnsop-nameserver-control-00
Sender: [email-masked]

----- Original Message ----- 
From: "Paul Wouters" <[email-masked]>
To: "bert hubert" <[email-masked]>
Cc: <[email-masked]>; "TS Glassey" <[email-masked]>
Sent: Monday, October 27, 2008 12:48 PM
Subject: Re: [DNSOP] draft-dickinson-dnsop-nameserver-control-00

>> pent attorney, your claims don't look like they would stand up at least 
>> in
>> Dutch courts.
>
> I agree. The patent is irrelevant.

Then you personally are assuming all professional liability for this working 
group if you are wrong since you just formally advised everyone on this list 
to ignore the patent's coverage. Nice move... since you literally are not 
qualified to tell people that, whereas  I am allowed to assert that these 
technologies are protected by our patent as the patent's protector. The ONLY 
person who can formally say otherwise by the way is a lawyer.

> One example of prior art I can come up

1)    The SSL restrictions comes from a single product which accomplished 
this process.  The SSL process is a simple tool which provides modular usage 
of itself as a tool, based on the key/pki model used.

By the way Paul -  I am negotiating with Network Solutions on their 
ownership of the US Navy's SSL patent as well.

2) The controlling access, patent is a derivative of an already filed patent 
and was originally filed in 1999 and issued in 2002 not filed in 2002 as you 
mistakenly represented here. The thing that ties it all together is the 
location value being asserted through the inclusion of the location-tool 
(the GPS reciever).

> part of the "invention" that might possible hold (IANAL).

They dont need to - they just need to have location-broadcasts which use 
signed location data.

> I have no idea how DNSSEC possibly relates to this.

Which further document's why its improper for you Paul to be giving people 
legal advice here. The US Government issued the patent so they and six other 
jurisdictions thought it was OK and there wasn't prior art preventing its 
implementation.

And yes Paul I can and will document how the patent pertains to DNSSEC and 
any number of other processes which now use secured-location information as 
part of their keying process for administering their practical security 
policy.

atent attorney, your claims don't look like they would stand up at least 
>> in
>> Dutch courts.
>
> I agree. The patent is irrelevant.

Then you personally are assuming all professional liability for this working 
group if you are wrong since you just formally advised everyone on this list 
to ignore the patent's coverage. Nice move... since you literally are not 
qualified to tell people that, whereas  I am allowed to assert that these 
technologies are protected by our patent as the patent's protector. The ONLY 
person who can formally say otherwise by the way is a lawyer.

> One example of prior art I can come up

1)    The SSL restrictions comes from a single product which accomplished 
this process.  The SSL process is a simple tool which provides modular usage 
of itself as a tool, based on the key/pki model used.

By the way Paul -  I am negotiating with Network Solutions on their 
ownership of the US Navy's SSL patent as well.

2) The controlling access, patent is a derivative of an already filed patent 
and was originally filed in 1999 and issued in 2002 not filed in 2002 as you 
mistakenly represented here. The thing that ties it all together is the 
location value being asserted through the inclusion of the location-tool 
(the GPS reciever).

> part of the "invention" that might possible hold (IANAL).

They dont need to - they just need to have location-broadcasts which use 
signed location data.

> I have no idea how DNSSEC possibly relates to this.

Which further document's why its improper for you Paul to be giving people 
legal advice here. The US Government issued the patent so they and six other 
jurisdictions thought it was OK and there wasn't prior art preventing its 
implementation.

And yes Paul I can and will document how the patent pertains to DNSSEC and 
any number of other processes which now use secured-location information as 
part of their keying process for administering their practical security 
policy.

---

From: "TS Glassey" <[email-masked]>
Date: Mon, 27 Oct 2008 16:24:38 -0700

No Paul that is an out and out LIE - I made that call and what I asked for 
was the legal department and whoever answered the phone refused to provide 
information as to who that was unless I justified the conversation. I was 
told I would have to 'specify which XCelera Products and processes' before I 
was to be transfered to a legal representative of the company without the 
individual identifying themselves.

Be advised that your General Counsel will be formally hearing from me 
tomorrow and we will ESCALATE THIS MATTER.

Todd Glassey

----- Original Message ----- 
From: "Paul Wouters" <[email-masked]>
To: "bert hubert" <[email-masked]>
Cc: <[email-masked]>; "TS Glassey" <[email-masked]>
Sent: Monday, October 27, 2008 4:10 PM
Subject: Rude legalese phone call, possibly related to "patent infringement"

> On Mon, 27 Oct 2008, Paul Wouters wrote:
>
>
> Just to inform the IETF community,
>
> Xelerance received a call from a person who refused to identify himself,
> who threatened with law suits and would only say it was a matter of
> "patent infringement". This person refused to reveal his name, his client
> or the product of Xelerance that was deemed to be infringing. It is most
> likely this person tried to pretend he was a lawyer, without actually
> saying he wasn't.
>
> He was informed to conduct further communication in writing.
>
> I will keep the IETF informed if this indeeds relates to DNSSEC's supposed
> violation of geospatial cryptography.
>
> Paul
>
>>> with a

No virus found in this incoming message.
Checked by AVG - http://www.avg.com
Version: 8.0.175 / Virus Database: 270.8.4/1750 - Release Date: 10/27/2008 
6:14 PM

---

From: "TS Glassey" <[email-masked]>
Date: Mon, 27 Oct 2008 16:24:38 -0700

Todd Glassey

---

From: Paul Wouters <[email-masked]>
Date: Mon, 27 Oct 2008 19:10:47 -0400 (EDT)

Paul

---

From: Paul Wouters <[email-masked]>
Date: Mon, 27 Oct 2008 19:10:47 -0400 (EDT)

Paul

---

From: Rob Austein <[email-masked]>
Date: Mon, 27 Oct 2008 19:29:10 -0400

<hat wg-co-chair=on>

  Ok, that's enough.

  Todd, you have made your point that you believe you have IPR in this
  space.  Noted.

  Now everyone please stop this, immediately.  This is not a forum for
  legal debates, let alone insults, and claims that Todd might or
  might not have against various implementors are between him and the
  implementors, to be settled elsewhere.

  Stop, now.

</hat>

---

From: Rob Austein <[email-masked]>
Date: Mon, 27 Oct 2008 19:29:10 -0400

<hat wg-co-chair=on>

  Ok, that's enough.

  Stop, now.

</hat>

---

From: Paul Wouters <[email-masked]>
Date: Mon, 27 Oct 2008 20:01:23 -0400 (EDT)

On Mon, 27 Oct 2008, TS Glassey wrote:

> to ignore the patent's coverage.

It is interesting that you claim such far reaching affects of statements made
on mailinglists, especially seeing that in 2003 you yourself claimed:

 	 know that I am not a lawyer and thus not qualified to advise
 	 prospective implementors about the implications of this court
 	 decision,

You can't have the cake and eat it too Todd.

Bullying Xelerance by phone is not going to make a difference (Google
confirmed the ranting call was made my a phone number associated with a
"Todd Glassley")[*]

> legal advice here.

Indeed. If I were to be giving legal advise, I would surely be charging $600/hour
for that, instead of giving it away on public mailing lists.

> The US Government issued the patent so they and six other 

I'm a Dutch citizen working for a Canadian company. There are limits
to what Canadians (who don't do software patents) allow to be jerked
around with by the US. Remember RIM?  I can see a connectioFrom [email-masked]  Mon Oct 27 16:57:05 2008
Date: Mon, 27 Oct 2008 20:01:23 -0400 (EDT)
From: Paul Wouters <[email-masked]>
To: TS Glassey <[email-masked]>
Cc: [email-masked], bert hubert <[email-masked]>
Subject: Re: [DNSOP] draft-dickinson-dnsop-nameserver-control-00
Sender: [email-masked]

On Mon, 27 Oct 2008, TS Glassey wrote:

> to ignore the patent's coverage.

It is interesting that you claim such far reaching affects of statements made
on mailinglists, especially seeing that in 2003 you yourself claimed:

 	 know that I am not a lawyer and thus not qualified to advise
 	 prospective implementors about the implications of this court
 	 decision,

You can't have the cake and eat it too Todd.

Bullying Xelerance by phone is not going to make a difference (Google
confirmed the ranting call was made my a phone number associated with a
"Todd Glassley")[*]

> legal advice here.

Indeed. If I were to be giving legal advise, I would surely be charging $600/hour
for that, instead of giving it away on public mailing lists.

> The US Government issued the patent so they and six other 

I'm a Dutch citizen working for a Canadian company. There are limits
to what Canadians (who don't do software patents) allow to be jerked
around with by the US. Remember RIM?  I can see a connection between RIM
disconnecting DC from coverage, and the USG's role into removing DNSSEC
from .gov and .mil. It will be interesting indeed.

> part of their keying process for administering their practical security 

Excellent. I shall await that information. Untill then, I'm not spending more
time on this matter.

Paul
[*] Either that, or by a comedian forging caller-id, though the latter seems
     less likely.
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

n between RIM
disconnecting DC from coverage, and the USG's role into removing DNSSEC
from .gov and .mil. It will be interesting indeed.

> part of their keying process for administering their practical security 

Excellent. I shall await that information. Untill then, I'm not spending more
time on this matter.

Paul
[*] Either that, or by a comedian forging caller-id, though the latter seems
     less likely.
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Jim Reid <[email-masked]>
Date: Tue, 28 Oct 2008 05:53:32 +0000

On Oct 27, 2008, at 23:21, TS Glassey wrote:

> Which further document's why its improper for you Paul to be giving  
> people legal advice here. The US Government issued the patent so  
> they and six other jurisdictions thought it was OK and there wasn't  
> prior art preventing its implementation.

People get patents for all sorts of stupid nonsense. That doesn't mean  
their patent stands up or is in any way enforceable, even in the  
jurisdiction where the patent was granted. That's something for the  
patent lawyers and the courts to decide. There's no point debating  
this any further here. Please take this childish "my patent's better  
than your internet draft" name-calling somewhere else.
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Jim Reid <[email-masked]>
Date: Tue, 28 Oct 2008 05:53:32 +0000

---

From: Florian Weimer <[email-masked]>
Date: Wed, 29 Oct 2008 21:56:54 +0100

* TS Glassey:

> Be advised that the IETF process REQUIRES ME TO NOTICE THE IETF EACH
> TIME SOMETHING IS PUBLISHED WHICH INFRINGES ON THE PATENT, per the
> direct words of BCP78 and its supporting documents. So if you object
> take it up with the IPR WG and the IESG for making it mandatory for me
> to notify the IETF each time one of you does something to infringe on
> our patent rights.

Out of curiosity, why are you interested in contributing to the IETF,
if you don't want to contribute anything you deem of value?

The disclosure requirements only apply to IETF contributors.  So if
you stop contributing to the IETF, those requirements disappear.
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Florian Weimer <[email-masked]>
Date: Wed, 29 Oct 2008 21:56:54 +0100

---

From: "TS Glassey" <[email-masked]>
Date: Wed, 29 Oct 2008 14:03:56 -0700

Florian
If you are asking me "why I am participating if I wont 'Give the IETF' my 
IP", the answer is I am formally protecting that IP and obeying the 
requirements that I inform the IETF of each new IPR infraction per the 
notice policy in place today.

Todd Glassey

----- Original Message ----- 
From: "Florian Weimer" <[email-masked]>
To: "TS Glassey" <[email-masked]>
Cc: "bert hubert" <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Wednesday, October 29, 2008 1:56 PM
Subject: Re: [DNSOP] draft-dickinson-dnsop-nameserver-control-00

No virus found in this incoming message.
Checked by AVG - http://www.avg.com
Version: 8.0.175 / Virus Database: 270.8.4/1754 - Release Date: 10/29/2008 
7:45 AM

---

From: "TS Glassey" <[email-masked]>
Date: Wed, 29 Oct 2008 14:03:56 -0700

Florian

Todd Glassey

----- Original Message ----- 
From: "Florian Weimer" <[email-masked]>
To: "TS Glassey" <[email-masked]>
Cc: "bert hubert" <[email-masked]>; <[email-masked]>; 
<[email-masked]>

---

From: Florian Weimer <[email-masked]>
Date: Wed, 29 Oct 2008 22:18:46 +0100

* TS Glassey:

> Florian
> If you are asking me "why I am participating if I wont 'Give the IETF'
> my IP", the answer is I am formally protecting that IP and obeying the

This requirement is only created by your continued contributions to
the IETF.  The IETF hasn't got any power to force you to do anything,
as long as you leave it alone.  Once you start contributing in some
way or other, it's different.

So simply stop contributing.  Problem solved.
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Florian Weimer <[email-masked]>
Date: Wed, 29 Oct 2008 22:18:46 +0100

---

From: "TS Glassey" <[email-masked]>
Date: Wed, 29 Oct 2008 14:25:21 -0700

No Florian - the requirement is created by the IETF's continued violation of 
the IPR space that the patent creates period. Once people stop filing 
infringing works with the IETF and violating my IP Rights then this matter 
will be closed right?

Todd Glassey
----- Original Message ----- 
From: "Florian Weimer" <[email-masked]>
To: "TS Glassey" <[email-masked]>
Cc: "bert hubert" <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Wednesday, October 29, 2008 2:18 PM
Subject: Re: [DNSOP] draft-dickinson-dnsop-nameserver-control-00

---

From: "TS Glassey" <[email-masked]>
Date: Wed, 29 Oct 2008 14:25:21 -0700

Todd Glassey
----- Original Message ----- 
From: "Florian Weimer" <[email-masked]>
To: "TS Glassey" <[email-masked]>
Cc: "bert hubert" <[email-masked]>; <[email-masked]>; 
<[email-masked]>

---

From: Peter Koch <[email-masked]>
Date: Thu, 30 Oct 2008 06:40:51 +0100

Todd, Florian, All,

On Wed, Oct 29, 2008 at 02:25:21PM -0700, TS Glassey wrote:
> No Florian - the requirement is created by the IETF's continued violation 
> of the IPR space that the patent creates period. Once people stop filing 

I fail to see how this discussion could be appropriately continued on the
DNSOP WG's mailing list.  Please reread Rob's earlier note
<http://www.ietf.org/mail-archive/web/dnsop/current/msg06818.html>
and take this off-line.

-Peter [co-chair hat on]

---

From: Peter Koch <[email-masked]>
Date: Thu, 30 Oct 2008 06:40:51 +0100

Todd, Florian, All,

-Peter [co-chair hat on]