Subject: [DNSOP] Potential root impact of draft-wing-behave-learn-prefix-00

From: Florian Weimer <[email-masked]>
Date: Thu, 20 Nov 2008 12:14:45 +0100

I came across the following in some IPv6-related draft and thought I'd
share it.

|3.1.  Using DNS to Learn IPv6 Prefix and Length
|
|   In order for an IPv6 host to determine if a NAT64 is present on its
|   network, it sends a DNS query.  Because a host doesn't always know
|   its network's default domain name, the procedure described below
|   provides a way for the host to learn it in order to authorize that
|   network's address family translator:
|
|   1.  Send a DNS AAAA query for "_aft_prefix", without a domain name.
|       If this does not return an IPv6 address it means a address family
|       translator is not present and processing MUST stop.

[...]

|   3.  If validation of this information is not necessary, then:
|
|       a.  Send a DNS TXT query for "_aft_prefix", without the domain
|           name, to learn the number of bits of the prefix.
|

[...]

|      Discussion:  without a domain name, it is unavoidable that root
|      nameservers will see this query.  Need to think about ways to
|      reduce the effect of those queries (e.g., make them authoritative
|      and return all 0's which will get cached).

So they are aware that this is broken.  Let's hope that this type of
service discovery through a fraction DNS root doesn't make its way
into the final standard.
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Florian Weimer <[email-masked]>
Date: Thu, 20 Nov 2008 14:02:32 +0100

> 	would they complain if the roots actually provided an authoritative
> 	answer (other than NXDOMAIN) at some point in the future?

It's mentioned in the draft (returning an AAAA of all-zeros).  But
given how introducing .local fared in the ICANN/IANA and IETF
processes, I don't think this is going to work.
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Florian Weimer <[email-masked]>
Date: Thu, 20 Nov 2008 14:02:32 +0100

---

From: Ted Lemon <[email-masked]>
Date: Thu, 20 Nov 2008 09:01:33 -0600

> service discovery through a fraction DNS root doesn't make its way

Use MDNS?

---

From: Ted Lemon <[email-masked]>
Date: Thu, 20 Nov 2008 09:01:33 -0600

Use MDNS?

---

From: [email-masked]
Date: Thu, 20 Nov 2008 12:44:55 +0000

--bill

---

From: [email-masked]
Date: Thu, 20 Nov 2008 12:44:55 +0000

--bill

---

From: Francis Dupont <[email-masked]>
Date: Thu, 20 Nov 2008 17:22:25 +0100

In your previous mail you wrote:

=> I agree but what you propose to do? There will be a double session
of behave WG tomorrow afternoon but this draft (which is not a WG item)
is not in the agenda, so IMHO it is not useful to worry behave chairs.
Perhaps we should only say the document should not become a WG item
if the defect is not repaired first (i.e., get it killed or fixed)?

Thanks

[email-masked]
_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Francis Dupont <[email-masked]>
Date: Thu, 20 Nov 2008 17:22:25 +0100

Thanks

---

From: John Schnizlein <[email-masked]>
Date: Thu, 20 Nov 2008 10:27:10 -0600

Today's Behave agenda includes DNS.

> Behave AGENDA
> SESSION TWO
>  THURSDAY, 09:00-11:30
> ...
>  9:55  NAT64                                           (Marcelo  
> Bagnulo, 25)
>        draft-bagnulo-behave-nat64
>
> 10:20  DNS64                                           (Marcelo  
> Bagnulo, 20)
>        draft-bagnulo-behave-dns64

---

From: John Schnizlein <[email-masked]>
Date: Thu, 20 Nov 2008 10:27:10 -0600