Subject: [DNSOP] summary of the discussion of draft-yao-dnsop-idntld-implementation-01.txt

From: "YAO Jiankang" <[email-masked]>
Date: Mon, 9 Nov 2009 08:57:18 +0800

Dear all,

      the 01 version of draft (draft-yao-dnsop-idntld-implementation-01.txt)
introduces the problem of IDN TLD variants and 4 possible solutions to this problem:
1. put the dname into the root directly for the IDN TLD variant
2. Put the NS into the root for IDN TLD variant and apply the DNAME to All names in the Apex of delegated IDN TLD variant zone.
   there has only one DNAME record in the Apex of delegated IDN TLD variant zone in the form of "IDN TLD variant DNAME original IDN TLD".
3. Put the NS into the root for IDN TLD variant and apply the DNAME to some names which want to be dnamed.
4. Put the NS into the root for IDN TLD variant and apply the NS to some names which want to use NS.
this draft also introduces some policies related to the above solutions.

through the discussion in the DNSOP wg list and DNS-OARC meeting, many think that we should separate the technical issues from the 
policy issues in this draft. Many prefer the solution 1 (put the dname into the root directly for the IDN TLD variant); many can accept the solution 2 ( Put the NS into the root for IDN TLD variant and apply the DNAME to All names in the Apex of delegated IDN TLD variant zone.).
solution 3 and solution 4 may cause the potential data inconsistencies  in the IDN TLD variant zone since the policy can not be granted in all the levels.

thanks a lot to all for the kind comments from DNSOP and DNS-oarc.

the aim of this draft is to identify the problem and find the possible solutions.

based on my understanding, the WG seems to agree the following updatings to the draft if we hope it to be an item of WG:
1. suggest to use the solution 1 and 2 and analyze these 2 solutions.
  (the results of solution 1 and 2 are almost same. both apply dname to all names)
2. remove the solution 3 and 4
3. remove most contents about the policy

Yao Jiankang
CNNIC

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 9 Nov 2009 13:52:45 +0900

On Mon, Nov 09, 2009 at 08:57:18AM +0800,
 YAO Jiankang <[email-masked]> wrote 
 a message of 128 lines which said:

> solution 3 and solution 4 may cause the potential data
> inconsistencies in the IDN TLD variant zone since the policy can not
> be granted in all the levels.

Cannot be guaranteed BY TECHNICAL MEANS. You can still use layer-8 or
layer-9 methods to get the consistency, if desired. Since IETF
provides protocols, not policies, this is not a problem for me.

> 2. remove the solution 3 and 4

-1. I would understand this removal if these solutions had a
TECHNICAL flaw. But I don't think it is the case.