Subject: [DNSOP] BIND use of compiled defaults

From: [email-masked]
Date: Tue, 8 Jun 2010 04:11:58 +0000

So ISC has allowed BIND to build with some default zones being created.  I think this
is - to coin a phrase - suboptimal and yet more code I have to rip out of the BIND distro...
but that is not the point of this missive... :)

I will use two of the automatically created zones to illistrate a potential point and then
ask a question.  Mark has "bracketed" the IPv4 space with the following two zone stanzas:

0.in-addr.arpa.

and

255.255.255.255.in-addr.arpa.

clearly the first incalulates the entire 0/8 netblock...  while the latter only incalcualtes
an IPv4 /32 or a host entry.

historically, one would define the local network with preceeding zeros, e.g.  

	0.0.0.152  with a netmask of 255.255.255.0  is the host .152 on the local network

and only the "all-zeros" /32 or 0.0.0.0/32 was special - reserved for broadcast.

and yet we see the ISC code reserving the entire /8 as an automatic zone.

If there was any consistancy here, ISC should have created the zone

255.in-addr.arpa.   or the 255/8 netblock 

but they did not.  They created a zone cut for a /32 - which (other than zome of my own
older configurations) seems to be unique.

So the question -  how common do we expect /32 delegations to become in future?

--bill

---

From: Mark Andrews <[email-masked]>
Date: Tue, 08 Jun 2010 14:52:01 +1000

> but that is not the point of this missive... :)

Your free to rip it out or you can just turn it off in named.conf
or you can change the defaults.

> 255.255.255.255.in-addr.arpa.

I've looked at the list of special purpost IPv4 addresses.  It just happens
that 0/8 and 255.255.255.255 are special purpose blocks.
 
> an IPv4 /32 or a host entry.

255/8 is not special purpose, just 255.255.255.255.

> and yet we see the ISC code reserving the entire /8 as an automatic zone.

0/8 is the local network for a /8 sized network or don't you think
nameservers should be able to handle that sized local networks.  Not
all networks are /24's.

> older configurations) seems to be unique.

The zones are consistant with RFC5735 and with operational practice.

>From IN-ADDR.ARPA or from some other zone to handle /25-/32 sized
delegations without using the techniques in RFC2317?  I know there
are people that argue that one shouldn't do RFC2317 style delegations
so for the latter I would say a lot.  For the former I don't expect
any unless we create special purpose blocks smaller than /24.

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: [email-masked]
Date: Tue, 8 Jun 2010 05:26:10 +0000

> any unless we create special purpose blocks smaller than /24.

	if you allow 255.255.255.255.in-addr.arpa.  -AS A ZONE-
	then i am much more confortable shreding a /24 into 
	255 component zones - RFC2317 is designed to do a cut
	in the in-addr.arpa space on non-octet alined boundaries 
	and since you have demo'd (other than me) the use of 
	a zone cut on octet bounds lt /24, I'm a happy camper.

--bill

---

From: Mark Andrews <[email-masked]>
Date: Tue, 08 Jun 2010 15:55:03 +1000

In message <[email-masked].>, [email-masked]
roshi.com writes:
> > > So the question -  how common do we expect /32 delegations to become in f
> utur
> > > e?
> > 

Bill, the DNS has always allowed 255.255.255.255.IN-ADDR.ARPA as a
zone or any other reverse lookup name.  Just because some people
thought that it wasn't possible didn't make it fact.  It also didn't
mean that it hadn't been done for years and years.

> 	255 component zones -

You don't need to shred it.  Just delegate the one zone.

>	RFC2317 is designed to do a cut

Mark

---

From: Tony Finch <[email-masked]>
Date: Tue, 8 Jun 2010 12:46:56 +0100

> 255.in-addr.arpa.   or the 255/8 netblock

My setup has null zones for all /8s in classes D and E ...

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
FITZROY SOLE: WESTERLY VEERING NORTHWESTERLY, THEN NORTHERLY LATER, 4 OR 5
INCREASING 5 TO 7 LATER IN WEST. MODERATE OR ROUGH. RAIN OR SHOWERS. MODERATE
OR GOOD, OCCASIONALLY POOR.