Subject: [DNSOP] Benoit Claise's No Objection on draft-ietf-dnsop-onion-tld-00: (with COMMENT)

From: "Benoit Claise" <[email-masked]>
Date: Thu, 03 Sep 2015 02:00:00 -0700

Benoit Claise has entered the following ballot position for
draft-ietf-dnsop-onion-tld-00: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-onion-tld/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Quoting Alvara, whose opinion I share: " [Personally, I believe having
the IETF assign TLDs is a very slippery slope. Of course, given rfc6761,
that boat seems to have already sailed.]

Discussing this matter with Joel, one extra argument (not in the
write-up) in favor of allocating .onion is that ICANN set this .onion TLD
aside (flagged as problematic). So there is no monetized value for it.

If/Once [tor-rendezvous] is a normative reference, do we consider github
as stable enough? What if that link disappears?

Nits/editorials (flagged by Tom Taylor's OPS directorate review)
    Section 2 item 3: s/either either/either/

---

From: hellekin <[email-masked]>
Date: Thu, 3 Sep 2015 06:56:18 -0300

On 09/03/2015 06:00 AM, Benoit Claise wrote:
> 
> If/Once [tor-rendezvous] is a normative reference, do we consider
> github as stable enough? What if that link disappears?
> 

Github is not involved at all in any of the references of the .onion
draft.  Github is an unrelated company using a domain under the .COM
TLD.

Moreover, that reference to the Git repository has a new,
"SEO-friendly" and stable URI that is consistent with other references
in the Tor project, in the form:

  https://spec.torproject.org/rend-spec

When the rendez-vous specification becomes an RFC, the same URI can be
used to point at it, making it useless to amend the .onion RFC.

==
hk

---

From: Benoit Claise <[email-masked]>
Date: Thu, 3 Sep 2015 13:11:14 +0200

Hi,
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA512
>
> draft.
My bad. Reading too fast. gitweb, not github

     [tor-address]
               Mathewson, N. and R. Dingledine, "Special Hostnames in
               Tor", September 2001,
               <https://gitweb.torproject.org/torspec.git/plain/address- 
<https://gitweb.torproject.org/torspec.git/plain/address-spec.txt>
               spec.txt <https://gitweb.torproject.org/torspec.git/plain/address-spec.txt>>.

    [tor-rendezvous]
               Mathewson, N. and R. Dingledine, "Tor Rendezvous
               Specification", April 2014,
               <https://gitweb.torproject.org/torspec.git/plain/rend- 
<https://gitweb.torproject.org/torspec.git/plain/rend-spec.txt>
               spec.txt <https://gitweb.torproject.org/torspec.git/plain/rend-spec.txt>>.

> Github is an unrelated company using a domain under the .COM
> TLD.
>
Based on your explanation, I believe we're good.

Regards, Benoit
>
> ==
> hk
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2
>
> iQJ8BAEBCgBmBQJV6Bk1XxSAAAAAAC4AKGlzc3Vlci1mcHJAbm90YXRpb25zLm9w
> ZW5wZ3AuZmlmdGhob3JzZW1hbi5uZXRFQ0IyNkIyRTNDNzEyMTc2OUEzNEM4ODU0
> ODA2QzM2M0ZDMTg5ODNEAAoJEEgGw2P8GJg9ma4P/3JVoc4cDsFrqodoZQq/4HsY
> /DRbUn/8fTwo4kx+gtvUsTylu6BEVz7mSvP/4Fg71VO+Mrc62hxOvMTJyTRhYC/z
> ye3kxFIOioFmSE4lZDm/Pcf45s6hNiEKiFqgKph4w8UGvpcgBr11hfSQy0nPYFKy
> I++KjXtBanZTvVrgvbWsBdoFhFDXA2JXDYuTJLjfmuxHm0bphmX35leXtwgsEb3Q
> q/dmfVmXCHVS9LU6qIeaMiGHZsGmn2FIDFxHEbkRGdnq00YATbS0P49bAWBJFHl+
> pRTe+oTRm9g+ezs/YW4NuCznkbq4vmdLZ77xrlgnNLhe+6wDea01tvwHnBGTOPiq
> ZISR8bIpc3miC4gI54DEQFtqIU3FamcqPDtB1S/dNBbeOfbv24VSX7G4NJxO1PlL
> aGAH+R6oGcv5ZZcqQ47xX49/3lxvdV886B9Ha+fgBBy4nQ+3ANaX9G92AHX8nNxC
> K9hxgXpwH7nFn9/vhkRES1uY4qGqyIGd4dw4s8iqFVWQiQsIfnEdqd9XsC45oXIs
> hMIEP0JZfZaB3fsTsV+BbjLG0F1jTuulVZIeDPun8fHFCD4T4NFfJKGUkt4uaor+
> 8YrBuh1+huIPcpJNAHT1txxLQTHB9u1ShWBfIL9hD75Fhl4t1/x0rg1WtsEni4ML
> EmMtYVIjCkoYmXbrFA4n
> =tesM
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
> .
>

---

From: Alec Muffett <[email-masked]>
Date: Thu, 3 Sep 2015 11:11:50 +0000

> as stable enough? What if that link disappears?

Mark Nottingham has an amended document - not submitted, but accruing amendments to address all the issues raised by IESG - at the following URL:

http://mnot.github.io/I-D/dnsop-onion-tld/draft-ietf-dnsop-onion-tld-01.txt <http://mnot.github.io/I-D/dnsop-onion-tld/draft-ietf-dnsop-onion-tld-01.txt>

…which he shared recently to this list, including a link to provide synoptic comparison of the existing draft and his amended copy.

In this new document you will see that - per recommendation - the relevant notes are being moved to a new, s5.1 “Normative” section, and (for clarity) the references to “gitweb.torproject.org" have been rewritten to reference the Tor Project’s specification site URI, spec.torproject.org <http://spec.torproject.org/>.

Any references to “gitweb.torproject.org” which you have seen in past (or currently) refer to a Tor Project internal Git repository, rather than the commercial Github company and its commercial offering.  The git software is open-source and widely instantiated. :-)

I hope this helps, and I shall be listening with interest to the call later today.  Thanks!

    - alec

—
Alec Muffett
Security Infrastructure
Facebook Engineering
London