Subject: Re: [DNSOP] I-D Action: draft-ietf-dnsop-sutld-ps-00.txt

From: Bob Harold <[email-masked]>
Date: Thu, 3 Nov 2016 11:12:27 -0400

On Mon, Oct 31, 2016 at 1:39 PM, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Domain Name System Operations of the IETF.
>
>         Title           : Special-Use Names Problem Statement
>         Authors         : Ted Lemon
>                           Ralph Droms
>                           Warren Kumari
>         Filename        : draft-ietf-dnsop-sutld-ps-00.txt
>         Pages           : 19
>         Date            : 2016-10-31
>
> Abstract:
>    The Special-Use Domain Names IANA registry policy defined in RFC 6761
>    has been shown through experience to present unanticipated
>    challenges.  This memo presents a list, intended to be comprehensive,
>    of the problems that have been identified.  In addition it reviews
>    the history of Domain Names and summarizes current IETF publications
>    and some publications from other standards organizations relating to
>    special-use domain names.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-dnsop-sutld-ps/
>
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-dnsop-sutld-ps-00
>
>
Looks good.  Some comments:

3.  Problems associated with Special-Use Domain Names

In one of the listed "problems":
      When a special-use domain name is added to the special-use domain
      names registry, not all software that processes such names will
      understand the special use of that name.  Consequently, any such
      use will result in queries for that name being sent to
      authoritative servers.  This constitutes an operational problem
      for operators of root zone authoritative name servers.

I think it should be noted that this also creates a privacy issue for some
special-use domain names.
(Not just an operational problem for operators.)

4.1.2
last paragraph:

   One point to take from this is that there is already a requirement in
   RFC6762 that when stub resolvers encounter the special label,
   '.LOCAL' at the top level of a domain name, they can only use the
   mDNS protocol be used for resolving that domain name.

Remove "be used" near the end.

-- 
Bob Harold

---

From: Ted Lemon <[email-masked]>
Date: Thu, 3 Nov 2016 12:26:30 -0400

On Nov 3, 2016, at 11:12 AM, Bob Harold <[email-masked]> wrote:
> I think it should be noted that this also creates a privacy issue for some special-use domain names.

Great comments—thanks!   Dude, you are on fire today!   :)