Subject: Re: [DNSOP] status opcode?

From: "Peter van Dijk" <[email-masked]>
Date: Wed, 09 Nov 2016 13:01:03 +0100

Hello Robert,

On 12 Oct 2016, at 21:38, Robert Edmonds wrote:

> What are status queries? Were they ever defined? Are they obsolete?

I have been unable to find a definition, and I tried quite hard earlier 
this year when a customer complained we were not handling them! Some 
VOIP equipment that shall remain unnamed needed to do ENUM queries, but 
only after a successful ‘health check’.

The health check looked like this (sorry, don’t have the pcap handy, 
just this summary):
ID 0
flags all zero except for the rcode=2
all counts zero
6 trailing NUL bytes

Once pdns_server started responding NOTIMP, instead of dropping the 
query, the equipment was happy.

Kind regards,
-- 
Peter van Dijk
PowerDNS.COM BV - https://www.powerdns.com/

---

From: Roy Arends <[email-masked]>
Date: Wed, 9 Nov 2016 13:11:46 +0000

> On 9 Nov 2016, at 12:01, Peter van Dijk <[email-masked]> wrote:
> 
> Hello Robert,
> 
> I have been unable to find a definition, and I tried quite hard earlier this year when a customer complained we were not handling them! Some VOIP equipment that shall remain unnamed needed to do ENUM queries, but only after a successful ‘health check’.
> 
> The health check looked like this (sorry, don’t have the pcap handy, just this summary):
> ID 0
> Once pdns_server started responding NOTIMP, instead of dropping the query, the equipment was happy.

Argus system and network monitoring software [1] sends DNS status requests.

If you look at [2], it states:

"UDP/DNS sends a 'status-query', UDP/DNSQ sends an 'IN ANY' query. some DNS servers (notably djbdns) do not handle 'status' queries.”

On the wire, it is an apparently random identifier, that doesn’t change between queries and only contains a 12 byte DNS header, opcode 2, rcode 0, all bits and counters 0.

Hope this helps

Warmly,

Roy

[1] http://argus.tcp4me.com/ <http://argus.tcp4me.com/>
[2] http://argus.tcp4me.com/services.html <http://argus.tcp4me.com/services.html>