Subject: [DNSOP] I-D Action: draft-ietf-dnsop-refuse-any-03.txt

From: [email-masked]
Date: Tue, 15 Nov 2016 21:44:19 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Domain Name System Operations of the IETF.

        Title           : Providing Minimal-Sized Responses to DNS Queries with QTYPE=ANY
        Authors         : Joe Abley
                          Olafur Gudmundsson
                          Marek Majkowski
	Filename        : draft-ietf-dnsop-refuse-any-03.txt
	Pages           : 9
	Date            : 2016-11-15

Abstract:
   The Domain Name System (DNS) specifies a query type (QTYPE) "ANY".
   The operator of an authoritative DNS server might choose not to
   respond to such queries for reasons of local policy, motivated by
   security, performance or other reasons.

   The DNS specification does not include specific guidance for the
   behaviour of DNS servers or clients in this situation.  This document
   aims to provide such guidance.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-refuse-any/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dnsop-refuse-any-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dnsop-refuse-any-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ólafur Guðmundsson <[email-masked]>
Date: Wed, 16 Nov 2016 14:47:43 +0900

Dear colleagues

This version addresses all the outstanding requests for changes.
The editors believe this version is ready for WGLC.

thanks
Olafur

On Wed, Nov 16, 2016 at 2:44 PM, <[email-masked]> wrote:

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Ondřej Surý <[email-masked]>
Date: Thu, 17 Nov 2016 03:48:13 +0100 (CET)

Section 7 (nit): s/implimentations/implementations/

Otherwise I have reviewed the document and I believe it's ready to be put in the oven.

~~~

There's a small procedural thing - the last name of the draft
appears on both datatracker.i.o and tools.i.o.  I believe it
would be better to reupload the draft with name changed to

draft-ietf-dnsop-minimal-any

to prevent the people who might thing the name of the draft
bears any significance.  As this requires almost no effort
I think it would be better to this now than fend of the
questions "why is this refuse-any while it doesn't refuse
ANY" later.

Cheers,
--
 Ondřej Surý -- Technical Fellow
 --------------------------------------------
 CZ.NIC, z.s.p.o.    --     Laboratoře CZ.NIC
 Milesovska 5, 130 00 Praha 3, Czech Republic
 mailto:[email-masked]    https://nic.cz/
 --------------------------------------------

----- Original Message -----
> From: "Ólafur Guðmundsson" <[email-masked]>
> To: "dnsop" <[email-masked]>
> Sent: Wednesday, 16 November, 2016 06:47:43
> Subject: Re: [DNSOP] I-D Action: draft-ietf-dnsop-refuse-any-03.txt

> On Wed, Nov 16, 2016 at 2:44 PM, < [ mailto:[email-masked] |
> [email-masked] ] > wrote:
> 
> 
> 
> [ https://datatracker.ietf.org/doc/draft-ietf-dnsop-refuse-any/ |
> https://datatracker.ietf.org/doc/draft-ietf-dnsop-refuse-any/ ]
> 
> [ https://tools.ietf.org/html/draft-ietf-dnsop-refuse-any-03 |
> https://tools.ietf.org/html/draft-ietf-dnsop-refuse-any-03 ]
> 
> [ https://www.ietf.org/rfcdiff?url2=draft-ietf-dnsop-refuse-any-03 |
> https://www.ietf.org/rfcdiff?url2=draft-ietf-dnsop-refuse-any-03 ]
> 
> 
> until the htmlized version and diff are available at [ http://tools.ietf.org/ |
> tools.ietf.org ] .
> 
> [ ftp://ftp.ietf.org/internet-drafts/ | ftp://ftp.ietf.org/internet-drafts/ ]
> 
> [ mailto:[email-masked] | [email-masked] ]
> [ https://www.ietf.org/mailman/listinfo/dnsop |
> https://www.ietf.org/mailman/listinfo/dnsop ]
> 
>

---

From: Ólafur Guðmundsson <[email-masked]>
Date: Thu, 17 Nov 2016 12:19:54 +0900

On Thu, Nov 17, 2016 at 11:48 AM, Ondřej Surý <[email-masked]> wrote:

> Applied

> questions "why is this refuse-any while it doesn't refuse
I in principle support this but this has to be the chairs call

Olafur

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 25 Nov 2016 19:24:36 -0500

On 11/16/16 10:19 PM, Ólafur Guðmundsson wrote:
>
>
> On Thu, Nov 17, 2016 at 11:48 AM, Ondřej Surý <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>
>     ~~~
>

That's an interesting observation.  I would support that in principle also.

I'll put that question into the WGLC last call statement

tim