Subject: [DNSOP] Fwd: [Curdle] I-D Action: draft-ietf-curdle-dnskey-eddsa-02.txt

From: Ondřej Surý <[email-masked]>
Date: Tue, 15 Nov 2016 00:22:18 +0100 (CET)

Dear all,

a new version of EDDSA for DNSSEC has been posted
that resolves most if not all comments received
during WGLC in curdle.  This is one last chance
to review the document, so don't miss it! :)

Cheers,
--
 Ondřej Surý -- Technical Fellow
 --------------------------------------------
 CZ.NIC, z.s.p.o.    --     Laboratoře CZ.NIC
 Milesovska 5, 130 00 Praha 3, Czech Republic
 mailto:[email-masked]    https://nic.cz/
 --------------------------------------------

----- Forwarded Message -----
From: [email-masked]
To: [email-masked]
Cc: "curdle" <[email-masked]>
Sent: Tuesday, 15 November, 2016 00:10:15
Subject: [Curdle] I-D Action: draft-ietf-curdle-dnskey-eddsa-02.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the CURves, Deprecating and a Little more Encryption of the IETF.

        Title           : EdDSA for DNSSEC
        Authors         : Ondrej Sury
                          Robert Edmonds
	Filename        : draft-ietf-curdle-dnskey-eddsa-02.txt
	Pages           : 8
	Date            : 2016-11-14

Abstract:
   This document describes how to specify EdDSA keys and signatures in
   DNS Security (DNSSEC).  It uses the Edwards-curve Digital Security
   Algorithm (EdDSA) with the choice of two curves, Ed25519 and Ed448.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-curdle-dnskey-eddsa/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-curdle-dnskey-eddsa-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-curdle-dnskey-eddsa-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
Curdle mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/curdle

---

From: Viktor Dukhovni <[email-masked]>
Date: Tue, 15 Nov 2016 07:53:21 +0000

> to review the document, so don't miss it! :)

My only comment is that I very much hope that the code-point
assignments for the new curves are accompanied by a deprecation of
at least as many obsolete algorithms that should no longer be used.

Specifically, I'd like to see deprecation of algorithms:

    * 3 (DSA/SHA1)
    * 5, (RSA/SHA-1, same as 7 but without possibility of NSEC3)
    * 6 (DSA-NSEC3-SHA1, same as 3 with perhaps NSEC3, but both need to go)
    * 12 (GOST R 34.10-2001)
	 except as required to meet any local regulations).

If, while adding two new algorithms, we in parallel deprecate four
old ones, then we're making progress.

-- 
	Viktor.

---

From: Jim Reid <[email-masked]>
Date: Tue, 15 Nov 2016 07:56:34 +0000

> On 15 Nov 2016, at 07:53, Viktor Dukhovni <[email-masked]> wrote:
> 

Maybe we should have a one-in, one-out rule for DNSSEC algorithms? :-)

---

From: Paul Wouters <[email-masked]>
Date: Tue, 15 Nov 2016 17:00:39 +0900

https://tools.ietf.org/html/draft-wouters-sury-dnsop-algorithm-update-02

Paul

Sent from my iPhone

> On Nov 15, 2016, at 16:53, Viktor Dukhovni <[email-masked]> wrote:
> 
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Dick Franks <[email-masked]>
Date: Tue, 15 Nov 2016 16:51:56 +0000

Ondrej

The document calls up two TBD code points for the EDDSA algorithms, but the
IANA Considerations section places no action on IANA to assign these and
add them to the registry.

Other than that, seems ok.

Dick Franks
________________________

---

From: Ondřej Surý <[email-masked]>
Date: Tue, 15 Nov 2016 18:05:57 +0100 (CET)

The IANA Considerations Sections says:

This document updates the IANA registry "Domain Name System Security (DNSSEC) Algorithm Numbers".

And I believe that's the correct language according to https://tools.ietf.org/html/rfc5226#section-5.1

Cheers,
Ondrej

----- Original Message -----
> From: "Dick Franks" <[email-masked]>
> To: "Ondřej Surý" <[email-masked]>
> Cc: "dnsop" <[email-masked]>
> Sent: Tuesday, 15 November, 2016 17:51:56
> Subject: Re: [DNSOP] Fwd: [Curdle] I-D Action: draft-ietf-curdle-dnskey-eddsa-02.txt

---

From: Dick Franks <[email-masked]>
Date: Tue, 15 Nov 2016 17:43:19 +0000

My mistake. Apologies.

I also had draft-wouters-sury-dnsop-algorithm-update-02
on screen. That has the registry table with same TBDs.
Starting at 04:30 dulls the brain.

Dick Franks
________________________

On 15 November 2016 at 17:05, Ondřej Surý <[email-masked]> wrote:

> And I believe that's the correct language according to
> https://tools.ietf.org/html/rfc5226#section-5.1
>
> Cheers,
> Ondrej
>
> --

---

From: Daniel Migault <[email-masked]>
Date: Tue, 15 Nov 2016 23:23:23 -0500

my understanding is that ed448 does not specify default values for the
context and i have not seen in the current draft a specification of the
context. Shouldn't we explicitly mention that the context is empty?
Yours,
daniel

---

From: Ondřej Surý <[email-masked]>
Date: Wed, 16 Nov 2016 05:45:15 +0100 (CET)

draft-irft-cfrg-eddsa states in Section 5.2:

   Value of context is set by signer and verifier (maximum of 255
   octets, the default is empty string) and has to match octet by octet
   for verification to be successful.

So in fact, the default context for Ed448 is "empty string".

Cheers,
Ondrej

----- Original Message -----
> From: "Daniel Migault" <[email-masked]>
> To: "Dick Franks" <[email-masked]>
> Cc: "dnsop" <[email-masked]>, "Ondřej Surý" <[email-masked]>
> Sent: Wednesday, 16 November, 2016 05:23:23

---

From: Daniel Migault <[email-masked]>
Date: Wed, 16 Nov 2016 00:01:58 -0500

Thanks, i did not saw it. This is explicitely mentioned.
Yours,
Daniel

On Nov 16, 2016 1:45 PM, "Ondřej Surý" <[email-masked]> wrote:

> >>> > The document calls up two TBD code points for the EDDSA algorithms,
> but
> >>> the
> >>> >> This draft is a work item of the CURves, Deprecating and a Little
> more
> >>> >> Encryption of the IETF.
> >>> >>
> >>> >>         Title           : EdDSA for DNSSEC
> >>> >>         Authors         : Ondrej Sury
> >>> >>                           Robert Edmonds