Subject: [DNSOP] Terminology draft - validation nits

From: Casey Deccio <[email-masked]>
Date: Sat, 28 Jan 2017 17:20:14 -0700

Thanks for the efforts that went into the new revision of the DNS Terminology draft.  Just a few comments on the new "Validation" section:

> The first two definitions above consider the only validity of...

Should be "only the" instead of "the only" (that typo was inherited from the text I contributed).

> The terms "authentication" and "verification" are used	
> interchangeably with "validation" in the sense of the third	
> definition above.

In the sense of (only) the third definition, only "authentication" is interchangeable with "validation".  However, "verification" and "validation" are interchangeable for all three definitions.  This can be seen by searching "verify" and "verification" in RFC 4033 and RFC 4034, for example.

My recommendation is that 1) this sentence is rewritten as follows:

> The term "verification" is used	
> interchangeably with "validation", in the sense of the third	
> definition above.

2) either the term "Validation:" is changed to "Validation/Verification:" and/or a new term is added: "Verification: (see Validation)";

If some of the references (e.g., from RFC 4033) for verification should be added to the text, then I can help with that, but I'm not sure it's necessary.

Casey

---

From: Casey Deccio <[email-masked]>
Date: Sat, 28 Jan 2017 18:45:30 -0700

> On Jan 28, 2017, at 5:20 PM, Casey Deccio <[email-masked]> wrote:
> 

*sigh*.  This should have read:

> The term "authentication" is used	

Casey

---

From: "Paul Hoffman" <[email-masked]>
Date: Sun, 29 Jan 2017 14:23:16 -0800

Added as Issue 11: 
https://github.com/DNSOP/draft-ietf-dnsop-terminology-bis/issues/11