Subject: Re: [DNSOP] I-D Action: draft-ietf-dnsop-dns-wireformat-http-01.txt

From: Petr Špaček <[email-masked]>
Date: Fri, 7 Apr 2017 09:38:05 +0200

Hello,

On 28.3.2017 16:58, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Domain Name System Operations of the IETF.
> 
>         Title           : DNS wire-format over HTTP
>         Authors         : Linjian Song
>                           Paul Vixie
>                           Shane Kerr
>                           Runxia Wan
> 	Filename        : draft-ietf-dnsop-dns-wireformat-http-01.txt

Version draft-ietf-dnsop-dns-wireformat-http-01 is the first one I
reviewed and it is a good read. No objections to current version.

Are there any implementations?

-- 
Petr Špaček  @  CZ.NIC

---

From: Shane Kerr <[email-masked]>
Date: Mon, 10 Apr 2017 11:12:41 +0000

Petr,

At 2017-04-07 09:38:05 +0200

> Are there any implementations?

There are two and a half implementations, one in C by Paul Vixie and one
in Go by BII, plus a client-side version in Javascript (ug) by me.

https://github.com/BII-Lab/DNSoverHTTP
https://github.com/BII-Lab/DNSoverHTTPinGO
http://www.blij.tk:8888/

Cheers,

--
Shane