Subject: Re: [DNSOP] Please review in terminology-bis: Global DNS and Private DNS

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 18 Dec 2017 14:52:11 +0100

On Mon, Nov 27, 2017 at 10:28:04AM -0800,
 Paul Hoffman <[email-masked]> wrote 
 a message of 14 lines which said:

> Section 2 has definitions of "Global DNS" and "Private DNS", based
> on the facets listed in "Naming system". This was discussed heavily
> on the list earlier, but it is also a pretty big change, so we want
> to be sure that it is what the WG wants. Please review these terms
> and comment on the list if you think the definitions should change.

I think that it would be better to remove "global DNS". It is not a
technical definition and it assumes things like the mythical "names
operational community". This draft is about DNS terminology. From the
point of view of the DNS, ICANN and OpenNIC are the same (same
protocols, same concepts, same names) even if their registration
(i.e. non-DNS) policies are different.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 18 Dec 2017 09:29:58 -0500

> (i.e. non-DNS) policies are different.

In homenet-dot, IIRC we ran into this problem, and started using terms like "globally-unique name" and "non-globally-unique name" to finesse it, but we still used "global DNS" once.   We use "globally scoped" and "locally scoped" a lot.

If you were to define the global DNS, I think it would simply be the set of names that are published and are unique subdomains of names that have delegations from the root.   This is slightly looser than "the set of all names that can be reached by delegations from the root" because some parts of the "global DNS" are not reachable outside of their local scope.   I'm not claiming that what I just said is what should be in the document, just that that's sort of the general idea of it.   What the document actually says is much more than this, much better than this, and I think includes this, although perhaps not as explicitly as might be desired.

Anyway, my point is that if you were to remove "global DNS" from the document, that would be really unfortunate.   What's there is good, and useful.

I think the point you've raised about "names operational community" is also pretty obviously wrong, because the text uses the term "administrative operational community" and says what it means: "which convenes itself in the ICANN."   So the term you say is mythical is not only well-defined, but has a meaning that is well known to pretty much everybody who participates in DNSOP!   :)

Now that I've attempted to compose this reply, it seems to me, and perhaps was obvious to other readers more quickly because they're at 20kft and not 1ft on this, that your real point is that the document should not privilege ICANN over OpenNIC.   If so, you should say that directly and we should reason about that, not start from your conclusion.

This is difficult, in the sense that while I tend to not like the idea of reifying ICANN in this way, the document is reporting the status quo, and is not saying anything about it that's not true, and the confusion you propose will in fact come up for the reader if the document doesn't say this.   If the status quo is wrong, this is not really the document in which that argument should be made; if that argument is successfully made at some later date, the document will not be wrong, but merely out of date in terms of reporting the status quo.

Taking out the whole section on global and private names seems like cutting off one's nose to spite one's face.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 21 Dec 2017 17:20:10 +0100

On Mon, Dec 18, 2017 at 09:29:58AM -0500,
 Ted Lemon <[email-masked]> wrote 
 a message of 176 lines which said:

> Now that I've attempted to compose this reply, it seems to me, and
> perhaps was obvious to other readers more quickly because they're at
> 20kft and not 1ft on this, that your real point is that the document
> should not privilege ICANN over OpenNIC.   If so, you should say
> that directly

Please do not tell me what is my real point. I know my real point
(even if it is not always expressed clearly).

When it comes to non-technical issue, the draft says, when defining
TLD, that "the division [between ccTLD and gTLD] is a matter of
policy, and beyond the scope of this document." This is the right
approach. The fact that the root is managed by ICANN or OpenNIC or
whatever is beyond the scope of this document.