Subject: [DNSOP] Mail addresses in .arpa

From: "John R. Levine" <[email-masked]>
Date: 8 Apr 2018 14:14:38 -0400

One day when I should have been doing something else, I make some .arpa 
e-mail addresses.

Try sending mail to [email-masked] and in all likelihood I 
will get it.

I know it's ugly, but is there any rule that forbids putting an MX in a 
reverse zone?

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Rubens Kuhl <[email-masked]>
Date: Sun, 8 Apr 2018 20:46:58 -0300

John,

Have you tried  sending e-mail from this address to Google, Microsoft and Zoho mail systems ?
(with SPF, please)

Rubens

> On 8 Apr 2018, at 15:14, John R. Levine <[email-masked]> wrote:
> 
> One day when I should have been doing something else, I make some .arpa e-mail addresses.
> 
> Try sending mail to [email-masked] and in all likelihood I will get it.
> 
> I know it's ugly, but is there any rule that forbids putting an MX in a reverse zone?
> 
> Regards,
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Petr Špaček <[email-masked]>
Date: Mon, 9 Apr 2018 08:43:41 +0200

> I know it's ugly, but is there any rule that forbids putting an MX in a

AFAIK there is no such rule because reverse zone is not "special" in the
protocol.

-- 
Petr Špaček  @  CZ.NIC

---

From: Tony Finch <[email-masked]>
Date: Mon, 9 Apr 2018 10:11:23 +0100

> On 8 Apr 2018, at 19:14, John R. Levine <[email-masked]> wrote:
> 

No, though talk to Joe Abley if you want some practical interop experience :-) https://mailarchive.ietf.org/arch/msg/dnsop/Ttvz3m_x7PyS6czeT-K9VQYQeqY/?qid=bff38cd5089003ca0d849bb8f2150644

Similarly, there’s nothing stopping you from putting PTR records in the “forward” DNS - my dodgy VM provisioning scripts stuff EUI48 <-> hostname maps in the DNS (the vm’s MAC address is its most persistent externally visible identifier).

08-00-27-b6-01-b4.dev.dns.cam.ac.uk. 3 IN PTR   vm0.dev.dns.cam.ac.uk.
vm0.dev.dns.cam.ac.uk.  3       IN      EUI48   08-00-27-b6-01-b4

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at