Subject: [DNSOP] Complexity and innovation in the DNS protocol: the work of DNSOP

From: Suzanne Woolf <[email-masked]>
Date: Wed, 18 Apr 2018 17:07:23 -0400

Hi,

The chairs have been discussing next steps after IETF 101, particularly the very lively WG input on the complexity and stability of the DNS protocol.

There are many aspects to the questions that came up. Some are not going to be resolved within the IETF or the standards process, but it sounds to us like there are things the IETF and DNSOP can do that could improve the situation.

We heard significant support in the WG for slowing down on adoption of new work, with more attention by the chairs and in WG discussion for a couple of factors:

First, what's the applicability of this work? what problem does it solve, and for whom?

Second, does this work add significantly to the complexity of the DNS protocol, or the work of implementers and operators?

Finally, what implementation experience exists with the technology?

We're not trying to create unnecessary barriers to new work; previous generations of DNS working groups have arguably tried to preserve stability of the protocol at the expense of innovation, with the result that people simply proceeded to innovate outside of the standards process.

However, we want to see these issues discussed as part of WG consideration for adoption of new work in the future, and will explicitly consider them when deciding whether new work has adequate support to advance in the working group.

Best,
Suzanne, Tim, and Benno

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 19 Apr 2018 15:16:20 -0400

> On Apr 18, 2018, at 5:07 PM, Suzanne Woolf <[email-masked]> wrote:
> 
> Hi,
> 

I have only been in the DNS community for a few years but spent many years in the IETF community in routing before that.

My experience is that the DNS protocol with all of it’s new submissions and feature proposals is not very complex in comparison to routing.

I am not in favor of slowing innovation or slowing the adoption of new work. I think each submitted proposal should stand on it’s own merits and we should be able to have discussions about each proposal to decide if it’s a benefit to the community without fear of being sidelined or slow-tracked.

Thanks,
Tom

---

From: Michael StJohns <[email-masked]>
Date: Thu, 19 Apr 2018 16:42:49 -0400

> Second, does this work add significantly to the complexity of the DNS protocol, or the work of implementers and operators?

A slight respin of this bullet:  Does this work change the way the 
infrastructure of the protocol works, or is this work targeted at users 
of data stored within the DNS?   The former class is things like DNSSEC, 
CNAMEs, DNAMES, CDS/CDNSKEY; the latter is something like DANE.

I'd also add a 4th bullet:  "Fourth, does this work require wide 
deployment to be useful?" - this question taken together with my respin 
of the second item is trying to suggest that the class of proposals that 
just add data to the DNS might be acceptable even if the expected 
deployments are limited, whereas a proposal that requires the servers, 
resolvers and clients to know something more than just serving the data 
should require a consideration of whether the deployment be wide, if 
not, then why not,  and how do we propose to get to a wide deployment?

Later, Mike