Subject: Re: [DNSOP] Creating a registry for reserved labels.

From: Paul Hoffman <[email-masked]>
Date: Mon, 1 Oct 2018 17:23:55 +0000

Here's my first cut at the draft to create the registry. Note that I don't yet actually describe the registry in the draft; I hope the WG might be interested in doing that. :-)

--Paul Hoffman

Forwarded message:

> From: [email-masked]
> To: [email-masked]
> Subject: I-D Action: draft-hoffman-dns-special-labels-00.txt
> Date: Mon, 01 Oct 2018 10:17:22 -0700
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>         Title           : IANA Registry for Special Labels in the DNS
>         Author          : Paul Hoffman
> 	Filename        : draft-hoffman-dns-special-labels-00.txt
> 	Pages           : 5
> 	Date            : 2018-10-01
>
> Abstract:
>    This document defines an new IANA registry for special labels in the
>    DNS.  The registry is useful because the labels cause special
>    handling in DNS entities such as stub resolvers, recursive resolvers,
>    and applications that use DNS, and developers of software for those
>    entities should be aware of the many types of special labels in use.
>
>    [[ A GitHub repo for this document is at
>    https://github.com/paulehoffman/dns-special-labels ]]
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-hoffman-dns-special-labels/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-hoffman-dns-special-labels-00
> https://datatracker.ietf.org/doc/html/draft-hoffman-dns-special-labels-00
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/

---

From: Tim Wicinski <[email-masked]>
Date: Tue, 2 Oct 2018 07:56:19 -0400

My only concern is that I hope kskrol-sentinel and mta-sts are not held up
while we quickly hammer out this labels registry.
Question:  does 8145 (key tag) fall into this bucket?

I think Terry's comment should be in any document describing this registry:

 Therefore, it is important to note that the reservation of the labels in
this manner is definitely *not* considered "best practice".

On Mon, Oct 1, 2018 at 1:24 PM Paul Hoffman <[email-masked]> wrote:

> Here's my first cut at the draft to create the registry. Note that I don't
> yet actually describe the registry in the draft; I hope the WG might be
> interested in doing that. :-)
>
> --Paul Hoffman
>
>
> Forwarded message:
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: "Wessels, Duane" <[email-masked]>
Date: Tue, 2 Oct 2018 14:01:56 +0000

Tim,

It feels to me like “this bucket” is not well defined enough at this point to say whether 8145 falls in it, or not.   Shouldn’t the dns-special-labels draft lay out some guidelines for what goes in the registry and what doesn’t?  And maybe even explain in what ways the registry entries are special, not simply that (someone thinks) they are special?

DW

From: DNSOP <[email-masked]> on behalf of Tim Wicinski <[email-masked]>
Date: Tuesday, October 2, 2018 at 4:56 AM
To: Paul Hoffman <[email-masked]>
Cc: dnsop <[email-masked]>
Subject: [EXTERNAL] Re: [DNSOP] Creating a registry for reserved labels.

My only concern is that I hope kskrol-sentinel and mta-sts are not held up while we quickly hammer out this labels registry.
Question:  does 8145 (key tag) fall into this bucket?

 Therefore, it is important to note that the reservation of the labels in this manner is definitely not considered "best practice".

On Mon, Oct 1, 2018 at 1:24 PM Paul Hoffman <[email-masked]<mailto:[email-masked]>> wrote:
Here's my first cut at the draft to create the registry. Note that I don't yet actually describe the registry in the draft; I hope the WG might be interested in doing that. :-)

--Paul Hoffman

Forwarded message:

> From: [email-masked]<mailto:[email-masked]>
> To: [email-masked]<mailto:[email-masked]>
> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>

_______________________________________________
DNSOP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnsop

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 2 Oct 2018 14:26:59 +0000

> My only concern is that I hope kskrol-sentinel and mta-sts are not held up while we quickly hammer out this labels registry. 

MTA-STS is already an RFC, so there is nothing to hold up. I don't think that the IESG would hold up Sentinel because this registry will have other values from existing RFCs.

> Question:  does 8145 (key tag) fall into this bucket? 

I didn't put it there because the label only applies for query type NULL, but others might disagree and want it in the registry.

>  Therefore, it is important to note that the reservation of the labels in this manner is definitely not considered "best practice".

I cannot disagree more. If Terry wants to write a document telling people what he thinks is the best practice is to creating important protocols like IDNA, that's great. I sincerely doubt he'll get IETF consensus, but he's welcome to try. This document is about the registry.

On Oct 2, 2018, at 7:01 AM, Wessels, Duane <[email-masked]> wrote:

> It feels to me like “this bucket” is not well defined enough at this point to say whether 8145 falls in it, or not.   Shouldn’t the dns-special-labels draft lay out some guidelines for what goes in the registry and what doesn’t?  

Yes. I punted that to the WG.

> And maybe even explain in what ways the registry entries are special, not simply that (someone thinks) they are special?

That too.

--Paul Hoffman

---

From: "John Levine" <[email-masked]>
Date: 2 Oct 2018 18:56:44 -0000

In article <[email-masked]>,
>I didn't put it there because the label only applies for query type NULL, but others might disagree and want it in the registry.

It seems to me that the most useful purpose for this registry is to
identify names that are resolved using the normal DNS protocol (not
like .local or .onion) but that are treated specially by some
application(s) above the DNS stack. So the 8145 key tag would go in,
as would evertything in _attrleaf, the latter likely by reference.

As to whether it's best or worst practice, I'd stay away from that and
just clarify that the bar for adding new entries is high because of
the risk that they will collide with existing non-special use.

R's,
John
-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Joe Abley <[email-masked]>
Date: Tue, 2 Oct 2018 14:59:32 -0400

> the risk that they will collide with existing non-special use.

Note also that if the document intends to create a registry, it will need to specify the procedures for change control (i.e. it will need to describe the bar in useful detail, not just clarify that it is high). RFC 8126 contains the authoritative and current guidance for how to do that.

Joe

---

From: "John R Levine" <[email-masked]>
Date: 2 Oct 2018 15:01:04 -0400

> Note also that if the document intends to create a registry, it will need to specify the procedures for change control (i.e. it will need to describe the bar in useful detail, not just clarify that…

The draft currently says IESG action which seems fine, or maybe require an 
RFC.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly