Subject: [DNSOP] Accounting for Special Use Names in Application Protocols

From: Mark Nottingham <[email-masked]>
Date: Tue, 8 Jan 2019 09:42:36 +1100

Hi DNSOP,

In the HTTPWG, we have an open issue about how to account for .onion in HTTP URL processing:
  https://github.com/httpwg/http-core/issues/10

Our discussion led us to believe we'd do better to have a general statement about special-use names when dereferencing HTTP URLs.

It's possible such text might end up here:
  https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#http.uri
... along with the following section on HTTPS, and of course in Security Considerations.

Do folks have thoughts about what it should say, and would any one be willing to help?

Cheers,

P.S. I haven't CC'd the HTTP WG to avoid issues with cross-posting; I'll point the WG at discussion here.

--
Mark Nottingham   https://www.mnot.net/

---

From: Brian Dickson <[email-masked]>
Date: Mon, 7 Jan 2019 16:42:19 -0800

My two cents:
I think it might be good to scope the 6761 issue, with something like the
following:

> The http (and similar) URIs must rely on some name resolution mechanism(s)
> to interpret the "authority" field and ultimately convert it into a
> transport identifier (e.g. IPv4, IPv6, carrier pigeon).

* If/when* DNS is consulted for resolution of the authority field, directly
> or indirectly, strict adherence to the spirit and text of RFC 6761 is
> required.

 I.e. it is necessary to recognize all special use names, and necessary to
> not resolve such names via DNS.

Hope this helps at least a little.

Brian

On Mon, Jan 7, 2019 at 2:43 PM Mark Nottingham <[email-masked]> wrote:

> Our discussion led us to believe we'd do better to have a general
> statement about special-use names when dereferencing HTTP URLs.
>
> .... along with the following section on HTTPS, and of course in Security
> Considerations.
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 7 Jan 2019 20:17:33 -0500

You may find this helpful: https://tools.ietf.org/html/rfc8244

I'd be happy to work on text, but not this month.

---

From: Tony Finch <[email-masked]>
Date: Tue, 8 Jan 2019 12:21:50 +0000

> I think it might be good to scope the 6761 issue, with something like the

[SNIP]

> > not resolve such names via DNS.

That's going too far: special-use domain names must have specific
instructions to application authors, which might say not to use the
DNS or might say to use the DNS as usual.

David Schinazi's comment on the GitHub issue about referring to the IANA
registry is good, and perhaps more useful than referring to RFCs directly.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Trafalgar: Northeast 3 or 4, increasing 5 at times. Moderate. Fair. Good.

---

From: Brian Dickson <[email-masked]>
Date: Tue, 8 Jan 2019 18:23:29 -0800

> DNS or might say to use the DNS as usual.

Hi, Tony,
You are, of course, right. I think what I meant was, for the specific case
of .onion, (what I said),
and for the general case, (what you said). I.e. wherever an RFC for
specific special use name exists,
as linked by the IANA registry, those particular instructions MUST be
followed, especially if not following
those rules might/would break things (like the case of .onion vs DNS).

Brian