Subject: [DNSOP] Unsupported algorithm or unknown algorithm in draft-ietf-dnsop-extended-error

From: Mats Dufberg <[email-masked]>
Date: Fri, 13 Sep 2019 09:11:58 +0000

Error codes 1 and 2, respectively, says "unsupported algorithm" in the headline but "unknown algorithm" in the description. It should be consistent, and I think unsupported makes most sense.

---
Mats Dufberg
DNS Specialist
Internetstiftelsen (The Swedish Internet Foundation)
Mobile: +46 73 065 3899
https://internetstiftelsen.se/

---

From: Wes Hardaker <[email-masked]>
Date: Fri, 27 Sep 2019 16:44:54 -0700

Mats Dufberg <[email-masked]> writes:

> Error codes 1 and 2, respectively, says "unsupported algorithm" in the
> headline but "unknown algorithm" in the description. It should be
> consistent, and I think unsupported makes most sense.

Thanks for the comments.  Responses are inline below in my tracking
notes below.

14.7 DONE Mats Dufberg
~~~~~~~~~~~~~~~~~~~~~~

  Error codes 1 and 2, respectively, says "unsupported algorithm" in the
  headline but "unknown algorithm" in the description. It should be
  consistent, and I think unsupported makes most sense.

  + Response: Good catch!  fixed.

-- 
Wes Hardaker
USC/ISI