Subject: [DNSOP] On painting the draft-ietf-dnsop-svcb-httpssvc bikeshed

From: Tommy Pauly <[email-masked]>
Date: Tue, 19 Nov 2019 18:39:13 +0800

Hello DNSOP,

In the interest of getting this spec ready to go, I want to start our bikeshed on the RRTYPE name. We need a stable name that we all can live with.

I'll start. Please chime in!

Since it seems that many people like SVCB, and many don't like HTTPSSVC (too many repeated SS's!), I suggest using:

SVCB (referred to as "Service Binding")

SVCB-HTTPS (referred to as"Service Binding for HTTPS")

Best,
Tommy

---

From: Petr Špaček <[email-masked]>
Date: Tue, 19 Nov 2019 11:49:43 +0100

>     SVCB-HTTPS (referred to as"Service Binding for HTTPS")

Please keep RR type name as one lexical unit!

Constructing the name from multiple tokens ("SVCB" "-" "HTTPS") will trigger all sorts of bugs all over the place. For example the venerable dnspython.org library would require rework before it would be able to support the new type named "SVCB-HTTPS".

What about SVCBWEB or WEBSVCB?

Or shorter SVC + WEBSVC?

-- 
Petr Špaček  @  CZ.NIC

---

From: Ted Lemon <[email-masked]>
Date: Tue, 19 Nov 2019 05:52:58 -0500

> What about SVCBWEB or WEBSVCB?

I think it’s good to keep the protocol in the name, but agree with the syntax issue.  Given that http is dead, why not just HTTPSVC or HTTPSVCB?  There’s never going to be a competing no-TLS version of the RRtype.

---

From: Petr Špaček <[email-masked]>
Date: Tue, 19 Nov 2019 11:54:27 +0100

> I think it’s good to keep the protocol in the name, but agree with the syntax issue.  Given that http is dead, why not just HTTPSVC or HTTPSVCB?  There’s never going to be a competing no-TLS versio…

Oh wait, why don't we get just "HTTP" for the protocol-specific variant? With generic key=value format it should be able to accomodate new stuff for future versions of HTTP...

-- 
Petr Špaček  @  CZ.NIC

---

From: Olli Vanhoja <[email-masked]>
Date: Tue, 19 Nov 2019 12:06:18 +0100

> SVCB-HTTPS (referred to as"Service Binding for HTTPS")

I like that. It works well if/when more types will be added.

---

From: Olli Vanhoja <[email-masked]>
Date: Tue, 19 Nov 2019 12:12:34 +0100

> Constructing the name from multiple tokens ("SVCB" "-" "HTTPS") will trigger all sorts of bugs all over the place. For example the venerable dnspython.org library would require rework before it wou…

Interesting point.

> What about SVCBWEB or WEBSVCB?

For sorting it seems more logical to start with SVCB. Is web a well
defined term, to me it sounds a bit vague. Are you thinking that HTTP
might be replaced in the future? And that new protocol wouldn't be
renamed as HTTP anymore.

---

From: Brian Dickson <[email-masked]>
Date: Tue, 19 Nov 2019 19:43:10 +0800

On Tue, Nov 19, 2019 at 6:39 PM Tommy Pauly <tpauly=
[email-masked]> wrote:

> Hello DNSOP,
>
> In the interest of getting this spec ready to go, I want to start our
> bikeshed on the RRTYPE name. We need a stable name that we all can live
> with.
>
> Since it seems that many people like SVCB, and many don't like HTTPSSVC
> (too many repeated SS's!), I suggest using:
>
"Binding" might be too confusing even if it is technically correct. It also
might be too strong for the 0 case (alias form).

Maybe REF instead of SVCB?

I'm not concerned with any lexical sorting issues, just keep it to one
token for parsing.

Since it's for HTTP(S), how about HREF ?
(Yes, that is a deliberate double entendre.)

Brian

---

From: Erik Nygren <[email-masked]>
Date: Tue, 19 Nov 2019 08:32:21 -0500

Some of my current leanings:

SVCB and HTTPB  (SVCB and HTTPSB)

Of even shorter:  "SB" and "HSB"

(I also prefer SVCHTTPS over HTTPSSVC as the latter is way too easy to
leave out one of the S's.)

I'd considered just calling "SVCB" as "B" but that makes it harder to
search for.
This is also why "HTTP" or "HTTPS" are dispreferred is that they are hard
to search for.

HTTP(S) is more than just the Web which is why I'd be disinclined to use
WEB in the name.

  Erik

On Tue, Nov 19, 2019 at 5:39 AM Tommy Pauly <tpauly=
[email-masked]> wrote:

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Bob Harold <[email-masked]>
Date: Tue, 19 Nov 2019 09:40:14 -0500

>> SVCB-HTTPS (referred to as"Service Binding for HTTPS")
Perhaps:

SVCB and SVCH ?

-- 
Bob Harold

---

From: Ray Bellis <[email-masked]>
Date: Tue, 19 Nov 2019 23:34:42 +0800

> Please keep RR type name as one lexical unit!

There's already one RR type with a hypenated name (NSAP-PTR).

> Constructing the name from multiple tokens ("SVCB" "-" "HTTPS")
> will trigger all sorts of bugs all over the place

I've looked for, but can't find, a formal grammar for the <type> field
in master file syntax.

That said (and given the existence of NSAP-PTR) if your lexer doesn't
already treat a hyphen as a legal character in a token rather than as a
token in its own right, that's probably already a bug.

Ray

---

From: Paul Vixie <[email-masked]>
Date: Tue, 19 Nov 2019 09:06:52 -0800

>     SVCB-HTTPS (referred to as"Service Binding for HTTPS")

seems like you could call it BIND.

-- 
P Vixie