Subject: [DNSOP] Are SVCB/HTTPSSVC going to be renamed after all?

From: Alessandro Ghedini <[email-masked]>
Date: Wed, 10 Jun 2020 23:59:39 +0100

Hello,

At the risk of re-opening a can of worms, there was a discussion a while ago on
this list on renaming the SVCB and HTTPSSVC records to something else
https://mailarchive.ietf.org/arch/msg/dnsop/dh_H24_Dq-nr4TkO0FCqySjsnC8/

So I was wondering where that discussion landed (if anywhere) as I can't seem to
be able to find any resolution to that on the list.

To be clear, I don't particularly care either way, but if a rename is going to
happen I'd rather it happens sooner as it will affect implementers, and it might
unduly cause people to hold back from merging/deploying code in case a rename
actually happens, e.g. https://github.com/miekg/dns/pull/1067#issuecomment-627807069

Cheers

---

From: Erik Nygren <[email-masked]>
Date: Fri, 12 Jun 2020 16:39:51 -0400

As discussed in a previous thread, we've renamed the HTTPSSVC RR to be the
"HTTPS" RR.
The SVCB RR is keeping its name.
A new version of the draft has been published with this change as well as
with other changes:

   https://datatracker.ietf.org/doc/draft-ietf-dnsop-svcb-https/

(We separated the rename change out as a separate version from
the other changes to make it easier to diff them separately.)

I think we're at the point now where it would be good to make a last
call for feedback and inputs prior to asking for an early code point
allocation
for the HTTPS RR and SVCB RR.

   Erik

On Wed, Jun 10, 2020 at 7:00 PM Alessandro Ghedini <[email-masked]>
wrote:

> actually happens, e.g.
> https://github.com/miekg/dns/pull/1067#issuecomment-627807069
>
> Cheers
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 12 Jun 2020 16:43:18 -0400

Thanks Eric

I'll review this (as I hope the other chairs will too), and we could get
that
rolling in the next few weeks.

tim

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 16 Jun 2020 09:12:15 -0700

That sounds great! Thanks to the authors for getting so many issues cleared up recently. The new version is looking good.

As an implementor, I’d like to voice my support for getting the early code point allocation soon.

Best,
Tommy 

> On Jun 12, 2020, at 1:43 PM, Tim Wicinski <[email-masked]> wrote:
> 
> 
> Thanks Eric
> 
> I'll review this (as I hope the other chairs will too), and we could get that
> On Fri, Jun 12, 2020 at 4:40 PM Erik Nygren <[email-masked] <mailto:[email-masked]>> wrote:
> As discussed in a previous thread, we've renamed the HTTPSSVC RR to be the "HTTPS" RR.
> A new version of the draft has been published with this change as well as with other changes:
> 
>    https://datatracker.ietf.org/doc/draft-ietf-dnsop-svcb-https/ <https://datatracker.ietf.org/doc/draft-ietf-dnsop-svcb-https/>
> 
> call for feedback and inputs prior to asking for an early code point allocation
> On Wed, Jun 10, 2020 at 7:00 PM Alessandro Ghedini <[email-masked] <mailto:[email-masked]>> wrote:
> Hello,
> 
> https://mailarchive.ietf.org/arch/msg/dnsop/dh_H24_Dq-nr4TkO0FCqySjsnC8/ <https://mailarchive.ietf.org/arch/msg/dnsop/dh_H24_Dq-nr4TkO0FCqySjsnC8/>
> 
> actually happens, e.g. https://github.com/miekg/dns/pull/1067#issuecomment-627807069 <https://github.com/miekg/dns/pull/1067#issuecomment-627807069>
> 
> Cheers
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/dnsop <https://www.ietf.org/mailman/listinfo/dnsop>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/dnsop <https://www.ietf.org/mailman/listinfo/dnsop>