Subject: [DNSOP] Working Group Last Call for draft-ietf-dnsop-iana-class-type-yang

From: Benno Overeinder <[email-masked]>
Date: Thu, 15 Oct 2020 00:05:47 +0200

This starts a Working Group Last Call for draft-ietf-dnsop-iana-class-type-yang.

Current versions of the draft are available here:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-iana-class-type-yang/

The Current Intended Status of this document is: Standards Track

Benno Overeinder will be Document Shepherd. 

The authors have incorporated the comments of the working group in their latest revision -05.  The chairs would like to thank Paul Wouters for his input during the various versions of the Internet Draft.

Please review the draft and offer relevant comments.
If this does not seem appropriate please speak out. 
If someone feels the document is *not* ready for publication, please speak out with your reasons.
Supporting statements that the document is ready are also welcome.

This starts a two week Working Group Last Call process, and ends on:  30 October 2020.

Thanks,

— Benno

---

From: Pieter Lexis <[email-masked]>
Date: Thu, 15 Oct 2020 13:28:30 +0200

Hi folks,

On 10/15/20 12:05 AM, Benno Overeinder wrote:
> The authors have incorporated the comments of the working group in
their latest revision -05.  The chairs would like to thank Paul Wouters
for his input during the various versions of the Internet Draft.
> Supporting statements that the document is ready are also welcome.

It looks like the authors did a good job cleaning up the document. I
don't see any issues regarding the content of the document.

Best regards,

Pieter

---

From: Paul Wouters <[email-masked]>
Date: Thu, 15 Oct 2020 15:11:25 -0400 (EDT)

> https://datatracker.ietf.org/doc/draft-ietf-dnsop-iana-class-type-yang/

This looks good to me.

One minor item. Is it possible to add text in a way that instructs
implementer they SHOULD NOT add "Obsolete" entries when populating?

Or maybe that could be an instruction to IANA or whoever runs the
"the initial revision" of the yang module?

The idea is that we want to try and stop the proliferation of decades
old stuff into new code/documents just because it has an IANA entry.

Paul

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 16 Oct 2020 10:23:39 +0200

> implementer they SHOULD NOT add "Obsolete" entries when populating?

I think we need to assume that an implementer is familiar with the YANG spec, and this is just one of the rules to follow. Specifically, RFC 7950 says:

   o  "obsolete" means that the definition is obsolete and SHOULD NOT be
      implemented and/or can be removed from implementations.

This should IMO be sufficient and we needn't repeat in in this document.

> old stuff into new code/documents just because it has an IANA entry.

Such items will be clearly labelled in both the IANA registry and YANG module.
If they are used in new implementations, it might mostly be, I suspect, due to some external pressures rather than implementers' ignorance.

Ladislav

>
> Paul
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

-- 
Ladislav Lhotka 
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Paul Wouters <[email-masked]>
Date: Fri, 16 Oct 2020 09:49:30 -0400 (EDT)

> This should IMO be sufficient and we needn't repeat in in this document.

Ah yes. And 7950 is referenced in the introduction, so I guess that
should be enough.

Thanks,

Paul