Subject: [DNSOP] draft-ietf-dnsop-private-use-tld

From: Roy Arends <[email-masked]>
Date: Thu, 8 Oct 2020 11:19:56 +0100

Dear WG,

As per the conclusion by the DNSOP chairs on the call for adoption, draft-arends-private-use-tld has been adopted as a work item for the DNSOP WG.

I have uploaded a new version to the IETF datatracker draft submission service: https://www.ietf.org/id/draft-ietf-dnsop-private-use-tld-00.txt <https://www.ietf.org/id/draft-dnsop-private-use-tld-00.txt>

The changes are administratively only, but one needs further explanation:

After many discussions with several folk about this document, one theme occurred: Due to having two authors that both happen to work for the same organisation, it was feared that some folks might perceive this work as being endorsed by this organisation. (Note that no one has come forward assuming that this was endorsed by any organisation). As I stated clearly on the mailing list and during presentations, this draft was an individual submission.

Meanwhile, some folk have come forward and offered help writing this document. I have held off on that until this document was accepted by the WG. Needless to say, if this document wasn’t accepted, adding authors would’ve been a waste of their time.

Now that it has been accepted, I’ve asked Joe Abley for help. Joe understands the premise of the idea very well, understands the policy implications, and can certainly improve on my technical writing. I also helps to avoid any latent confusion that this idea might be endorsed by some organisation.

Joe and I have started work on the next version of the document.

Independently, and wholly unrelated to the previous point, Edward Lewis has asked me to be removed from the draft's author list. While he authored the first versions years ago, he currently lacks the bandwidth to get involved. I have reluctantly indulged his request. Thanks Edward for your insights and hard work!

Other changes: the date. The title of the draft. The document numbering (reset to -00).

Warmly,

Roy Arends

---

From: Fred Baker <[email-masked]>
Date: Mon, 12 Oct 2020 00:44:19 -0700

> On Oct 8, 2020, at 7:08 AM, Daniel Migault via RSSAC <[email-masked]> wrote:
> 
> Just to let you know that the draft for the private tld has been adopted as WG document. 
>  
>  https://www.ietf.org/id/draft-ietf-dnsop-private-use-tld-00.txt
> 
> Yours, 
> Daniel

Thanks, Daniel.

Joe and Roy, I'm trying to figure out how you intend these names to be managed and used. In your draft, you opine that having some form of private tld may be useful, and it may be. You apparently don't intend them to be announced in the root zone (or any other zone), and note that there is nothing that precludes them being formally defined and published from the root in the future, invalidating all extant uses of any such name without warning or review.

That seems a little precarious.

How do you plan to manage them?

---

From: Roy Arends <[email-masked]>
Date: Mon, 12 Oct 2020 13:38:50 +0000

> On 12 Oct 2020, at 08:44, Fred Baker <[email-masked]> wrote:
> 
> 
> 
>> https://urldefense.com/v3/__https://www.ietf.org/id/draft-ietf-dnsop-private-use-tld-00.txt__;!!PtGJab4!qHw-_WPRJG1YyMoR9K-baj4pViqk2fJQzJDsZbPg0smvVfNrGkUePaUGZNI96GahZI69WNY$ 
>> 
>> Yours, 
>> Daniel
> 
> Thanks, Daniel.
> 
> Joe and Roy, I'm trying to figure out how you intend these names to be managed and used. In your draft, you opine that having some form of private tld may be useful, and it may be.

Thank you for taking the time to read the document.

> You apparently don't intend them to be announced in the root zone

That is correct. 

> (or any other zone)

We make no assumptions on other zones. 

> , and note that there is nothing that precludes them being formally defined and published from the root in the future, invalidating all extant uses of any such name without warning or review.

This initial version of the draft details that it is highly unlikely that these two letter strings will ever be delegated, as it would violate principles that were set out in the past. You are quite right that nothing (in this draft) precludes them being formally defined. 
> That seems a little precarious.

One possible avenue that we’re researching is to treat these two letter strings as code points that at one point were set by the ISO as user-assigned, and should therefor be reserved (in the tradition of reserving previously assigned code points so that they can not be re-assigned to mean other things) and designate them as “special use” (RFC6761, RFC8244).

> How do you plan to manage them?

It seems to me that using the Special-Use Domain Names is a potential avenue to make sure that these are indeed never delegated from the root zone. Naturally this should all be done in coordination with the various ICANN communities and liaisons. 

 I hope this addresses your question. 

We will detail our progress at the IETF109 DNSOP WG and hopefully publish version -01 of this document.

Warm regards,

Roy

---

From: Fred Baker <[email-masked]>
Date: Mon, 12 Oct 2020 11:32:56 -0700

Ok, thanks.

Sent using a machine that autocorrects in interesting ways...

> On Oct 12, 2020, at 6:38 AM, Roy Arends <[email-masked]> wrote:
> 
>