Subject: [DNSOP] Going forward on draft-ietf-dnsop-private-use

From: Roy Arends <[email-masked]>
Date: Mon, 2 Nov 2020 16:31:53 +0000

Dear WG,

Joe and I have accepted the kind offer of Eberhard Lisse to help with this effort as an author. Eberhard is well aware of the various delicate balances in policy development processes within the ICANN community.  

As for version -01, the authors propose to separate the document into two:

(1) A document that discusses the motivation for private space top level domains, provides recommendations for people setting them up, etc.
(2) A document to note that ISO policy supports using ISO3166 User Assigned code elements to anchor private namespaces, recognise that use and, finally, recommend against use of these code elements for any other purposes that cause operational or security problems (e.g. due to collisions with delegations in the root zone).

Warmly,

Joe, Roy and El

---

From: Paul Wouters <[email-masked]>
Date: Mon, 2 Nov 2020 12:19:39 -0500 (EST)

> (1) A document that discusses the motivation for private space top level domains, provides recommendations for people setting them up, etc.

The IETF / DNSOP should not recommend setting up private space TLDs by
instructing people how to do this.

> (2) A document to note that ISO policy supports using ISO3166 User Assigned code elements to anchor private namespaces, recognise that use and, finally, recommend against use of these code elements…

I still don't see the value in this, but there is also no harm done
describing this. So I am ambivalent on this.

In general, I'm mostly afraid that this/these document(s) will eat up a
lot of DNSOP resources/time, seeing more Special Domain discussions and
all, while naming things is really outside of IETF/DNSOPS area.

Paul

---

From: Joe Abley <[email-masked]>
Date: Mon, 2 Nov 2020 12:56:07 -0500

Hi Paul,

> instructing people how to do this.

We anticipated that there would be differences of opinion around this set of topics that might be difficult to resolve. This is the motivation of splitting the issues into different documents, really.

> describing this. So I am ambivalent on this.

It seemed to us that the needle of consensus might be more consistently in that kind of green arc for this topic, too.

> all, while naming things is really outside of IETF/DNSOPS area.

I am confident that our chairs are listening and are aware of the lack of jurisdictional clarity on this point.

Joe

---

From: "John Levine" <[email-masked]>
Date: 2 Nov 2020 15:21:24 -0500

>instructing people how to do this.

The counterargument is that people have been using private TLDs for
many decades, our advice not to do so is widely ignored, and we might
be able to offer some advice on how minimize interop problems for
people who do so.

R's,
John

PS: I don't think any of us like NAT, but I also think we have seen
that pretending that it would go away if we ignored it didn't work.

---

From: Joe Abley <[email-masked]>
Date: Tue, 3 Nov 2020 09:03:11 -0500

> We anticipated that there would be differences of opinion around this set of topics that might be difficult to resolve. This is the motivation of splitting the issues into different documents, real…

And to make this more clear, while the authors are proposing that the issues be split into multiple documents, that doesn't mean we've already decided to do so. This is a working group document and we will take direction from the working group about how to proceed.

Joe

---

From: Tony Finch <[email-masked]>
Date: Fri, 6 Nov 2020 00:18:36 +0000

> instructing people how to do this.

+1

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Fisher: West or northwest 4 to 6, becoming variable 2 to 4 later. Moderate or
rough. Fair. Good.