Subject: Re: [DNSOP] I-D Action: draft-ietf-dnsop-dnssec-iana-cons-00.txt

From: Vladimír Čunát <[email-masked]>
Date: Thu, 11 Mar 2021 11:41:17 +0100

Hello.

I'm quite surprised that the IANA section of the draft includes that 
registering *flags* is also changed from "Standards Action" to "RFC 
Required".  While the algorithm space is rather large, that certainly 
doesn't apply to the NSEC3 and NSEC3PARAM flags (only 7 remain free).

--Vladimir | knot-resolver.cz

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 11 Mar 2021 15:38:49 +0000

On Mar 11, 2021, at 2:41 AM, Vladimír Čunát <[email-masked]> wrote:
> 
> I'm quite surprised that the IANA section of the draft includes that registering *flags* is also changed from "Standards Action" to "RFC Required".  While the algorithm space is rather large, that certainly doesn't apply to the NSEC3 and NSEC3PARAM flags (only 7 remain free).
> 

The size of the namespace isn't all that relevant in that, for any namespace, if it is filling up "too fast", one can quickly change the requirements to be more stringent. I'm pretty sure that has happened in the thousands of IANA registries, but the last time I checked, it happened "very, very rarely".

As I said in the meeting, none of these changes will happen without the WG being alerted. Consistency of registration is more important than trying to predict rare events in the future.

--Paul Hoffman

---

From: Ben Schwartz <[email-masked]>
Date: Thu, 11 Mar 2021 10:40:57 -0500

I agree with Vladimir: bitflags in an octet are totally different from
algorithm registrations.  I don't think they should have the same
registration policy.

On Thu, Mar 11, 2021 at 10:39 AM Paul Hoffman <[email-masked]>
wrote:

> The size of the namespace isn't all that relevant in that, for any
> namespace, if it is filling up "too fast", one can quickly change the
> requirements to be more stringent. I'm pretty sure that has happened in the
> thousands of IANA registries, but the last time I checked, it happened
> "very, very rarely".
>
> As I said in the meeting, none of these changes will happen without the WG
> being alerted. Consistency of registration is more important than trying to
> predict rare events in the future.
>
> --Paul Hoffman_______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Jim Reid <[email-masked]>
Date: Thu, 11 Mar 2021 15:50:54 +0000

> On 11 Mar 2021, at 15:38, Paul Hoffman <[email-masked]> wrote:
> 

I agree with Paul. We’ve burnt through < 20 code points since DNSSEC was invented ~20 years ago. At that rate, code point exhaustion could well be a problem for our great-great-great-great-grandchildren. I think we can safely kick that can down the road for a century or two.

---

From: Vladimír Čunát <[email-masked]>
Date: Thu, 11 Mar 2021 17:03:11 +0100

On 3/11/21 4:38 PM, Paul Hoffman wrote:
>> I'm quite surprised that the IANA section of the draft includes that registering*flags*  is also changed from "Standards Action" to "RFC Required".  While the algorithm space is rather large, that certainly doesn't apply to the NSEC3 and NSEC3PARAM flags (only 7 remain free).
>>

It's not like I'm necessarily opposed to it.  I was just surprised and 
didn't know how fast our reaction could come.  And so far it doesn't 
seem like we'd need this, but that argument works both ways actually.

--Vladimir