Subject: Re: [DNSOP] draft-ietf-dnsop-delegation-only is still not useful

From: Viktor Dukhovni <[email-masked]>
Date: Sun, 7 Mar 2021 06:26:09 -0200

> On Nov 3, 2020, at 8:19 PM, John Levine <[email-masked]> wrote:
> 
> I grepped through the downloaded contracted zone files for signed A
> and AAAA records and found over 32,000 of them in over 200 TLDs. The
> list of TLDs and counts are below, or you can find the whole set at
> https://www.iecc.com/signedglue.txt

Perhaps the count could be broadened?  That is, a count of RRSIGs for all
*non-apex* RRtypes other than DS, NSEC or NSEC3?  In a delegation-only
zone one would generally not expect to find much besides NS, DS and RRSIG
and NSEC(3) RRs, with the NS RRs and glue A RRs unsigned.

[ If the zone is signed via BIND, one might also find some signatures
  for TYPE65534. ]

For a somewhat more complete picture, below you'll find John Levine's data
augmented with recent delegation counts for all the CZDS zones including
the ones not listed him, where presumably the count of stray non-glue address
records was zero.

For example, for .biz, in addition to the two signed non-apex A records,
there are also three internal bookkeeping records:

  _nicname._tcp.biz. srv     0 0 43 whois.nic.biz.
  whois.biz.         cname   whois.nic.biz.
  www.whois.biz.     cname   whois.nic.biz.

-- 
	Viktor.

non-deleg  zone size  name
---------  ---------  ----
        0          3  aaa
        0          4  aarp
        0          1  abarth
        0         37  abb
        0        252  abbott
        0         31  abbvie
        0          9  abc
        0          4  able
        1        556  abogado
        0        445  abudhabi
        0      43853  academy
        0          1  accenture
        0       1548  accountant
        0       1509  accountants
        0        339  aco
        0       2215  actor
        0          5  adac
        0          2  ads
        0       8132  adult
        1          4  aeg
        0          7  aetna
        1          1  afamilycompany
        0         88  afl
        0      28950  africa
        0          1  agakhan
        0      73905  agency
        0         48  aig
        0          3  airbus
        0        733  airforce
        0          1  airtel
        0          1  akdn
        0          1  alfaromeo
        0          1  alibaba
        0          1  alipay
        0       1282  allfinanz
        0         21  allstate
        0          1  ally
        0       2414  alsace
        0          1  alstom
        1          1  amazon
        0          4  americanexpress
        0          1  americanfamily
        0          7  amex
        0          9  amfam
        0          3  amica
        0      23530  amsterdam
        0          3  analytics
        0          1  android
        0          1  anquan
        0         28  anz
        1          1  aol
        0       3823  apartments
        0     714968  app
        0         27  apple
        0         35  aquarelle
        2          1  arab
        0          3  aramco
        0       2876  archi
        0       2807  army
        0     100814  art
        0         13  arte
        0          1  asda
      182     197015  asia
        0       3419  associates
        0          1  athleta
        0       6229  attorney
        0       4277  auction
        0       1802  audi
        1          1  audible
        0       4601  audio
        0         63  auspost
        1          1  author
        0        421  auto
        0        429  autos
        0          1  avianca
        1        102  aws
        0         36  axa
        0         21  azure
        0       3298  baby
        0          1  baidu
        0          1  banamex
        0          1  bananarepublic
        0      13636  band
        0       2409  bank
        0     248724  bar
        0       5330  barcelona
        0         25  barclaycard
        0        125  barclays
        1          1  barefoot
        0       1965  bargains
        0          1  baseball
        0        305  basketball
        0          6  bauhaus
        1      30628  bayern
        1          6  bbc
        5          1  bbt
        0         13  bbva
        0          1  bcg
        0          2  bcn
        0          2  beats
        0       1290  beauty
        1      13738  beer
        1         25  bentley
        0      49447  berlin
        0      80032  best
        0          1  bestbuy
        4      22980  bet
        0          1  bharti
        0       1874  bible
        0      18298  bid
        0      15943  bike
        0         22  bing
        0       1355  bingo
        0      19203  bio
        2    1377825  biz
        6       5900  black
        0        980  blackfriday
        0          1  blockbuster
        0     187969  blog
        0         75  bloomberg
       60      13858  blue
        1          1  bms
        0        126  bmw
        0        299  bnpparibas
        0        413  boats
        0          1  boehringer
        0          1  bofa
        0          1  bom
        0       2427  bond
        0          2  boo
        1          1  book
        0          1  booking
        0          1  bosch
        0         12  bostik
        1       3449  boston
        1       1407  bot
        0      14584  boutique
        0          2  box
        1        186  bradesco
        0         11  bridgestone
        1        284  broadway
        8       1026  broker
        0          7  brother
        2       8116  brussels
        1          1  budapest
        0          7  bugatti
        0       4236  build
        0       4664  builders
        0      27394  business
        1          1  buy
        0     246971  buzz
        0      10252  bzh
        0       2668  cab
        0      17689  cafe
        0          1  cal
        1          1  call
        0          1  calvinklein
        0      45166  cam
        0       3431  camera
        0       7018  camp
        0         85  cancerresearch
        0         58  canon
        0       3881  capetown
        0      19533  capital
        0          1  capitalone
        0        302  car
        0          1  caravan
        0       7862  cards
        0      29532  care
        8       1272  career
        0       9104  careers
        0        281  cars
        1      47541  casa
        0          1  case
        0          1  caseih
        0      16258  cash
        0       8122  casino
       17     110807  cat
        0       3629  catering
        0         13  catholic
        0         72  cba
        0          5  cbn
        0          1  cbre
        0          9  cbs
        0      39889  center
        0       3293  ceo
        0         77  cern
        0          7  cfa
        0          5  cfd
        8          4  chanel
        0          2  channel
        0       2494  charity
        0         26  chase
        0      18432  chat
        0       3461  cheap
        0          7  chintai
        0       1520  christmas
        0          2  chrome
        0      26638  church
        0          1  cipriani
        1          1  circle
        0         22  cisco
        0          4  citi
        0        146  citic
        0      29546  city
        0          1  cityeats
        0       2863  claims
        0       2987  cleaning
        0      46312  click
        0       9833  clinic
        0          1  clinique
        0      13100  clothing
        0     204142  cloud
        0    1022586  club
        8          8  clubmed
        0      19885  coach
        0      16134  codes
        0      22160  coffee
        0       4507  college
        0      10117  cologne
        0  151609047  com
        1          1  comcast
        0          4  commbank
        0      17393  community
        0      72268  company
        0        386  compare
        0       7382  computer
        0          1  comsec
        0       1759  condos
        0       8603  construction
        0      31048  consulting
        0       9937  contact
        0       3861  contractors
        1       2187  cooking
        8          2  cookingchannel
        0      29362  cool
        0       8013  coop
        0       1839  corsica
        0       1052  country
        0          1  coupon
        0       2437  coupons
        0       2945  courses
        2       6066  cpa
        0       4850  credit
        0       1000  creditcard
        0        530  creditunion
        0       1314  cricket
        8          2  crown
        8        574  crs
        0          1  cruise
        0       1952  cruises
        8         15  csc
        0         12  cuisinella
        1       7981  cymru
        0      74987  cyou
        0          9  dabur
        0          2  dad
        0       7726  dance
        0          1  data
        0       9512  date
        0       3274  dating
        0          1  datsun
        0          2  day
        0          1  dclk
        1          1  dds
        1          1  deal
        0        107  dealer
        0       9336  deals
        0       1911  degree
        0       9319  delivery
        0         24  dell
        0         68  deloitte
        0          1  delta
        0        927  democrat
        0       8188  dental
        0       3086  dentist
        0        817  desi
        0     119849  design
        0     248917  dev
        0         59  dhl
        0       2239  diamonds
        0       1365  diet
        0      88932  digital
        0      12587  direct
        0      17774  directory
        0       3216  discount
        0          1  dish
        8          1  diy
        0          6  dnp
        0          2  docs
        0       5484  doctor
        0      14005  dog
        0       6519  domains
        0          1  dot
        0       7908  download
        0          1  drive
        0          1  dtv
        0          6  dubai
        8          1  duck
        0          1  dunlop
        0          4  dupont
        0       1925  durban
        0       4933  dvag
        0          1  dvr
        0      27180  earth
        0          2  eat
        4       3830  eco
        0         79  edeka
        0      28704  education
        0     109007  email
        0         10  emerck
        0      14562  energy
        0       4826  engineer
        0       7714  engineering
        0       6977  enterprises
        0          3  epson
        0       5081  equipment
        8          5  ericsson
        0         95  erni
        0          2  esq
        0      10320  estate
        0          1  etisalat
        0          4  eurovision
        0      11913  eus
        0      25739  events
        0      13275  exchange
        0      32701  expert
        0       3228  exposed
        0       8823  express
        0          9  extraspace
        0         62  fage
        0       4368  fail
        0          4  fairwinds
        0       4469  faith
        0      26646  family
        0       4405  fan
        0       4103  fans
        0      21634  farm
        0          1  farmers
        1      11719  fashion
        1          1  fast
        0          1  fedex
        0        902  feedback
        0          1  ferrari
        0          6  ferrero
        0          1  fiat
        8          1  fidelity
        0          1  fido
        0       5049  film
        0          1  final
        0      21304  finance
        0       5654  financial
        1          1  fire
        0          2  firestone
        0         48  firmdale
        0       4915  fish
        1       1581  fishing
        1      82826  fit
        0      12807  fitness
        0          1  flickr
        0       1817  flights
        0          2  flir
        0       1894  florist
        0       1101  flowers
        0          2  fly
        0         33  foo
        8          1  food
        8          1  foodnetwork
        0       5330  football
        0          4  ford
        8        407  forex
        0       4978  forsale
        0        244  forum
        0      17467  foundation
        0        131  fox
        1          1  free
        0         41  fresenius
        0      12740  frl
        0          5  frogans
        8          2  frontdoor
        0          1  frontier
        0          2  ftr
        0          3  fujitsu
        8          1  fujixerox
        0     212938  fun
        0      17039  fund
        0       2823  furniture
        0       2257  futbol
        0      23921  fyi
        0       5834  gal
        0      18596  gallery
        8          1  gallo
        0          1  gallup
        0       2270  game
        0      28677  games
        0          1  gap
        1       3659  garden
        0       8715  gay
        0          1  gbiz
        0      10712  gdn
        0         16  gea
        0       3425  gent
        8          6  genting
        0          1  george
        0          1  ggee
        0       5434  gift
        0       4983  gifts
        0       1811  gives
        0          1  giving
        8          1  glade
        0       3443  glass
        0         18  gle
       28      47506  global
        0        113  globo
        0          4  gmail
        0      22537  gmbh
        0         12  gmo
        0        474  gmx
        0         11  godaddy
        0      12568  gold
        0          1  goldpoint
        0      12652  golf
        0          2  goo
        0          1  goodyear
        0        171  goog
        0         83  google
        1       1151  gop
        1          1  got
        0          4  grainger
        0       6696  graphics
        0       3982  gratis
        2       6345  green
        0        894  gripe
        0          1  grocery
        0      84028  group
        8          2  guardian
        0          8  gucci
        0          1  guge
        0      15703  guide
        0        791  guitars
        0      62581  guru
        0        796  hair
        0      20526  hamburg
        0          1  hangout
        0       6653  haus
        0          1  hbo
        0          1  hdfc
        0          2  hdfcbank
        0      22216  health
        0      10133  healthcare
        0      16618  help
        0          8  helsinki
        0          3  here
        0          5  hermes
        8          1  hgtv
        0        491  hiphop
        0         27  hisamitsu
        0         17  hitachi
        0        263  hiv
        0          1  hkt
        0       1279  hockey
        0       7185  holdings
        0       3990  holiday
        0          1  homedepot
        0          1  homegoods
        0      13500  homes
        0          1  homesense
        0          5  honda
        1       2673  horse
        0       2082  hospital
        0      48281  host
        0       3067  hosting
        1          1  hot
        0         51  hoteles
        0          1  hotels
        8         19  hotmail
        0      23215  house
        0       2967  how
        0         15  hsbc
        0          1  hughes
        0         22  hyatt
        0          1  hyundai
        0          1  ibm
        0          1  icbc
        8          8  ice
        0    1031652  icu
        0          6  ieee
        0         43  ifm
        0         27  ikano
        0          2  imamat
        1          1  imdb
        0      17361  immo
        0       6883  immobilien
        0       3243  inc
        0       5199  industries
        0          2  infiniti
    20338    3987658  info
        0          2  ing
        0      41291  ink
        0      13513  institute
        0        205  insurance
        0       5373  insure
        0      26607  international
        0          1  intuit
        0       5401  investments
        0         38  ipiranga
        0       3041  irish
        0         10  ismaili
        2       8211  ist
        8       7278  istanbul
        0         16  itau
        0         14  itv
        0          1  iveco
        8          4  jaguar
        8          4  java
        0         17  jcb
        0          1  jeep
        0       9013  jetzt
        0       3954  jewelry
        0          7  jio
        0         10  jll
        0          3  jmp
        0        117  jnj
        0      38016  jobs
        0       2567  joburg
        1          1  jot
        1          1  joy
        0         22  jpmorgan
        0          4  jprs
        0        563  juegos
        8          1  juniper
        0       5918  kaufen
        0          1  kddi
        8          1  kerryhotels
        8          1  kerrylogistics
        8          1  kerryproperties
        0         42  kfh
        0          3  kia
       33       8968  kim
        0          5  kinder
        1          1  kindle
        0       8122  kitchen
        0      12963  kiwi
        0      25748  koeln
        0         41  komatsu
        0          1  kosher
        0         10  kpmg
        0         48  kpn
        0        601  krd
        0       9387  kred
        8          1  kuokgroup
        0        948  kyoto
        0          1  lacaixa
        0        239  lamborghini
        0          1  lamer
        0          7  lancaster
        0          1  lancia
        0      17169  land
        8          4  landrover
        0         11  lanxess
        0          1  lasalle
        0       4983  lat
        0          1  latino
        0         23  latrobe
        1      16392  law
        0      10098  lawyer
        0          1  lds
        0       1796  lease
        0        846  leclerc
        8          1  lefrak
        0      14636  legal
        8          2  lego
        0          3  lexus
        0       2998  lgbt
        0         42  lidl
        0     224748  life
        0          1  lifeinsurance
        0          1  lifestyle
        0       5853  lighting
        1          1  like
        0          3  lilly
        0       6185  limited
        0       1775  limo
        0          2  lincoln
        8         93  linde
        6     153502  link
        8         63  lipsy
        0     411445  live
        0          1  living
        0          2  lixil
        7      18614  llc
        2          1  llp
        0       6825  loan
        0       4702  loans
        0          1  locker
        1         17  locus
        0          1  loft
        0      12685  lol
        1      49053  london
        0          1  lotte
        0         65  lotto
        0      33570  love
        0          1  lpl
        0          1  lplfinancial
        0     109436  ltd
        0        673  ltda
        8        105  lundbeck
        1       3554  luxe
        0       1777  luxury
        0          1  macys
        0       3109  madrid
        8          6  maif
        0       1120  maison
        0        600  makeup
        0        168  man
        0      11473  management
        0         45  mango
        0          1  map
        0      19239  market
        0      25620  marketing
        8       1063  markets
        0         16  marriott
        0          1  marshalls
        0          1  maserati
        0          6  mattel
        0       2864  mba
        0          1  mckinsey
        8          4  med
        0      58255  media
        0         49  meet
        0       6785  melbourne
        0          2  meme
        0        594  memorial
        0      12415  men
        0       6512  menu
        0          1  merckmsd
        1      13614  miami
        8         91  microsoft
        0        410  mini
        0          1  mint
        0          3  mit
        0          1  mitsubishi
        0         35  mlb
        0          1  mls
        0       1640  mma
      303     327363  mobi
        0          1  mobile
        0       2572  moda
        0       9923  moe
        1        256  moi
        0       2942  mom
        0         59  monash
        0      14249  money
        0     135198  monster
        0          1  mormon
        0       3674  mortgage
        2      16331  moscow
        0          1  moto
        0        213  motorcycles
        0          2  mov
        0       3401  movie
        0          1  msd
        0          5  mtn
        0          3  mtr
        0        755  museum
        0          3  mutual
        8          3  nab
        0       4402  nagoya
        8          1  nationwide
        0          4  natura
        0        839  navy
        0          1  nba
        0          8  nec
        0   13184860  net
        0          5  netbank
        0          1  netflix
        0      60562  network
        0        675  neustar
        0       1090  new
        0      70831  news
        8          6  next
        8          1  nextdirect
        0          1  nexus
        0          2  nfl
        0       3752  ngo
        0          1  nhk
        0         11  nico
        0          2  nike
        8          1  nikon
        0      32880  ninja
        0          5  nissan
        8          1  nissay
        0          4  nokia
        0          3  northwesternmutual
        8          1  norton
        1          1  now
        0          6  nowruz
        0          1  nowtv
        0        132  nra
        0      16735  nrw
        0         14  ntt
        0      63254  nyc
        8          1  obi
        0       1191  observer
        8          1  off
        0          6  office
        0       4200  okinawa
        0          2  olayan
        0          2  olayangroup
        0          1  oldnavy
        0          1  ollo
        8          3  omega
        0      88701  one
        0       3752  ong
        3       7346  onl
        0    1751370  online
        8          1  onyourside
        0       9547  ooo
        0          1  open
        8          3  oracle
        8          5  orange
     8171   10341131  org
        1       1691  organic
        0          1  origins
        0        758  osaka
        0         16  otsuka
        0          1  ott
        0      60802  ovh
        0     146218  page
        0          1  panasonic
        2      20010  paris
        0          1  pars
        0      10273  partners
        0       6487  parts
        0      19442  party
        0          2  passagens
        1          1  pay
        0          1  pccw
        2      11561  pet
        0         12  pfizer
        0        567  pharmacy
        0          1  phd
        0         21  philips
        0          1  phone
        0      18042  photo
        0      44505  photography
        0      22665  photos
        0       1187  physio
        0       5940  pics
        8         52  pictet
        0       8329  pictures
        0          1  pid
        1          1  pin
        0          3  ping
       14       6234  pink
        0          8  pioneer
        0       8163  pizza
        0       5979  place
        0          1  play
        0          1  playstation
        0       2707  plumbing
        0      25816  plus
        0          1  pnc
        0          3  pohl
        4       3403  poker
        4          7  politie
        0      10071  porn
        0          1  pramerica
        0         17  praxi
        0      28489  press
        1          1  prime
     1246     266133  pro
        0          2  prod
        0       9079  productions
        0          2  prof
        0          1  progressive
        4       5933  promo
        0      14503  properties
        0       2814  property
        0         91  protection
        0         78  pru
        0         70  prudential
        0      21529  pub
        0          2  pwc
        0        243  qpon
        0       6809  quebec
        0        564  quest
        0          1  qvc
        0       3501  racing
        0       2626  radio
        8          1  raid
        1          1  read
        8      16195  realestate
        8      40805  realtor
        0      17947  realty
        0       4936  recipes
       38      20622  red
        0         11  redstone
        0          2  redumbrella
        0       1964  rehab
        0       1059  reise
        0       4713  reisen
        0         88  reit
        0          1  reliance
        0      17462  ren
        0       4915  rent
        0      11689  rentals
        0       7214  repair
        0       8479  report
        0        961  republican
        0      32810  rest
        0       7685  restaurant
        0      11473  review
        0      14180  reviews
        8         11  rexroth
        0         84  rich
        0          1  richardli
        0         29  ricoh
        0          1  ril
        0        787  rio
        0       5060  rip
        0          6  rmit
        0          2  rocher
        0      80983  rocks
        1        997  rodeo
        0          1  rogers
        1          1  room
        0          2  rsvp
        0        299  rugby
        0       9762  ruhr
        0      22250  run
        8          2  rwe
        0        564  ryukyu
        0       4024  saarland
        1          1  safe
        0          1  safety
        0          2  sakura
        0      11528  sale
        0       3149  salon
        0          1  samsclub
        0          7  samsung
        0         29  sandvik
        0          7  sandvikcoromant
        8         12  sanofi
        0         27  sap
        0       1002  sarl
        0          2  sas
        1          1  save
        0         84  saxo
        0         85  sbi
        8          1  sbs
        8          1  sca
        3         34  scb
        0         16  schaeffler
        0         36  schmidt
        0          1  scholarships
        0      20136  school
        0       3666  schule
        0        236  schwarz
        0      13912  science
        8          1  scjohnson
        0      12678  scot
        0          1  search
        0        745  seat
        1          1  secure
        0        338  security
        0          1  seek
        0        296  select
        8         44  sener
        0      54484  services
        8          3  ses
        0          6  seven
        0         16  sew
        0       7470  sex
        0       5881  sexy
        0          7  sfr
        8          1  shangrila
        0         19  sharp
        0          1  shaw
        8         30  shell
        0          1  shia
        1        839  shiksha
        0       4759  shoes
        0     783186  shop
        0       6657  shopping
        0          1  shouji
        0      17016  show
        0          1  showtime
        1          1  silk
        0          1  sina
        0       3394  singles
        0    1194848  site
        0       5674  ski
        0        570  skin
        8         64  sky
        0          6  skype
        0          1  sling
        0         35  smart
        1          1  smile
        0         31  sncf
        0       2885  soccer
        0      23557  social
        0          5  softbank
        0      17440  software
        0          6  sohu
        0       8045  solar
        0      83566  solutions
        0          1  song
        0          6  sony
        0       1452  soy
        0     324694  space
        0       9162  sport
        1          1  spot
        0          7  spreadbetting
        4       6046  srl
        0        114  stada
        0          1  staples
        0          1  star
        0         30  statebank
        0         30  statefarm
        0          8  stc
        0          1  stcgroup
        0         96  stockholm
        0        407  storage
        0     511169  store
        0      18008  stream
        0      74144  studio
        0       2070  study
        0      11804  style
        0      13141  sucks
        0       3307  supplies
        0       6618  supply
        0      28004  support
        1       8915  surf
        0       1696  surgery
        0         12  suzuki
        8          8  swatch
        0          1  swiftcover
        0      17980  swiss
        0       6977  sydney
        0      32852  systems
        0          1  tab
        0       2027  taipei
        1          1  talk
        0          1  taobao
        0          2  target
        8          5  tatamotors
        0        841  tatar
        0       1658  tattoo
        0       8613  tax
        0       5855  taxi
        0          1  tci
        0          1  tdk
        0      33723  team
        0     327360  tech
        0      33411  technology
      141      56036  tel
        0          9  temasek
        0       1677  tennis
        0         79  teva
        0          1  thd
        0       1200  theater
        0        120  theatre
        8          1  tiaa
        0        776  tickets
        0       2241  tienda
        8          1  tiffany
        0      26151  tips
        0        848  tires
        0       7396  tirol
        0          1  tjmaxx
        0          1  tjx
        0          1  tkmaxx
        0          1  tmall
        0     102342  today
        0     190173  tokyo
        0      15826  tools
      783    1295785  top
        0         60  toray
        0          5  toshiba
        0        104  total
        0      10257  tours
        0       4817  town
        0         10  toyota
        0       4894  toys
        0      19056  trade
        8       1445  trading
        0      21826  training
       12      21373  travel
        8          1  travelchannel
        0          3  travelers
        0          2  travelersinsurance
        0         54  trust
        0          2  trv
        0       3374  tube
        0         18  tui
        1          1  tunes
        1          1  tushu
        0          1  tvs
        8          1  ubank
        8          2  ubs
        0          2  unicom
        0       6885  university
        0      24344  uno
        0         47  uol
        0          2  ups
        0       3388  vacations
        0          1  vana
        8         13  vanguard
        0      13295  vegas
        0      16461  ventures
        0          1  verisign
        0       1592  versicherung
        0       7664  vet
        0       1140  viajes
        0      22289  video
        0         18  vig
        0          1  viking
        0       1682  villas
        0       6191  vin
        1     839671  vip
        1          1  virgin
        8          1  visa
        0       9246  vision
        0          1  viva
        0         36  vivo
        2       6227  vlaanderen
        1       1639  vodka
        0          4  volkswagen
        8          1  volvo
       12       4633  vote
        0        211  voting
        0        397  voto
        0       2555  voyage
        0          2  vuelos
        1      13466  wales
        0          1  walmart
        0         20  walter
        0     247947  wang
        1          1  wanggou
        0       8398  watch
        0          1  watches
        0          1  weather
        0          1  weatherchannel
        0       3511  webcam
        8        157  weber
        0     304330  website
        1      15254  wedding
        0          1  weibo
        8        145  weir
        0        915  whoswho
        0      15775  wien
        0      21095  wiki
        0         21  williamhill
        0      66075  win
        8         22  windows
        0      16752  wine
        0          1  winners
        0          6  wme
        0          1  wolterskluwer
        0         17  woodside
        1     579543  work
        0      24078  works
        0     126734  world
        1          1  wow
        0          1  wtc
        0      22030  wtf
        8         57  xbox
        8          3  xerox
        1          1  xfinity
        0          1  xihuan
       18      31702  xin
        0          1  xn--11b4c3d
        0        109  xn--1ck2e1b
        0        202  xn--1qqw23a
        2          7  xn--30rr7y
        0       2641  xn--3bst00m
        0      23133  xn--3ds443g
        0          1  xn--3oq18vl8pn36a
        0          1  xn--3pxu8k
        0          1  xn--42c2d9a
        0         42  xn--45q11c
        0        139  xn--4gbrim
        0         45  xn--55qw42g
        0      32589  xn--55qx5d
        8          1  xn--5su34j936bgsg
        0        682  xn--5tzm5g
        1       1355  xn--6frz82g
        0      15045  xn--6qq986b3xl
        0      13286  xn--80adxhks
        0          1  xn--80aqecdr1a
        0       2647  xn--80asehdb
        0        887  xn--80aswg
        0          2  xn--8y0a063a
        8       1658  xn--9dbq2a
        3          1  xn--9et52u
        0          1  xn--9krt00a
        0          1  xn--b4w605ferd
        0         42  xn--bck1b9a5dre4c
        1        964  xn--c1avg
        0          1  xn--c2br7g
        0        147  xn--cck2b3b
        1          1  xn--cckwcxetd
        0          2  xn--cg4bki
        0      24836  xn--czr694b
        0        798  xn--czrs0t
        0      21836  xn--czru2d
        0        782  xn--d1acj3b
        0          1  xn--eckvdtc9d
        2          7  xn--efvy88h
        0         69  xn--fct429k
        0          1  xn--fhbei
        0       2713  xn--fiq228c5hs
        0        175  xn--fiq64b
        0        149  xn--fjq720a
        0          1  xn--flw351e
        0          1  xn--fzys8d69uvgm
        0       2307  xn--g2xx48c
        0         63  xn--gckr3f0f
        0          1  xn--gk3at1e
        0       4825  xn--hxt814e
        1         70  xn--i1b6b1a6a2e
        0        171  xn--imr513n
        0      22025  xn--io0a7i
        0          1  xn--j1aef
        1          1  xn--jlq480n2rg
        0          1  xn--jlq61u9w7b
        0         56  xn--jvr189m
        0          9  xn--kcrx77d1x4a
       60      30563  xn--kput3i
        0          2  xn--mgba3a3ejt
        0          2  xn--mgba7c0bbn0a
        0          1  xn--mgbaakc7dvf
        0        543  xn--mgbab2bd
        0         30  xn--mgbca7dzdo
        0          1  xn--mgbi4ecexp
        0          1  xn--mgbt3dhd
        8       4610  xn--mk1bu44c
        2          1  xn--mxtq1m
        0        576  xn--ngbc5azd
        0         10  xn--ngbe9e0a
        2          1  xn--ngbrx
        1        315  xn--nqv7f
        0          1  xn--nqv7fs00ema
        0         25  xn--nyqy26a
        0         84  xn--otu796d
        0      33224  xn--p1acf
        0          1  xn--pssy2u
        0        932  xn--q9jyb4c
        0          1  xn--qcka1pmc
        0        603  xn--rhqv96g
        0         34  xn--rovu88b
        0     141007  xn--ses554g
        8       1152  xn--t60b56a
        8       3301  xn--tckwe
        0          1  xn--tiq49xqyj
        0        193  xn--unup4y
        0          2  xn--vermgensberater-ctb
        0          2  xn--vermgensberatung-pwb
        0       2292  xn--vhquv
        0       2155  xn--vuq861b
        8          1  xn--w4r85el8fhu5dnra
        8          1  xn--w4rs40l
        0        395  xn--xhq521b
        0         61  xn--zfr164b
        0      91521  xxx
        0    2966973  xyz
        0        276  yachts
        0          1  yahoo
        1          1  yamaxun
        0         62  yandex
        0          1  yodobashi
        1      18070  yoga
        0       4158  yokohama
        1          1  you
        0          8  youtube
        0          1  yun
        1          2  zappos
        0          4  zara
        0          1  zero
        0          2  zip
        0      31011  zone
        0          3  zuerich

---

From: Paul Wouters <[email-masked]>
Date: Sun, 7 Mar 2021 15:23:19 -0500 (EST)

>  www.whois.biz.     cname   whois.nic.biz.

The _prefix records are not a problem, as these are exempted by the
draft. Semantically, these records state something about the zone itself
and cannot be mistaken for a delegation.

The whois and nic records are common in TLDs. I thought it would be
better not to have hardcoded exceptions, and just have people do the
minor change of converting these into real delegations.

Note that the count presented has other issues too. For example,
the first pseudo random domain I picked to look further from the top
of the file:

info.txt.gz:ns1.breeat.info.	86400	in	rrsig	a	7	3	86400	20201123152255	20201102142255	27464	info.	cDhuFyGRJqi2uJnAuYMuHguwvHQx498oIQawSOXNBMxewSnudEeeElsgXXw3vuN1t+tOX2v9Y+WMdB5Wh3I1gkon3xxC6ZX2njDq5wcqDNFIm/pGpZkM2Bwv/7uzU9Hx8r+Lmn3lNgyhEKFc0f/H8ESveGw93jK/bkoQnjQf5qI=
info.txt.gz:ns1.breeat.info.	86400	in	rrsig	a	8	3	86400	20201123152255	20201102142255	44286	info.	Kx2nR9MxG2NDbO8pYGlwET5JFjvIJnYMswvptkU/oqj2a5bb4i1qU9cBQg6P5zZ7ekstxCJjV08HyUkh30b9Sn/sCJovVA+OEoOEef4r+yij2XQN93kvli19fqNDfNPEnO8fQqZ3ifcvFvs8S1EEJKlcPVSsnlSVnFPPRVlye/U=
info.txt.gz:ns2.breeat.info.	86400	in	rrsig	a	7	3	86400	20201123152255	20201102142255	27464	info.	mVxcu2heoUVOuahh9GODtZBMomdYZ1MsiJ41nYAgf0SCUy8oD9qJ/7yCFZg7WOyiGNUHEtuyBBAyj6DxKbSURDOhZ3Auarha298bo2z4n8Q4HIBMjFWE4imQ9K9ZayB8j2uG8i7V8l7asnbGKvM1b4C7fnB43pY7L9pt8xcAIZc=
info.txt.gz:ns2.breeat.info.	86400	in	rrsig	a	8	3	86400	20201123152255	20201102142255	44286	info.

These are 4 RRSIG for 2 name servers with an A record for which the
domain no longer exists.  Note that ns1 and ns2 point to the same single
IP address. I don't know how many other zones use these two nameservers,
but a quick check shows that there are no DNS server running on that IP
address anyway.

The TLD might as well just remove the glue. It is just garbage. It only
causes users longer timeouts into the inevitable failure of reaching those
nameservers. That is, actually not having these records is an _advantage_
over having them.

I don't have access to the original data used here, but it would be
interesting to know what percentage of this glue actually keeps a
domain running, and what percentage is just a futile attempt to keep
up a dying domain but only causing delay without gains.

I also cannot see if domains using these nameservers are still up at
all, running on other nameservers that are not running on promoted glue.
That would also be interesting to know. Perhaps someone with access to
the original data could run a script to determine that.

Regardless, as explains before. The problem is not hard to solve by
moving the signed glue into its own delegated special zone, which would
have the benefit of _clearly_ indicating to anyone who sees these NS
records that the domain is about to fall over. It is an improvement to
do this even if you don't do it to prepare for being a delegation_only
zone.

Based on this and the recent .org glue cleanup, I think there might even
be a good reason to write up a new draft about promoting-stale-glue-is-bad.

Paul

---

From: Joe Abley <[email-masked]>
Date: Sun, 7 Mar 2021 18:03:41 -0500

On 7 Mar 2021, at 15:23, Paul Wouters <[email-masked]> wrote:

> domain no longer exists.

Just a point of clarification -- the domain does exist; it's just suppressed from publication in the DNS.

jabley@manta ~ % whois -h whois.afilias.net breeat.info | fgrep Status
Domain Status: clientTransferProhibited https://icann.org/epp#clientTransferProhibited
Domain Status: serverHold https://icann.org/epp#serverHold
Domain Status: autoRenewPeriod https://icann.org/epp#autoRenewPeriod
jabley@manta ~ % 

When it comes to TLD zones, it's necessary to consider the registry data as well as the DNS if you want to be sure you are seeing the whole picture.

>  Note that ns1 and ns2 point to the same single

gTLD operators can't just remove things that in its opinion are not working or not necessary. The things they can and can't do are constrained by contract. I appreciate that there are many registries that are not run by contracted parties, of course.

In general, it's difficult to know for sure what the impact of removing a linked glue record is. A nameserver that doesn't respond today might be fixed tomorrow, or might never be fixed for particular clients due to some other local policy. There may well be extraneous orphan glue records (in the DNS sense) in the ORG zone that could safely be removed, but it's difficult to know for sure unless you have certain knowledge about the names concerned and the intensions of the organisations involved in them. There are definitely orphan glue records (same sense) whose removal would cause operational problems for other domains.

[...]

> be a good reason to write up a new draft about promoting-stale-glue-is-bad.

You should feel very free to write up whatever you want :-) but as I have mentioned a few times, so long as there are reasons to suppress publication of zone cuts for particular domains, e.g. for reasons of abuse management, and so long as it's possible to link subordinate host objects to other domain objects that *are* published, and so long as the data model specified in EPP remains as it is, the number of promoted glue records in zones like ORG are not going to reach zero and suppressing orphan glue (orphan in the DNS sense, not the registry sense) definitely has the potential to break things.

I don't think you make something a problem by calling it one. These things are only problems because you have a use-case for zones like these being delegation only, and the reality of how these zones are constructed doesn't fit nicely with that. I also don't think you can solve a problem by declaring the solution to be simple on the grounds that you've ignored all the things that would otherwise make the solution complicated :-)

Joe

---

From: "John Levine" <[email-masked]>
Date: 7 Mar 2021 18:16:01 -0500

>and NSEC(3) RRs, with the NS RRs and glue A RRs unsigned.

I poked around and agree with you that there isn't much other than A
and AAAA signed glue-ish records. There's a few SRV records. I don't
think any TLD other than .biz has CNAMEs. There are a lot of MX in
.NAME which is a rather peculiar TLD.

But as I said in November, there is a lot of signed glue, it is not going away,
and this draft does not match reality.  Nothing has changed and I don't see any
reason to waste more time with it.

R's,
John

---

From: Paul Wouters <[email-masked]>
Date: Wed, 24 Mar 2021 21:35:11 -0400 (EDT)

On Sun, 7 Mar 2021, John Levine wrote:

> and AAAA signed glue-ish records.

> and this draft does not match reality.

A solution was given for moving signed glue to its own sub zone. I understand
you don't think that solution works for you. That is fine.

> Nothing has changed and I don't see any reason to waste more time with it.

I think there could be TLDs and SLDs that want to deploy this single
bit. If you want to stop wasting time, you could just let those who want
it have the code point.

Paul

---

From: "John R Levine" <[email-masked]>
Date: 24 Mar 2021 22:08:10 -0400

> you don't think that solution works for you. That is fine.

But that makes the false assumptions that there is a problem to be solved, 
and that glue is the only thing other than NS found in TLD zones.

> I think there could be TLDs and SLDs that want to deploy this single > bit.

Could you identify the TLDs, please?  The TLDs I have talked to have 
shown no interest at all in this hack.

> If you want to stop wasting time, you could just let those who want
> it have the code point.

Um, I am pretty sure I am not the code point police.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly