Subject: [DNSOP] Moving forward on draft-ietf-dnsop-private-tld

From: Roy Arends <[email-masked]>
Date: Fri, 30 Jul 2021 19:20:43 +0100

Dear WG

About 40 years ago, give or take, when Jon Postel planned to use the ISO3166 two character code elements as top level domains representing country names, ISO's TC46 secretariat was contacted (as was requested to users of the ISO3166 standard at the time) and he was told that the standard should not be used for DNS, as the future was in X.500. (Postel wasn’t swayed by the argument, and did what we now refer to as permission-less innovation).

Recently, the ISO was contacted again, and subsequently the WG was again told that the standard wasn’t to be used in this way. It seems that a handful of folks are swayed by the argument and want to use this as guidance for the future of draft-ietf-dnsop-private-tld.

Early on, Joe Abley proposed a way forward that I held off initially: Recognise that User Assigned 3166 code elements are used in various ways, including private networks, that these elements have not been delegated and are known to be used to anchor private namespaces. Do not recommend, promote or reserve anything, no registries. Document potential future pitfalls for using these codes for private namespaces and empower readers to make their own decisions.

I now see that with the current status quo, this might a way forward that both sides of the argument might come together on. Essentially, instead of making the pond safe, we’ll have a warning sign that using the pond is at their own risk.

I hope the WG can come together on this as a way forward. 

Warmly,

Roy

---

From: Paul Wouters <[email-masked]>
Date: Fri, 30 Jul 2021 14:29:09 -0400

> I hope the WG can come together on this as a way forward. 

Please start a BOF and discuss this outside of dnsop. At dnsop, we don’t have time for any more Special Use domains discussions. 

We are seeing the WG dropping actual protocol work because of these discussions. I now consider these discussions harmful.

Sorry,

Paul

---

From: Roy Arends <[email-masked]>
Date: Fri, 30 Jul 2021 19:33:02 +0100

> On 30 Jul 2021, at 19:29, Paul Wouters <[email-masked]> wrote:
> 
> 

This is a working group draft, and should be discussed in the WG.

Roy

---

From: Joe Abley <[email-masked]>
Date: Fri, 30 Jul 2021 14:38:22 -0400

Hi Paul,

> We are seeing the WG dropping actual protocol work because of these discussions. I now consider these discussions harmful.

I think we've seen the working group drop particular proposed efforts for a variety of reasons. I don't think it's accurate to characterize them all (or any of them, to be honest) as victims to some special names obsession.

Sometimes the working group just doesn't like particular ideas, and we move on. Harmful is in the eye of the beholder, perhaps. 

Joe

---

From: Paul Wouters <[email-masked]>
Date: Fri, 30 Jul 2021 14:43:31 -0400

> This is a working group draft, and should be discussed in the WG.

So was draft-ietf-dnsop-delegation-only until it was killed yesterday due to lack of time because we had to spend it on political discussions with ISO liaisons.

Paul

---

From: Paul Wouters <[email-masked]>
Date: Fri, 30 Jul 2021 14:55:39 -0400

> I think we've seen the working group drop particular proposed efforts for a variety of reasons. I don't think it's accurate to characterize them all (or any of them, to be honest) as victims to som…

We had a discussion yesterday about how do just don’t have enough time. We had a survey about prioritization because we don’t have enough time. It is all about dnsop resources. I believe my characterization is accurate. That is independent of one of my drafts being nixed for lack of time in the WG. You can look back and see me critique the WG on time spent on Special Use domains going back several years. We never reach agreement, always conclude we are not the right group. We even vowed to stop talking about and and then reneged on that (although Suzan and I disagree on the history there)

> Sometimes the working group just doesn't like particular ideas, and we move on.

That’s not what happened. When adopted people felt it was an experiment that could be done even if half the group felt there was no use for it. The document then simply was never moved further by the chairs. It would have been fine if during a WGLC people said this is a bad idea after all. But that is not what happened. What happened is that the WG instead took on .zz and then threw .alt in there and then we had another couple of face time meetings in these things that just never see consensus because the WG is very vocally split.

> Harmful is in the eye of the beholder, perhaps. 

We literally had a survey to ask us “what should we kill because we don’t have enough time” and yet we keep talking about ISO and now Roy wants to keep talking about ISO after ISO said “don’t do that”. Yeah, it’s an objective harmful waste of time. Sorry if that sounds harsh.

Paul

---

From: Joe Abley <[email-masked]>
Date: Fri, 30 Jul 2021 15:45:33 -0400

Hi Paul,

On Jul 30, 2021, at 14:55, Paul Wouters <[email-masked]> wrote:

> We literally had a survey to ask us “what should we kill because we don’t have enough time”

I don't think that's exactly the question I saw, but perhaps I misremember. 

For what it's worth (and as you know from our conversations about it on this list) I disliked your delegation-only draft on its merits and not because of lack of time. 

If the working group expresses similar sentiments about the 3166 private use codepoint draft I will be similarly disappointed, because I think there's non-zero value in documenting where we got to and I don't think it will be much work to do so. But life will go on. 

It's a shame we have to have these conversations exclusively over email instead of in a bar. I'm buying when we get to travel again. 

Joe

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 30 Jul 2021 22:03:56 +0000

Hi Roy, WG,

Roy, just for clarity, am I right to presume that the status of the document that you propose would purely be informational?

It is, of course, up to the WG to decide what to do with this document, but I would like to make a couple of comments that may help the WG.

I would like to somewhat echo a point that was made in DNSOP yesterday when this draft was being discussed, in that I don't believe that IETF should publish a document that either directly or indirectly undermines ISO TC46's ownership or authority over the ISO3166 code points.  I believe that this concern is likely shared by other ADs.

Hence, if the WG decides to progress this document with the proposed structure below, then I'm not convinced that just documenting that these code points exist and that some people use them would be sufficient.  Given the informal liaison feedback that was received, I think that the IETF would likely need to adopt stronger wording that proactively recommends that these country codes are not used for private networks, and highlights the potential problems with doing so.

Regards,
Rob
// Ops AD

-----Original Message-----
From: DNSOP <[email-masked]> On Behalf Of Roy Arends
Sent: 30 July 2021 19:21
To: dnsop <[email-masked]>
Subject: [DNSOP] Moving forward on draft-ietf-dnsop-private-tld

Dear WG

Warmly,

Roy

_______________________________________________
DNSOP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dnsop

---

From: "John Levine" <[email-masked]>
Date: 30 Jul 2021 18:10:56 -0400

>For what it's worth (and as you know from our conversations about it on this list) I disliked your delegation-only draft on its merits and not because of lack of time. 

Same here.  I think the WG had plenty of reasons not to advance it.

R's,
John

---

From: Wes Hardaker <[email-masked]>
Date: Fri, 30 Jul 2021 15:34:30 -0700

Roy Arends <[email-masked]> writes:

> Essentially, instead of making the pond safe, we’ll have a warning
> sign that using the pond is at their own risk.

The wording of said warning sign is the critical element, IMHO.
Certainly my support of the document greatly depends on said wording.

In the end, there should be a goal behind why we want to publish
something.  If that goal is "know people do this.  don't do this.
please stop", then that may be a reasonable goal.  If we're just going
to document history, without recommendations (to stop), then I think it
may bring more harm than good.

-- 
Wes Hardaker
USC/ISI

---

From: Benno Overeinder <[email-masked]>
Date: Sat, 31 Jul 2021 13:45:45 +0200

Hi Paul, Working Group,

> So was draft-ietf-dnsop-delegation-only until it was killed yesterday due to lack of time because we had to spend it on political discussions with ISO liaisons.

To be clear, the discussion of the poll and priorities was informative 
and no decisions have been made about dropping WG documents yet.  Your 
argument that the document got delayed due to other more pressing drafts 
is acknowledged.

We also hold off the suggestion to raise hands for alt-tld draft in a 
similar way.  The poll helped the discussion, but is only part of the 
discussion.  For the individual drafts, the DNSOP chairs will contact 
the authors and discuss the way forward with the WG.

Best regards,

-- Benno

---

From: Ray Bellis <[email-masked]>
Date: Sat, 31 Jul 2021 16:47:44 +0100

On 30/07/2021 19:29, Paul Wouters wrote:

> We are seeing the WG dropping actual protocol work because of these
> discussions.
If only we had a working group for discussing DNS Extensions...

Ray

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 31 Jul 2021 16:38:17 +0000

On Jul 31, 2021, at 4:45 AM, Benno Overeinder <[email-masked]> wrote:
> For the individual drafts, the DNSOP chairs will contact the authors and discuss the way forward with the WG.

During the meeting, there was a call for more transparency, and co-chair Tim strongly agreed with it.

Please strongly consider reversing those two steps: discuss the way forward with the WG, *then* contact the authors (who should be following the WG anyway...). In the unlikely-but-possible case where the WG wants to move forward on a draft and none of the current authors want to do so, the chairs can ask the list for new volunteer editors. 

--Paul Hoffman

---

From: Василий Долматов <[email-masked]>
Date: Sat, 31 Jul 2021 19:59:04 +0300

> 31 июля 2021 г., в 19:38, Paul Hoffman <[email-masked]> написал(а):
> 
Funny thing when authors are alive, but cannot understand the reason why draft is silently postponed until no time…

Really more transparency is welcome…

dol@

> 
> --Paul Hoffman_______________________________________________
> DNSOP mailing list
> [email-masked]

---

From: Benno Overeinder <[email-masked]>
Date: Sat, 31 Jul 2021 22:01:55 +0200

> Please strongly consider reversing those two steps: discuss the way forward with the WG, *then* contact the authors (who should be following the WG anyway...). In the unlikely-but-possible case whe…

Agree that the WG determines what happens to a document and that is 
discussed by the WG, that is clear. It was merely a sign of courtesy to 
contact the authors of the document first to let them know that it will 
be discussed.

-- Benno