Subject: [DNSOP] Francesca Palombini's No Objection on draft-ietf-dnsop-dns-tcp-requirements-13: (with COMMENT)

From: Francesca Palombini via Datatracker <[email-masked]>
Date: Thu, 28 Oct 2021 02:43:05 -0700

Francesca Palombini has entered the following ballot position for
draft-ietf-dnsop-dns-tcp-requirements-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-dns-tcp-requirements/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for the work on this document. Many thanks to Jean Mahoney for her ART
ART review:
https://mailarchive.ietf.org/arch/msg/art/YAoRhQIrKn4g0L6XFZvV45bWL44/.

I only have one very minor comments, to take or leave as you please:

   headers are 40 bytes (versus 20 without options in IPv4).  Second, it
   seems as though some people have misinterpreted IPv6's required
   minimum MTU of 1280 as a required maximum.  Third, fragmentation in

FP: The "some people" is quite cryptic, in my opinion. What people? Does this
come from analyzing implementations? Then it would probably be good to state so
instead.

Francesca

---

From: "Wessels, Duane" <[email-masked]>
Date: Fri, 29 Oct 2021 23:31:48 +0000

Francesca, thank you for the review.

> On Oct 28, 2021, at 2:43 AM, Francesca Palombini via Datatracker <[email-masked]> wrote:
> 
> 
> 

Perhaps this is better?

   Second, it is common
   for IPv6-connected hosts to use the minimum MTU of 1280 bytes <xref target="PMTU”/>

Where the PMTU reference is "Exploring Usable Path MTU in the Internet” (https://doi.org/10.23919/TMA.2018.8506538)

DW

---

From: Geoff Huston <[email-masked]>
Date: Sat, 30 Oct 2021 00:41:39 +0000

> On 30 Oct 2021, at 10:31 am, Wessels, Duane <dwessels=[email-masked]> wrote:
> 

Hi Duane,

I don't think the use of the term “common” with reference to an MTU of 1280 is all that much better!

The Path MTU paper does not appear to be a terribly good measurement reference in the context of the DNS. The paper cites what they term "IPv6 webservers" for their conclusions. Our observations for DNS recursive resolvers performed in late 2020 show only 30% of those recursive resolvers that were visible to our experiment presenting an MSS of 1220 octets, while 55% presented  an MSS of 1440 octets. (https://www.potaroo.net/ispcol/2020-11/xldns-fig11.png). The measurement was written up at https://www.potaroo.net/ispcol/2020-11/xldns.html

I would suggest “a visible proportion of DNS recursive resolvers present a TCP MSS value that is conistent with a local MTU setting of 1280” or even “Approximately one third of DNS recursive resolvers” and cite the APNIC measurement paper to justify the quantified proportion.

kind regards,

   Geoff