Subject: [DNSOP] I-D Action: draft-ietf-dnsop-glue-is-not-optional-04.txt

From: [email-masked]
Date: Tue, 08 Feb 2022 14:33:55 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Domain Name System Operations WG of the IETF.

        Title           : DNS Referral Glue Requirements
        Authors         : M. Andrews
                          Shumon Huque
                          Paul Wouters
                          Duane Wessels
	Filename        : draft-ietf-dnsop-glue-is-not-optional-04.txt
	Pages           : 10
	Date            : 2022-02-08

Abstract:
   The DNS uses referral glue records to allow iterative clients to find
   the addresses of nameservers that are contained within a delegated
   zone.  Authoritative Servers are expected to return all available
   referral glue records in a referral response.  If message size
   constraints prevent the inclusion of all in-domain referral glue
   records, the server MUST set the TC flag to inform the client that
   the response is incomplete, and that the client SHOULD use another
   transport to retrieve the full response.  This document updates RFC
   1034 to clarify correct server behavior.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-glue-is-not-optional/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-dnsop-glue-is-not-optional-04.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dnsop-glue-is-not-optional-04

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: "Wessels, Duane" <[email-masked]>
Date: Tue, 8 Feb 2022 22:43:38 +0000

Hello DNSOP,

Here is a short summary of the changes between -03 and -04 of this draft:

We use "referral glue" on the assumption that other types of glue may be defined in the future. Not all authors necessarily like this change but we are trying it on for size.

Added an Operational Considerations section.

Noted that many current implementations set TC=1 only when no glue RRs fit. New requirements may lead to more truncation and TCP.

Sibling glue can be optional (hence a title change). Only require TC=1 when all in-domain glue RRs don't fit.

Avoid talking about requirements for UDP/TCP specifically, and talk more generically about message size constraints regardless of transport. However, we added a paragraph describing the current behavior of most iterative clients to start with UDP and fall back to TCP when truncated.

DW

> On Feb 8, 2022, at 2:33 PM, [email-masked] wrote:
> 
> Caution: This email originated from outside the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe. 
>