Subject: Re: [DNSOP] Fwd: New Version Notification for draft-dwmtwc-dnsop-caching-resolution-failures-00.txt

From: Petr Špaček <[email-masked]>
Date: Tue, 8 Feb 2022 14:28:31 +0100

Hello everyone,

it seems that we now have two drafts about the same topic - this new one 
and draft-moura-dnsop-negative-cache-loop.

Perhaps authors could discuss if they are in agreement and could pick one?

Petr Špaček  @  Internet Systems Consortium

On 14. 01. 22 19:14, Wessels, Duane wrote:
> Dear DNSOP,
> 
> In light of some recent events and research, we feel that it could be 
> beneficial to strengthen the requirements around negative caching of DNS 
> resolution failures. Please see the recently submitted Internet Draft 
> referenced below and let us know if you have any feedback.
> 
> DW
> 
> 
>> Begin forwarded message:
>>
>> *From: *<[email-masked] <mailto:[email-masked]>>
>> *Subject: **[EXTERNAL] New Version Notification for 
>> draft-dwmtwc-dnsop-caching-resolution-failures-00.txt*
>> *Date: *January 13, 2022 at 1:28:00 PM PST
>> *To: *Duane Wessels <[email-masked] 
>> <mailto:[email-masked]>>, Matthew Thomas <[email-masked] 
>> <mailto:[email-masked]>>, William Carroll 
>> <[email-masked] <mailto:[email-masked]>>
>>
>> A new version of I-D, 
>> draft-dwmtwc-dnsop-caching-resolution-failures-00.txt
>> has been successfully submitted by William Carroll and posted to the
>> IETF repository.
>>
>> Name:draft-dwmtwc-dnsop-caching-resolution-failures
>> Revision:00
>> Title:Negative Caching of DNS Resolution Failures
>> Document date:2022-01-13
>> Group:Individual Submission
>> Pages:13
>> URL: 
>> https://www.ietf.org/archive/id/draft-dwmtwc-dnsop-caching-resolution-failures-00.txt 
>> <https://www.ietf.org/archive/id/draft-dwmtwc-dnsop-caching-resolution-failures-00.txt>
>> Status: 
>> https://datatracker.ietf.org/doc/draft-dwmtwc-dnsop-caching-resolution-failures/ 
>> <https://datatracker.ietf.org/doc/draft-dwmtwc-dnsop-caching-resolution-failures/>
>> Htmlized: 
>> https://datatracker.ietf.org/doc/html/draft-dwmtwc-dnsop-caching-resolution-failures 
>> <https://datatracker.ietf.org/doc/html/draft-dwmtwc-dnsop-caching-resolution-failures>
>>
>>
>> Abstract:
>>   In the DNS, resolvers employ caching to reduce both latency for end
>>   users and load on authoritative name servers.  The process of
>>   resolution may result in one of three types of responses: (1) a
>>   response containing the requested data; (2) a response indicating the
>>   requested data does not exist; or (3) a non-response due to a
>>   resolution failure in which the resolver does not receive any useful
>>   information regarding the data's existence.  This document concerns
>>   itself only with the third type.
>>
>>   RFC 2308 specifies requirements for DNS negative caching.  There,
>>   caching of type (1) and (2) responses is mandatory and caching of
>>   type (3) responses is optional.  This document updates RFC 2308 to
>>   require negative caching for DNS resolution failures.
>>
>>
>>
>>
>> The IETF Secretariat

---

From: "Wessels, Duane" <[email-masked]>
Date: Tue, 8 Feb 2022 22:16:42 +0000

Hi Petr,

I would say one is a subset of the other, but not exactly the same topic.

draft-moura-dnsop-negative-cache-loop focuses relatively narrowly on one type of resolution failure: delegations in a loop / cyclic dependency as documented in their TusNAME work.

draft-dwmtwc-dnsop-caching-resolution-failures, on the other hand, is intended to cover resolution failures much more broadly. Based on our experience, we observe abnormal behavior in a number of different situations including outages, timeouts, server failures, validation failures, and delegation problems.

We plan to present our draft at the next meeting and I assume the other authors will as well, so that will be a good chance for the working group to give us all feedback.

DW

> On Feb 8, 2022, at 5:28 AM, Petr Špaček <[email-masked]> wrote:
> 
> Hello everyone,
> 
> it seems that we now have two drafts about the same topic - this new one and draft-moura-dnsop-negative-cache-loop.
> 
>> In light of some recent events and research, we feel that it could be beneficial to strengthen the requirements around negative caching of DNS resolution failures. Please see the recently submitted Internet Draft referenced below and let us know if you have any feedback.
>> DW
>>> Begin forwarded message:
>>> 
>>> *Subject: **[EXTERNAL] New Version Notification for draft-dwmtwc-dnsop-caching-resolution-failures-00.txt*
>>> *To: *Duane Wessels <[email-masked] <mailto:[email-masked]>>, Matthew Thomas <[email-masked] <mailto:[email-masked]>>, William Carroll <[email-masked] <mailto:[email-masked]>>
>>> 
>>> A new version of I-D, draft-dwmtwc-dnsop-caching-resolution-failures-00.txt
>>> URL: https://secure-web.cisco.com/1-PFLv-gJPKY7IUv53FHemsD97LSSdToCXsQHAguzJmIyVR8DlgbIUfK3NQBXH-5zgoS4DQIIvAT9SMf0y632bk-kgt0veCCWPt9eqKvdmUM_8bz-jZwYAtW9vzG8Yle7Gp7sv_jeafkAwZw5L2kCkJgy4hfNVxUERJJyCxnWI88uVj_yjKi5NiJgO5ANYPWUfYKdg_SnWCnWUDLuwAgLHaD476ZKPPsK82E0W_s8SJOQoH4OGG9glsNw5_92tWYg/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-dwmtwc-dnsop-caching-resolution-failures-00.txt <https://secure-web.cisco.com/1-PFLv-gJPKY7IUv53FHemsD97LSSdToCXsQHAguzJmIyVR8DlgbIUfK3NQBXH-5zgoS4DQIIvAT9SMf0y632bk-kgt0veCCWPt9eqKvdmUM_8bz-jZwYAtW9vzG8Yle7Gp7sv_jeafkAwZw5L2kCkJgy4hfNVxUERJJyCxnWI88uVj_yjKi5NiJgO5ANYPWUfYKdg_SnWCnWUDLuwAgLHaD476ZKPPsK82E0W_s8SJOQoH4OGG9glsNw5_92tWYg/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-dwmtwc-dnsop-caching-resolution-failures-00.txt>
>>> Status: https://secure-web.cisco.com/1DyTvZbisHjKnPovlyhjAOtHxDAwKAqB2zXhGz5eE0Ca-1XPZAqQhDEyq-XNf1nKXr9SySf_nEWu5XQkh450f2xF3gmfQKMuLIyBqZqbYTfqZyyMbWrcyG3KqVYjmGV6dL3NSnwTn0iXcgzWvT7mLCzivYnGbpRH23V8z4fqw3ikCCp6NwxyuP8O_ak1u03fM9kH0QYTu_C1vGE3rGAn7dFkT0A4Vk3mRhgnZSlh3vhaJmDWMO1xylYlPvJBQ40Af/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dwmtwc-dnsop-caching-resolution-failures%2F <https://secure-web.cisco.com/1DyTvZbisHjKnPovlyhjAOtHxDAwKAqB2zXhGz5eE0Ca-1XPZAqQhDEyq-XNf1nKXr9SySf_nEWu5XQkh450f2xF3gmfQKMuLIyBqZqbYTfqZyyMbWrcyG3KqVYjmGV6dL3NSnwTn0iXcgzWvT7mLCzivYnGbpRH23V8z4fqw3ikCCp6NwxyuP8O_ak1u03fM9kH0QYTu_C1vGE3rGAn7dFkT0A4Vk3mRhgnZSlh3vhaJmDWMO1xylYlPvJBQ40Af/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dwmtwc-dnsop-caching-resolution-failures%2F>
>>> Htmlized: https://secure-web.cisco.com/1MtdsiBy0XYrTWaww2jsyGmhpR1_l4cfsY2lzwq4M4gkF3VU-omPqy4e66hhbK7hfsy_x0cC1ZTi4VBXdrxpcOJPQgL-NdJ6b_iqYKCiDtAXs-6A60hPQqq4UZ7C7A1iyL29ghpvCZWMAvER26fj-YW4tmLvr5avpsjTGdZZTCIzvskQ9Nn-Degm8WJ03ldm01hMS6gB7ditarcN0g-dAl6zKyLmHKLy-txj3g8mNMsKTuTmkkE7vXFX-YxgBfJel/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-dwmtwc-dnsop-caching-resolution-failures <https://secure-web.cisco.com/1MtdsiBy0XYrTWaww2jsyGmhpR1_l4cfsY2lzwq4M4gkF3VU-omPqy4e66hhbK7hfsy_x0cC1ZTi4VBXdrxpcOJPQgL-NdJ6b_iqYKCiDtAXs-6A60hPQqq4UZ7C7A1iyL29ghpvCZWMAvER26fj-YW4tmLvr5avpsjTGdZZTCIzvskQ9Nn-Degm8WJ03ldm01hMS6gB7ditarcN0g-dAl6zKyLmHKLy-txj3g8mNMsKTuTmkkE7vXFX-YxgBfJel/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-dwmtwc-dnsop-caching-resolution-failures>
>>> 
>>> 
>>> Abstract:
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://secure-web.cisco.com/19zpX2nlFp-gPK0VZMG2uiiTOI6BMpyoMtbbgEDzyI50SnGa4fn2o00VJknIEpJCeAD-SutwhS_R6D-lTdmMGapb88qgTDIj_ZienwZkTCbAAVSP51RXNGmef_YtOU0euykdEeTkMdxpWaGqkTdnomxxiTdzEeVBubXUGQyf4gNWOne_JWrQlmGQqfogJjW55mRWOq4ITBICB0dqqDmlLCAcZlACYW5HM50hrFYpSDcjXh13eDwDLkqzI2MtDxSjv/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdnsop