Subject: Re: [dnssd] WGLC for draft-ietf-dnssd-srp

From: Tim Wicinski <[email-masked]>
Date: Mon, 2 Aug 2021 14:16:01 -0400

I've read the document and I think it is ready to be published.

My one nit before moving forward is the authors run the nits tool and
address the messages about updating references.

tim

On Wed, Jul 28, 2021 at 5:57 PM David Schinazi <[email-masked]>
wrote:

> Hi DNSSD enthusiasts,
>
> This email starts an official Working Group Last Call
> for draft-ietf-dnssd-srp. This call asks whether we believe the document is
> ready for publication. As such we are asking two questions:
>
> 1) if you believe this document is not ready to publish, please speak up
> now
>
> 2) if you have read the document and think it is ready, please say so as
> well
>
> For this call to succeed, we'll need statements of explicit support from
> people who have read the draft. Please send statements in either direction
> as responses to this email. This call will be open until 2021-08-15 23:59
> UTC.
>
> Thanks,
> David
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd
>

---

From: Nathan Dyck <[email-masked]>
Date: Wed, 4 Aug 2021 21:15:15 -0400

Hi All,

I have read the document and while I am brand new to IETF operations, I
believe it is largely ready to publish. A few smaller issues.

I had to re-read section 2.1.1 a few times to understand all the details.
One wording that threw me off a bit was "updates its local idea of the SRP
namespace". This could be improved by unifying terms from earlier in the
document, which outline this process as "registers the SRP client hostname
locally". Further, the section itself feels somewhat non-specific as to how
these types of records should be identified so that Advertising Proxy can
distinguish when to use the different conflict behaviours.

Section 3: "may made" should be "may make" I think.

Echoing Jonathan and Abtin's use-cases in Thread Border Routing, Nanoleaf
will be using this technology in our Thread Border routing feature as part
of our Shapes and Elements product lines.
https://www.techhive.com/article/3619639/nanoleafs-shapes-and-new-wood-like-elements-panels-will-include-thread-border-routers.html

Best Regards,

Nathan

Chief Product Officer
Nanoleaf

---

From: Esko Dijk <[email-masked]>
Date: Sun, 15 Aug 2021 20:37:17 +0000

Hello David,

Due to holiday I missed this last call. Having reviewed an earlier version I would like to check if the issues are solved now; and can answer the question by Tuesday or Wednesday if that’s ok. (Instead of today)

Best regards
Esko

From: dnssd <[email-masked]> On Behalf Of David Schinazi
Sent: Wednesday, July 28, 2021 23:57
To: DNSSD <[email-masked]>
Subject: [dnssd] WGLC for draft-ietf-dnssd-srp

Hi DNSSD enthusiasts,

This email starts an official Working Group Last Call for draft-ietf-dnssd-srp. This call asks whether we believe the document is ready for publication. As such we are asking two questions:

1) if you believe this document is not ready to publish, please speak up now

2) if you have read the document and think it is ready, please say so as well

For this call to succeed, we'll need statements of explicit support from people who have read the draft. Please send statements in either direction as responses to this email. This call will be open until 2021-08-15 23:59 UTC.

Thanks,
David

---

From: David Schinazi <[email-masked]>
Date: Mon, 16 Aug 2021 11:09:17 -0700

Hi Esko,

That's reasonable, we can wait a few more days for you to review.

David

On Sun, Aug 15, 2021 at 1:37 PM Esko Dijk <[email-masked]>
wrote:

> Hello David,
>
>
>
> Due to holiday I missed this last call. Having reviewed an earlier version
> I would like to check if the issues are solved now; and can answer the
> question by Tuesday or Wednesday if that’s ok. (Instead of today)
>
>
>
> Best regards
>
> Esko
>
>
>
> *From:* dnssd <[email-masked]> *On Behalf Of * David Schinazi
> *Sent:* Wednesday, July 28, 2021 23:57
> *To:* DNSSD <[email-masked]>
> *Subject:* [dnssd] WGLC for draft-ietf-dnssd-srp
>
>
>
> Hi DNSSD enthusiasts,
>
>
>

---

From: David Schinazi <[email-masked]>
Date: Thu, 19 Aug 2021 12:03:55 -0700

Hi everyone,

During this Working Group Last Call, the chairs received
statements of support from 11 people and no objections.

I'd like to personally thank everyone who read and
reviewed the draft, this work is exactly how we produce
high-quality RFCs.

However, we received multiple suggestions for minor
changes, and Esko raised some concerns regarding
Section 5 (Sleep Proxy).

Based on this we are declaring the WGLC successful,
and we are placing the document in the "Waiting for WG
Chair Go-Ahead" state [1]. We expect the authors to
submit a revised draft that addresses the comments
received during WGLC. Once that is done, we'll give
folks an opportunity to verify that their comments were
addressed, and assuming they were we'll submit the
draft to the IESG for publication.

Thanks,
David for the chairs

[1] https://datatracker.ietf.org/doc/html/rfc6174#section-4.2.8