Subject: Re: [dnssd] Adoption call for draft-sctl-advertising-proxy

From: Nathan Dyck <[email-masked]>
Date: Wed, 11 Aug 2021 20:52:44 +0000

Hi All,

I have read the document and  I believe it is largely ready to publish. A few smaller issues (note I previously sent these incorrectly referencing the separate call for draft-ietf-dnssd-srp).

I had to re-read section 2.1.1 a few times to understand all the details. One wording that threw me off a bit was "updates its local idea of the SRP namespace". This could be improved by unifying terms from earlier in the document, which outline this process as "registers the SRP client hostname locally". Further, the section itself feels somewhat non-specific as to how these types of records should be identified so that Advertising Proxy can distinguish when to use the different conflict behaviours.

Section 3: "may made" should be "may make" I think.

--
Nathan Dyck
Chief Product Officer
e: [email-masked]<mailto:[email-masked]> | c: +1 (289) 242-0016

The Nanoleaf Team
www.nanoleaf.me<http://www.nanoleaf.me>
follow us on twitter @nanoleaf
like us on facebook: fb.com/thenanoleaf
follow us on instagram @nanoleaf

From: dnssd <[email-masked]> on behalf of Jonathan Hui <jonhui=[email-masked]>
Date: Thursday, July 29, 2021 at 4:25 PM
To: David Schinazi <[email-masked]>
Cc: DNSSD <[email-masked]>
Subject: Re: [dnssd] Adoption call for draft-sctl-advertising-proxy
I have reviewed the latest version of this document (draft-sctl-advertising-proxy-02) and believe this work should be adopted by this working group.

The advertising proxy addresses important use cases for Matter and Thread and makes it possible to discover services registered via SRP via mDNS.

OpenThread includes an open source implementation of the advertising proxy - anyone interested in playing with it, see the Thread Border Router Codelab<https://openthread.io/codelabs/openthread-border-router#0>.

Thanks to Ted and Stuart for driving this effort.

--
Jonathan Hui

On Wed, Jul 28, 2021 at 3:03 PM David Schinazi <[email-masked]<mailto:[email-masked]>> wrote:
Hi DNSSD enthusiasts,

This email starts an official adoption call for draft-sctl-advertising-proxy by the DNSSD working group. This call asks whether we think that this document is a good starting point for working group discussion. That means that it is still possible to adopt a document with issues if we believe we'll be able to solve those issues together as a working group. As such we are asking two questions:

1) if you believe that this document is not something the working group should be working on, please speak up now

2) if you have read the document and would like to discuss it further inside the DNSSD working group, please say so as well

For this call to succeed, we'll need statements of explicit support from people who have read the draft. Please send statements in either direction as responses to this email. This call will be open until 2021-08-15 23:59 UTC.

Thanks,
David
_______________________________________________
dnssd mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dnssd

---

From: David Schinazi <[email-masked]>
Date: Mon, 16 Aug 2021 11:06:30 -0700

Hi everyone,

During this adoption call, the chairs received statements
of support from 9 people, and no objections. We therefore
declare this adoption call a success. The chairs want to
thank everyone who responded, in particular the newest
members of DNSSD! On procedural note since this wasn't
necessarily clear based on everyone's responses: this was
a call for adoption, not publication. This means that the
document is now an official working group document, but we
will determine whether it's ready for publication at a later date.
Folks have raised some interesting questions on the list, so
let's keep discussing!

Ted & Stuart, please upload a draft-ietf-advertising-proxy-00
with the same contents as draft-sctl-advertising-proxy-02. We
also encourage you to move the document to GitHub to simplify
tracking discussions.

Thanks,
David

On Wed, Jul 28, 2021 at 3:02 PM David Schinazi <[email-masked]>
wrote:

> Hi DNSSD enthusiasts,
>
> This email starts an official adoption call
> for draft-sctl-advertising-proxy by the DNSSD working group. This call asks
> whether we think that this document is a good starting point for working
> group discussion. That means that it is still possible to adopt a document
> with issues if we believe we'll be able to solve those issues together as a
> working group. As such we are asking two questions:
>
> 1) if you believe that this document is not something the working
> group should be working on, please speak up now
>
> 2) if you have read the document and would like to discuss it further
> inside the DNSSD working group, please say so as well
>
> For this call to succeed, we'll need statements of explicit support from
> people who have read the draft. Please send statements in either direction
> as responses to this email. This call will be open until 2021-08-15 23:59
> UTC.
>
> Thanks,
> David
>