Subject: Re: [dnssd] WGLC for draft-ietf-dnssd-srp

From: Simon Lin <[email-masked]>
Date: Thu, 12 Aug 2021 16:32:58 +0800

Hi,

I'd like to add my support for publishing the draft-ietf-dnssd-srp.

We have been using the OpenThread SRP implementation for Thread Border
Routers for a period of time and found that this technique is vital for
bridging the gap between Thread networks and the Infrastructure network.

We can also see the potential of utilizing SRP within the WiFi networks to
reduce inefficient multicast traffic.

Regards,
Simon

---

From: Nathan Dyck <[email-masked]>
Date: Thu, 12 Aug 2021 15:18:57 +0000

Hi All,

I have now properly read the draft-ietf-dnssd-srp in addition to the draft-sctl-advertising-proxy document, which my previous comments were aimed. I support it being published.

I have two smaller recommendations on draft-ietf-dnssd-srp:

  1.  The document specifies that clients must retain their key pairs in stable storage, although the equivalent requirement is not explicitly required for servers (KEY + lease time especially) as far as I could read. I believe it should be, likely somewhere in 2.3. It is not clear to me whether the records themselves are critical or just the KEY + lease. In current Thread implementations, I do not believe records are stored in stable storage.
  2.  The order of delete vs. add is specified in 2.3.1 and seems important. Is it worth also recommending a “should” case for clients in section 2.2.5.5.2.?
     *   “…in the old service being replaced by the new service.”
     *   Append: “The sequence of these instructions in the SRP update should include the delete before the add.”

Thanks,

Nathan

--
Nathan Dyck
Chief Product Officer
e: [email-masked]<mailto:[email-masked]> | c: +1 (289) 242-0016

The Nanoleaf Team
www.nanoleaf.me<http://www.nanoleaf.me>
follow us on twitter @nanoleaf
like us on facebook: fb.com/thenanoleaf
follow us on instagram @nanoleaf

From: dnssd <[email-masked]> on behalf of Simon Lin <simonlin=[email-masked]>
Date: Thursday, August 12, 2021 at 8:42 AM
To: [email-masked] <[email-masked]>
Subject: Re: [dnssd] WGLC for draft-ietf-dnssd-srp
Hi,

We have been using the OpenThread SRP implementation for Thread Border Routers for a period of time and found that this technique is vital for bridging the gap between Thread networks and the Infrastructure network.

We can also see the potential of utilizing SRP within the WiFi networks to reduce inefficient multicast traffic.

Regards,
Simon