Subject: [Doh] DOH server on non-standard ports

From: Mateusz Jończyk <[email-masked]>
Date: Wed, 4 Apr 2018 12:58:19 +0200

Hello,
I think that it may be beneficial to specify that a DOH server MAY work on a
port other than 443 and that the DOH client MUST support accessing DOH servers
on ports other than 443.

I have been thinking about the possibility of adding support for DOH to a home
router. In the future, someone may modify dnsmasq so that it would act as a DOH
server - dnsmasq could then run on this router and provide DOH services.
The port 443 would be already used by the router's management interface which
would probably run as a separate process on this router (as it would be an
entirely different codebase). So dnsmasq would have to provide DOH services on
another port.

Greetings,
Mateusz Jończyk

---

From: Patrick McManus <[email-masked]>
Date: Wed, 4 Apr 2018 08:49:58 -0400

neither https not uris are limited to any particular port. I don't see a
problem here..

On Wed, Apr 4, 2018 at 6:58 AM, Mateusz Jończyk <[email-masked]> wrote:

> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh
>
>

---

From: Mateusz Jończyk <[email-masked]>
Date: Fri, 6 Apr 2018 11:49:10 +0200

OK, but wouldn't it be beneficial to specify explicitly that DOH clients MUST
support accessing DOH servers on ports other then 443 - for compatibility reasons?

I would propose to add the following text:
	A DNS API server MAY work on a port other then 443 so all DNS API
	clients MUST support accessing DOH servers on ports other than 443.

at the end of section 4 "The HTTP Request".

Greetings,
Mateusz Jończyk

Patrick McManus on Wed, 04 April 2018 12:50 UTC wrote:
> W dniu 04.04.2018 o 12:58, Mateusz Jończyk pisze:
>> Hello,

---

From: Patrick McManus <[email-masked]>
Date: Fri, 6 Apr 2018 13:32:15 -0400

one of the nice things about DoH is that it does not squat on any
particular part of the URI space which will allow many deployments to
integrate DoH into existing servers. (That's actually one of the points of
bcp56bis, and a good argument for tossing the .wk url out).

obviously, that's not always possible (such as your example) and a
different port is required.. but that's not really desirable and is already
possible so I don't think I support the change in language.

---

From: Dave Lawrence <[email-masked]>
Date: Fri, 6 Apr 2018 14:06:02 -0400

Patrick McManus writes:
> obviously, that's not always possible (such as your example) and a different
> port is required.. but that's not really desirable and is already

I don't see why any change in language is necessary either.  The
Internet has a very, very long and rich history of running any given
protocol on any given port the end points agree on.  I don't know how
anyone would reasonably conclude that the only port that DoH could
possibly run on is 443, and so adding text to be explicit about it is
just unnecessarily superfluous.