Subject: [Doh] Googles Experimental DoH Endpoint.

From: "Winfield, Alister" <[email-masked]>
Date: Thu, 16 May 2019 20:24:08 +0000

oh by the way I noticed this and it seems counter to the claim of DoH only running on 8.8.8.8.

To keep it short I’ve removed the SSL setup step from the example.

$ openssl s_client -connect search.google.com:443 -servername search.google.com

…

---

GET /experimental?dns=AAABAAABAAAAAAAAA3d3dwdleGFtcGxlA2NvbQAAAQAB HTTP/1.1

host: dns.google.com

HTTP/1.1 200 OK

Strict-Transport-Security: max-age=31536000; includeSubDomains; preload

Access-Control-Allow-Origin: *

Date: Tue, 14 May 2019 13:49:53 GMT

Expires: Tue, 14 May 2019 13:49:53 GMT

Cache-Control: private, max-age=20595

Content-Type: application/dns-message

Server: HTTP server (unknown)

Content-Length: 49

X-XSS-Protection: 0

X-Frame-Options: SAMEORIGIN

Alt-Svc: quic=":443"; ma=2592000; v="46,44,43,39"

??wwwexamplecom?

                Ps]??"^C

$

Tried a few more gmail.google.com, www.youtube.com, news.google.com

So I guess it’s their entire web estate

--
Alister Winfield.
Information in this email including any attachments may be privileged, confidential and is intended exclusively for the addressee. The views expressed may not be official policy, but the personal views of the originator. If you have received it in error, please notify the sender by return e-mail and delete it from your system. You should not reproduce, distribute, store, retransmit, use or disclose its contents to anyone. Please note we reserve the right to monitor all e-mail communication through our internal and external networks. SKY and the SKY marks are trademarks of Sky Limited and Sky International AG and are used under licence.

Sky UK Limited (Registration No. 2906991), Sky-In-Home Service Limited (Registration No. 2067075), Sky Subscribers Services Limited (Registration No. 2340150) and Sky CP Limited (Registration No. 9513259) are direct or indirect subsidiaries of Sky Limited (Registration No. 2247735). All of the companies mentioned in this paragraph are incorporated in England and Wales and share the same registered office at Grant Way, Isleworth, Middlesex TW7 5QD

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 16 May 2019 22:26:08 +0000

So, you're effectively doing domain fronting here; i.e., routing to one server name with SNI, while using a different host header.

Firefox (for example) doesn't support doing this with its DoH implementation, AFAICT; you'd have to write a custom client (or intermediary).

> On 16 May 2019, at 8:24 pm, Winfield, Alister <Alister.Winfield=[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: "Winfield, Alister" <[email-masked]>
Date: Fri, 17 May 2019 10:07:16 +0000

> On 16/05/2019, 23:26, "Mark Nottingham" <[email-masked]> wrote:
  >
  >    Firefox (for example) doesn't support doing this with its DoH implementation, AFAICT; you'd have to write a custom client (or
  >.   intermediary).

That may be true, but the change to allow it in a mainstream client will, in most cases, be trivial and malware writers really don't care.

    --
    Mark Nottingham   https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.mnot.net%2F&amp;data=02%7C01%7CAlister.Winfield%40sky.uk%7C1d37fab671d04f769d0b08d6da4d8824%7C68b865d5cf184b2b82a4a4eddb9c5237%7C0%7C1%7C636936423881565755&amp;sdata=U1mbd%2FYW8GyL%2Bfyq%2BAjozT4se2vE0Si8GG5r%2F0LOj%2FU%3D&amp;reserved=0

    --------------------------------------------------------------------
    This email is from an external source. Please do not open attachments or click links from an unknown or suspicious origin. Phishing attempts can be reported by sending them to [email-masked] as attachments. Thank you
    --------------------------------------------------------------------

---

From: "Winfield, Alister" <[email-masked]>
Date: Fri, 17 May 2019 10:10:28 +0000

> intermediary).

    Oh and obviously it's still the case the Google are stating one fact, repeating it at every opportunity whilst (I hope by accident) doing completely the opposite in reality.