Subject: [Dots] A general question about the near source mitigation and DOTS call home mechanism:

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Fri, 12 Jul 2019 03:38:25 +0000

Hi all,
If I am correct, current dots call home draft include 2 main points: 1-dots server create underlay tls connection with dots client due to the dots server is located behind home gateway (more generally, DC gateway, cloud gateway, branch gateway, ...); 2-for near source mitigation, dots client should send the attack source information (address, port, ...) to dots server for its mitigation.

I am wondering why we cannot use the same attack source information of point 2 in the dots signal channel, which aims for the same goal of near source mitigation? I do see the use cases and requirements for many outbound attacks. And it also means the point 1 and 2 of signal channel call home is not necessary to be combined together always.

And should we consider the update of current signal channel WG draft, or other way?

Your comments?

B.R.
Frank

---

From: <[email-masked]>
Date: Fri, 12 Jul 2019 05:24:49 +0000

Hi Franck,

The source information can be used in the DOTS signal channel. The I-D says the following:

   This specification extends the mitigation request defined in

   Section 4.4.1 of [I-D.ietf-dots-signal-channel<https://tools.ietf.org/html/draft-ietf-dots-signal-call-home-03#ref-I-D.ietf-dots-signal-channel>] to convey the

   attacker source prefixes and source port numbers.

     augment /ietf-signal:dots-signal/ietf-signal:message-type

             /ietf-signal:mitigation-scope/ietf-signal:scope:

       +--rw source-prefix*     inet:ip-prefix {source-signaling}?

       +--rw source-port-range* [lower-port] {source-signaling}?

       |  +--rw lower-port    inet:port-number

       |  +--rw upper-port?   inet:port-number

       +--rw source-icmp-type-range*

          |                    [lower-type] {source-signaling}?

          +--rw lower-type    uint8

          +--rw upper-type?   uint8

The attributes are optional for the DOTS signal channel:

      This is an optional attribute for the base DOTS signal channel

      operations [I-D.ietf-dots-signal-channel<https://tools.ietf.org/html/draft-ietf-dots-signal-call-home-03#ref-I-D.ietf-dots-signal-channel>].

while some of them are mandatory for the call home:

   The 'source-prefix' parameter is a mandatory attribute when the

                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

   attack traffic information is signaled by a DOTS client in the Call

                                                                  ^^^^

   Home scenario (depicted in Figure 2).

   ^^^^

Cheers,
Med

De : Xialiang (Frank, Network Standard & Patent Dept) [mailto:[email-masked]]
Envoyé : vendredi 12 juillet 2019 05:38
À : [email-masked]
Cc : [email-masked]; [email-masked]
Objet : A general question about the near source mitigation and DOTS call home mechanism:

Hi all,

Your comments?

B.R.
Frank

---

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Fri, 12 Jul 2019 05:54:18 +0000

Hi Med,
Ok. Thanks for the clarification.

Any suggestions about whether we should add these attack source related information into the base dots signal channel draft? As a contributor, I think it’s friendly for the RFC readers to find all the useful attributes in one draft.

B.R.
Frank

发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2019年7月12日 13:25
收件人: Xialiang (Frank, Network Standard & Patent Dept) <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: A general question about the near source mitigation and DOTS call home mechanism:

Hi Franck,

          +--rw lower-type    uint8

          +--rw upper-type?   uint8

                                                                  ^^^^

   ^^^^

Cheers,
Med

De : Xialiang (Frank, Network Standard & Patent Dept) [mailto:[email-masked]]
Envoyé : vendredi 12 juillet 2019 05:38
À : [email-masked]<mailto:[email-masked]>
Cc : [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Objet : A general question about the near source mitigation and DOTS call home mechanism:

Hi all,
If I am correct, current dots call home draft include 2 main points: 1—dots server create underlay tls connection with dots client due to the dots server is located behind home gateway (more generally, DC gateway, cloud gateway, branch gateway, …); 2—for near source mitigation, dots client should send the attack source information (address, port, …) to dots server for its mitigation.

Your comments?

B.R.
Frank

---

From: <[email-masked]>
Date: Fri, 12 Jul 2019 06:13:34 +0000

Re-,

This is exactly the role of the IANA registry set by the signal channel. The base spec defines only an initial version; future extensions will be registered and be easily available.

Cheers,
Med

De : Xialiang (Frank, Network Standard & Patent Dept) [mailto:[email-masked]]
Envoyé : vendredi 12 juillet 2019 07:54
À : BOUCADAIR Mohamed TGI/OLN; [email-masked]
Cc : [email-masked]; [email-masked]
Objet : 答复: A general question about the near source mitigation and DOTS call home mechanism:

Hi Med,

B.R.
Frank

Hi Franck,

          +--rw lower-type    uint8

          +--rw upper-type?   uint8

                                                                  ^^^^

   ^^^^

Cheers,
Med

Hi all,

Your comments?

B.R.
Frank

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Fri, 12 Jul 2019 06:17:30 +0000

Hi Frank,

A typical DDoS attack would involve several thousand compromised devices (botnets) to attack the victim, and the IP addresses itself could be spoofed and can keep changing.  DOTS signal channel cannot convey so many prefixes.
However, in the DOTS call home scenario, it is not a problem since the source-prefix is restricted to the subscriber assigned prefixes and IP addresses.

Cheers,
-Tiru

From: Dots <[email-masked]> On Behalf Of Xialiang (Frank, Network Standard & Patent Dept)
Sent: Friday, July 12, 2019 11:24 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Dots] 答复: A general question about the near source mitigation and DOTS call home mechanism:

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
Hi Med,
Ok. Thanks for the clarification.

B.R.
Frank

发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
发送时间: 2019年7月12日 13:25
收件人: Xialiang (Frank, Network Standard & Patent Dept) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: RE: A general question about the near source mitigation and DOTS call home mechanism:

Hi Franck,

          +--rw lower-type    uint8

          +--rw upper-type?   uint8

                                                                  ^^^^

   ^^^^

Cheers,
Med

Hi all,

Your comments?

B.R.
Frank

---

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Fri, 12 Jul 2019 06:21:06 +0000

Good point, thank you.

发送时间: 2019年7月12日 14:14

Re-,

Cheers,
Med

À : BOUCADAIR Mohamed TGI/OLN; [email-masked]<mailto:[email-masked]>

Hi Med,

B.R.
Frank

Hi Franck,

          +--rw lower-type    uint8

          +--rw upper-type?   uint8

                                                                  ^^^^

   ^^^^

Cheers,
Med

Hi all,

Your comments?

B.R.
Frank

---

From: <[email-masked]>
Date: Fri, 12 Jul 2019 06:22:57 +0000

Hi Tiru,

Agree. This is why src-* are not considered as part of the initial set of attributes defined in the base spec.

Nevertheless, there are scenarios where a limited number of sources can be included even for the base signal channel. An example is discussed in draft-hayashi-dots-dms-offload-usecase.

Cheers,
Med

De : Konda, Tirumaleswar Reddy [mailto:[email-masked]]
Envoyé : vendredi 12 juillet 2019 08:18
À : Xialiang (Frank, Network Standard & Patent Dept); BOUCADAIR Mohamed TGI/OLN; [email-masked]
Cc : [email-masked]; [email-masked]
Objet : RE: A general question about the near source mitigation and DOTS call home mechanism:

Hi Frank,

Cheers,
-Tiru

B.R.
Frank

Hi Franck,

          +--rw lower-type    uint8

          +--rw upper-type?   uint8

                                                                  ^^^^

   ^^^^

Cheers,
Med

Hi all,

Your comments?

B.R.
Frank

---

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Fri, 12 Jul 2019 06:27:26 +0000

Hi,
Got your points and agree.

Thanks!

B.R.
Frank

发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2019年7月12日 14:23
收件人: Konda, Tirumaleswar Reddy <[email-masked]>; Xialiang (Frank, Network Standard & Patent Dept) <[email-masked]>; [email-masked]
抄送: [email-masked]; [email-masked]
主题: RE: A general question about the near source mitigation and DOTS call home mechanism:

Hi Tiru,

Cheers,
Med

De : Konda, Tirumaleswar Reddy [mailto:[email-masked]]
Envoyé : vendredi 12 juillet 2019 08:18
À : Xialiang (Frank, Network Standard & Patent Dept); BOUCADAIR Mohamed TGI/OLN; [email-masked]<mailto:[email-masked]>
Cc : [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Objet : RE: A general question about the near source mitigation and DOTS call home mechanism:

Hi Frank,

Cheers,
-Tiru

From: Dots <[email-masked]<mailto:[email-masked]>> On Behalf Of Xialiang (Frank, Network Standard & Patent Dept)
Sent: Friday, July 12, 2019 11:24 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Dots] 答复: A general question about the near source mitigation and DOTS call home mechanism:

B.R.
Frank

Hi Franck,

          +--rw lower-type    uint8

          +--rw upper-type?   uint8

                                                                  ^^^^

   ^^^^

Cheers,
Med

Hi all,

Your comments?

B.R.
Frank