Subject: [Dots] draft-ietf-dots-call-home: Clarify DOTS Agent Roles

From: <[email-masked]>
Date: Thu, 25 Jul 2019 14:16:48 +0000

Re-,

There was a comment raised during the meeting asking to further clarify the role of the various DOTS agent in the call home. We added an new section to address this comment: https://tools.ietf.org/html/draft-ietf-dots-signal-call-home-04#section-1.4

Cheers,
Med

---

From: "Valery Smyslov" <[email-masked]>
Date: Thu, 25 Jul 2019 19:04:15 +0300

Hi Med,

thank you for adding this section, it really helps. 

However, I was asking for more - did you consider

changing the terminology in such a way, that 

Call Home use case is not mixed with basic DOTS use case?

For example, calling entities not just DOTS Client and DOTS

Server, but say Call Home DOTS Client and Call Home DOTS Server?

(actually I don't like these ad hoc names, probably you can invent better
term).

Regards,

Valery.

From: Dots <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, July 25, 2019 5:17 PM
To: [email-masked]
Subject: [Dots] draft-ietf-dots-call-home: Clarify DOTS Agent Roles

Re-,

There was a comment raised during the meeting asking to further clarify the
role of the various DOTS agent in the call home. We added an new section to
address this comment:
<https://tools.ietf.org/html/draft-ietf-dots-signal-call-home-04#section-1.4
https://tools.ietf.org/html/draft-ietf-dots-signal-call-home-04#section-1.4 

Cheers,

Med

---

From: <[email-masked]>
Date: Fri, 26 Jul 2019 07:16:06 +0000

Hi Valery,

We didn't consider the use of new terms because we thought this may be interpreted as if we are defining new DOTS roles (which we don't).

The text uses "in the call home scenario" to make that distinction in some places, but I understand this may not be sufficient.

I'm OK to go with "Call Home DOTS *". I updated the terminology section with the following:

   DOTS agents involved in the DOTS Call Home adhere to the DOTS roles

   as defined in [RFC8612].  For clarity, this document uses "Call Home

   DOTS client" (or "Call Home DOTS server") to refer to a DOTS client

   (or DOTS server) deployed in a Call Home scenario.

and changed the text when it makes sense. The full diff is available at:

https://github.com/boucadair/dots-call-home/blob/master/wdiff%20draft-ietf-dots-signal-call-home-04.txt%20draft-ietf-dots-signal-call-home-05.pdf

candidate -05: https://github.com/boucadair/dots-call-home/blob/master/draft-ietf-dots-signal-call-home-05.txt

Please let us know if this is better.

Thank you.

Cheers,

Med

De : Valery Smyslov [mailto:[email-masked]]
Envoyé : jeudi 25 juillet 2019 18:04
À : BOUCADAIR Mohamed TGI/OLN; [email-masked]
Objet : RE: [Dots] draft-ietf-dots-call-home: Clarify DOTS Agent Roles

Hi Med,

For example, calling entities not just DOTS Client and DOTS
Server, but say Call Home DOTS Client and Call Home DOTS Server?
(actually I don't like these ad hoc names, probably you can invent better term).

Regards,
Valery.

Re-,

Cheers,
Med

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Fri, 26 Jul 2019 08:44:39 +0000

I don’t see any such terminology used in other specifications like https://tools.ietf.org/html/rfc8071. Why do we need “Call Home” prefix even after the text clarifies the roles clearly ?
If we go with this change all the figures needs to modified, and these terms need to be defined before being used.

Cheers,
-Tiru

From: Dots <[email-masked]> On Behalf Of [email-masked]
Sent: Friday, July 26, 2019 12:46 PM
To: Valery Smyslov <[email-masked]>; [email-masked]
Subject: Re: [Dots] draft-ietf-dots-call-home: Clarify DOTS Agent Roles

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
Hi Valery,

We didn’t consider the use of new terms because we thought this may be interpreted as if we are defining new DOTS roles (which we don’t).

The text uses “in the call home scenario” to make that distinction in some places, but I understand this may not be sufficient.

I’m OK to go with “Call Home DOTS *”. I updated the terminology section with the following:

Thank you.

Cheers,

Med

De : Valery Smyslov [mailto:[email-masked]]
Envoyé : jeudi 25 juillet 2019 18:04
À : BOUCADAIR Mohamed TGI/OLN; [email-masked]<mailto:[email-masked]>
Objet : RE: [Dots] draft-ietf-dots-call-home: Clarify DOTS Agent Roles

Hi Med,

For example, calling entities not just DOTS Client and DOTS
Server, but say Call Home DOTS Client and Call Home DOTS Server?
(actually I don't like these ad hoc names, probably you can invent better term)..

Regards,
Valery.

From: Dots <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Thursday, July 25, 2019 5:17 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dots] draft-ietf-dots-call-home: Clarify DOTS Agent Roles

Re-,

Cheers,
Med

---

From: <[email-masked]>
Date: Fri, 26 Jul 2019 08:54:31 +0000

Re-,

Please see inline.

Cheers,
Med

De : Dots [mailto:[email-masked]] De la part de Konda, Tirumaleswar Reddy
Envoyé : vendredi 26 juillet 2019 10:45
À : BOUCADAIR Mohamed TGI/OLN; Valery Smyslov; [email-masked]
Objet : Re: [Dots] draft-ietf-dots-call-home: Clarify DOTS Agent Roles

I don’t see any such terminology used in other specifications like https://tools.ietf.org/html/rfc8071. Why do we need “Call Home” prefix even after the text clarifies the roles clearly ?
[Med] For us who are familiar with the text, there is no confusion. But I hear the comment from Valery as this may be confusing in some places. It is worth to clarify at this stage rather than spending extra cycles when the document advances in the process.

If we go with this change all the figures needs to modified, and these terms need to be defined before being used.
[Med] No all of the figures, but only when there is a confusion.

Cheers,
-Tiru

Thank you.

Cheers,

Med

Hi Med,

Regards,
Valery.

Re-,

Cheers,
Med

---

From: "Panwei (William)" <[email-masked]>
Date: Fri, 26 Jul 2019 11:12:09 +0000

Hi,

I agree with Med. This maybe confused for people who are not familiar with this spec.
The confusing part can be at the situation where base siganl channel and call home channel are used at the same time. In this case there are two kinds of DOTS client/server, we must emphasize DOTS client used in base signal channel and DOTS client used in call home signal channel to separate them. I think the new terms will make this difference better for both understanding and expressing.
BTW, I suggest giving 'Call Home Signal Channel' a term definition at the same time.

--------------------------------------------------
潘伟 William
Mobile: +86-18551640326<tel:+86-18551640326>
Email: [email-masked]<mailto:[email-masked]>
发件人：[email-masked] <[email-masked]>
收件人：Konda, Tirumaleswar Reddy <[email-masked]>;Valery Smyslov <[email-masked]>;[email-masked] <[email-masked]>
时间：2019-07-26 04:54:48
主 题：Re: [Dots] draft-ietf-dots-call-home: Clarify DOTS Agent Roles

Re-,

Please see inline.

Cheers,
Med

Cheers,
-Tiru

Thank you.

Cheers,

Med

Hi Med,

Regards,
Valery.

Re-,

Cheers,
Med

---

From: <[email-masked]>
Date: Fri, 26 Jul 2019 11:33:19 +0000

Re-,

What about adding the following to the terminology section?

   'DOTS signal channel Call Home' refers to a DOTS signal channel
   established at the initiative of a DOTS server.  That is, the DOTS
   server (a.k.a., Call Home DOTS server) initiates a secure connection
   to a DOTS client (a.k.a., Call Home DOTS client), and uses that
   connection to receive the attack traffic information from the Call
   Home DOTS client.  More details are provided in Section 3.

Cheers,
Med

De : Panwei (William) [mailto:[email-masked]]
Envoyé : vendredi 26 juillet 2019 13:12
À : BOUCADAIR Mohamed TGI/OLN; Konda, Tirumaleswar Reddy; Valery Smyslov; [email-masked]
Objet : RE: [Dots] draft-ietf-dots-call-home: Clarify DOTS Agent Roles

Hi,

Re-,

Please see inline.

Cheers,
Med

Cheers,
-Tiru

Thank you.

Cheers,

Med

Hi Med,

Regards,
Valery.

Re-,

Cheers,
Med