Subject: [Dots] we can consider update current DOTS use cases draft to reflect your case://答复: Hi, authors, 3 questions on draft-hayashi-dots-dms-offload-usecase-01:

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Fri, 12 Jul 2019 06:12:44 +0000

Hi Yuhei,
Thanks for quick and clear clarification.

See inline:

And in summary from my side, the only thing we may need to do according to your proposal is to update the DOTS use cases draft to reflect your new case: " It's effective that DMS have DOTS client function in DOTS orchestration use case ".
But we welcome more discussions.

B.R.
Frank

-----邮件原件-----
发件人: H Y [mailto:[email-masked]] 
发送时间: 2019年7月12日 13:00
收件人: Xialiang (Frank, Network Standard & Patent Dept) <[email-masked]>
抄送: [email-masked]; Valery Smyslov <[email-masked]>; [email-masked]; [email-masked]
主题: Re: [Dots] Hi, authors, 3 questions on draft-hayashi-dots-dms-offload-usecase-01:

Hi Frank,

Thank you for reviewing my draft :-)
Please see inline.

> 1.  I see your proposed offload use case as an variant of DOTS Orchestration use case (section 3.3 of draft-ietf-dots-use-cases-18).
[hayashi]Yes, that's right.

> If so, what is your propose for this part of content? Do you want to improve the existing DOTS use cases WG draft with your addition?
[hayashi]Yes, I want to add our use case to improve the DOTS orchestration use cases.
About the DOTS orchestration use case in current use cases WG draft, DMS doesn't have DOTS client function.
IMO, it's effective that DMSs send blocked information to an orchestrator via standardized IF and the orchestrator carries out some action in the network.

At IETF 104, I proposed to add our use case to improve the DOTS orchestration use cases, however, I could not do it because the use case WG draft now is in Publication Requested status.
Some people gave me the advice to include DOTS deployment consideration to my draft, so I update my draft based on the comments.

Please see IETF104 minute https://datatracker.ietf.org/doc/minutes-104-dots/

[Frank]: So, I suggest you to contact with DOTS use cases draft authors about this proposal asap, since it's in the AD Evaluation status and I think your improvement is just a minor part.

> 2.      Right now, DOTS protocol defines sending DOTS request via signal channel, do you propose to send it via data channel in some situation? If so, I personally disagree with it, since we originally define signal channel and data channel for different functionalities & messages, we can not send any DOTS messages over wrong channel, like: DOTS request via data channel.
[hayashi] After I submitted
draft-h-dots-mitigation-offload-expansion-00,  some people gave me comments not to use signal channel but to use data channel via out-of band because link b/w the DMS and Orchestrator won't be congested under attack time.

Please see the mail thread [Dots]
draft-h-dots-mitigation-offload-expansion-00: Reasons why we want to standardize between DMS and orchestrator using DOTS

Current data channel has the capability to send filtering rules immediately, so I think it can be used to send blocked information from DMS to Orchestrator.
If the signal channel has the capability to convey the attacker's information, the signal channel can be also used to send it to form DMS to Orchestrator.

[Frank]: sending acl filtering rules via DOTS data channel is ok.

> 3.      In addition to extended offload use case content, I do not see any new protocol, message or attribute extension comparing to the existing defined DOTS protocols, the left content are just some examples about how you use the existing DOTS protocol for your offload use case. So, what do you want DOTS WG to do for this draft, since there are no new thing here?
[hayashi] This draft requires that ...
- It's effective that DMS have DOTS client function in DOTS orchestration use case.

[Frank]: this is not excluded in current DOTS architecture, just lack of clear text of this point. You can discuss this point with use cases draft authors.

- It's effective that signal channel has the capability to send src information.
For example, it's useful and feasible to send src port information via the DOTS signal channel to request mitigation against reflection attack.

[Frank]: DOTS signal channel call home draft has already specified it. No more needs to be done.

> And be careful using signal channel call home for your use case, since it is a special mechanism for near source attack mitigation with DOTS server create TLS connection with DOTS client, which I don’t think it’s very suitable for your case.
Thank you for giving me comments. Could I define another signal channel expansion to send src information via signal channel?

[Frank]: I think it's not necessary. You can see my discussion with Med about the same thing just now in: https://mailarchive.ietf.org/arch/msg/dots/hRd3BRTUjXx5roIS2jJ6UXzTny4

Thanks,
Yuhei

2019年7月12日(金) 12:10 Xialiang (Frank, Network Standard & Patent Dept)
<[email-masked]>:
>
> Hi authors,
>
> I have reviewed this new version and have 3 questions as below:
>
> 1.      I see your proposed offload use case as an variant of DOTS Orchestration use case (section 3.3 of draft-ietf-dots-use-cases-18). If so, what is your propose for this part of content? Do you want to improve the existing DOTS use cases WG draft with your addition?
>
> 2.      Right now, DOTS protocol defines sending DOTS request via signal channel, do you propose to send it via data channel in some situation? If so, I personally disagree with it, since we originally define signal channel and data channel for different functionalities & messages, we can not send any DOTS messages over wrong channel, like: DOTS request via data channel.
>
> 3.      In addition to extended offload use case content, I do not see any new protocol, message or attribute extension comparing to the existing defined DOTS protocols, the left content are just some examples about how you use the existing DOTS protocol for your offload use case. So, what do you want DOTS WG to do for this draft, since there are no new thing here? And be careful using signal channel call home for your use case, since it is a special mechanism for near source attack mitigation with DOTS server create TLS connection with DOTS client, which I don’t think it’s very suitable for your case.
>
>
>
> Thanks!
>
>
>
> B.R.
>
> Frank
>
>
>
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

--
----------------------------------
Yuuhei HAYASHI
08065300884
[email-masked]
[email-masked]
----------------------------------

---

From: H Y <[email-masked]>
Date: Fri, 12 Jul 2019 16:03:08 +0900

Hi Frank,

Please see inline.

> But we welcome more discussions.
[hayashi]
Thanks. I would like to contact use case authors asap.
And I would like to discuss more at IETF 105.

> [Frank]: So, I suggest you to contact with DOTS use cases draft authors about this proposal asap, since it's in the AD Evaluation status and I think your improvement is just a minor part.
[hayashi]
Thank you for giving me advice.
I would like to do so.

> [Frank]: sending acl filtering rules via DOTS data channel is ok.
[hayashi]
Thanks.

> [Frank]: this is not excluded in current DOTS architecture, just lack of clear text of this point. You can discuss this point with use cases draft authors.
[hayashi]
OK.

> [Frank]: DOTS signal channel call home draft has already specified it. No more needs to be done.
[hayashi]
OK.

> [Frank]: I think it's not necessary. You can see my discussion with Med about the same thing just now in: https://mailarchive.ietf.org/arch/msg/dots/hRd3BRTUjXx5roIS2jJ6UXzTny4
[hayashi]
OK.

Thanks,
Yuhei

---

From: H Y <[email-masked]>
Date: Fri, 12 Jul 2019 16:55:31 +0900

Hi use cases WG draft authors,

I'm Yuhei, author of draft-hayashi-dots-dms-offload-usecase which is
an variant of DOTS Orchestration use case.
The summary of the draft is as below.
- DMS has DOTS client function and Orchestrator has DOTS server fucntion.
- DMS sends blocked or detected traffic information to the
orchestrator via DOTS protocol.

IMO, it's effective that DMSs send blocked traffic information to an
orchestrator via standardized IF, and the orchestrator carries out
some action in the network such as the DMS offload use case.

So I would like to minor-change and improve Section 3.3 in the current
use case WG.
Is there any problem?
If it is no problem, I would like to make amendments asap.

I'm glad if you give me a comment.

Thanks,
Yuhei

---

From: "Xialiang (Frank, Network Standard & Patent Dept)" <[email-masked]>
Date: Fri, 12 Jul 2019 10:03:59 +0000

Hi Yuhei,
As one of the author of this draft, I understand and agree with your proposed change.

Thanks!

B.R.
Frank

-----邮件原件-----
发件人: H Y [mailto:[email-masked]] 
发送时间: 2019年7月12日 15:56
收件人: [email-masked]
抄送: [email-masked]; Xialiang (Frank, Network Standard & Patent Dept) <[email-masked]>; Valery Smyslov <[email-masked]>; [email-masked]; [email-masked]
主题: Re: [Dots] we can consider update current DOTS use cases draft to reflect your case://答复: Hi, authors, 3 questions on draft-hayashi-dots-dms-offload-usecase-01:

I'm Yuhei, author of draft-hayashi-dots-dms-offload-usecase which is an variant of DOTS Orchestration use case.
The summary of the draft is as below.
- DMS has DOTS client function and Orchestrator has DOTS server fucntion.
- DMS sends blocked or detected traffic information to the orchestrator via DOTS protocol.

IMO, it's effective that DMSs send blocked traffic information to an orchestrator via standardized IF, and the orchestrator carries out some action in the network such as the DMS offload use case.

So I would like to minor-change and improve Section 3.3 in the current use case WG.
Is there any problem?
If it is no problem, I would like to make amendments asap.

Thanks,
Yuhei

2019年7月12日(金) 16:03 H Y <[email-masked]>:
> > 抄送: [email-masked]; Valery 
> > Smyslov <[email-masked]>; [email-masked]; 
> > [email-masked]
> > Thank you for reviewing my draft :-) Please see inline.
> >
> > Please see IETF104 minute 
> > https://datatracker.ietf.org/doc/minutes-104-dots/
> >
> > draft-h-dots-mitigation-offload-expansion-00: Reasons why we want to 
> > standardize between DMS and orchestrator using DOTS
> >
> > [Frank]: I think it's not necessary. You can see my discussion with 
> > Med about the same thing just now in: 
> > https://mailarchive.ietf.org/arch/msg/dots/hRd3BRTUjXx5roIS2jJ6UXzTn
> > y4
> [hayashi]
> OK.
>
> Thanks,
> Yuhei
>
> >
> > Thanks,
> > Yuhei
> >

---

From: H Y <[email-masked]>
Date: Sat, 13 Jul 2019 11:55:11 +0900

Hi Frank, use cases WG draft authors,

> As one of the author of this draft, I understand and agree with your proposed change.
Thank you for agreeing with that :-)

> If it is no problem, I would like to make amendments asap.
I made the minor amendments.
Please see attachments.

Thanks,
Yuhei