Subject: Re: [Dots] WGLC on draft-ietf-dots-server-discovery-05

From: "Jon Shallow" <[email-masked]>
Date: Wed, 6 Nov 2019 14:58:52 -0000

Hi All,

I have read through draft-ietf-dots-server-discovery-05 and think that it is
a good document.

However, in particular with DHCPv(4|6), it is only possible to use the first
OPTION_Vx_DOTS_ADDRESS (5.1.3, 5.2.3).  If the server at the first address
is down / unavailable for whatever reason, it is not possible to define a
backup IP address as a secondary entry.  Is it the intention to not allow
backup IP addresses?

With DNS, I know that A/AAAA records can be presented round-robin which
gives the possibility of backup IP addresses, but am not sure whether this
holds true for implementations for other Resource Records.  If backup
addresses are to be allowed, the draft is unclear whether only the first
A/AAAA RR is allowed, or each can be tested until the first non-failure is
found, or whether happy-eyeballs it to be invoked against all of the IP
addresses and then the final IP preferentially chosen according to the RR
returned order.

Regards

Jon

> -----Original Message-----
> From: Dots [mailto:[email-masked]] On Behalf Of Valery
> Smyslov
> Sent: 23 October 2019 08:37
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Dots] WGLC on draft-ietf-dots-server-discovery-05
> 
> Hi,
> 
> this message starts a Work Group Last Call (WGLC) for
draft-ietf-dots-server-
> discovery-05.
> The version to be reviewed is here:
https://www.ietf.org/id/draft-ietf-dots-
> server-discovery-05.txt
> 
> The WGLC will last for two weeks and will end on November the 7th.
> Please send your comments to the list before this date.
> 
> Regards,
> Frank & Valery.
> 
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: <[email-masked]>
Date: Wed, 6 Nov 2019 15:51:44 +0000

Hi Jon, 

Thank you for the comments. 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de Jon Shallow
> Envoyé : mercredi 6 novembre 2019 15:59
> À : 'Valery Smyslov'; [email-masked]; [email-masked]
> Objet : Re: [Dots] WGLC on draft-ietf-dots-server-discovery-05
> 
> Hi All,
> 
> OPTION_Vx_DOTS_ADDRESS (5.1.3, 5.2.3).

[Med] Yes

  If the server at the first address
> backup IP address as a secondary entry.  Is it the intention to not allow

[Med] Hmm, that is possible given that an instance is designed to carry a list of IP addresses.

   If the DHCP client receives OPTION_V6_DOTS_ADDRESS only, the
   address(es) included in OPTION_V6_DOTS_ADDRESS are used to reach the
   ^^^^^^^^^^
   peer DOTS agent.  In addition, these addresses can be used as
   identifiers for authentication.

> addresses and then the final IP preferentially chosen according to the RR

[Med] Considerations related to address selection (including HE) are not detailed here on purpose because this is not part of discovery.

---

From: "Jon Shallow" <[email-masked]>
Date: Wed, 6 Nov 2019 16:22:44 -0000

Hi Med,

Sorry - not thinking straight - yes, you are correct in that a single
OPTION_Vx_DOTS_ADDRESS can contain multiple IP addresses - must have glazed
over the specific definition before hitting the "it MUST only use the first
instance" in the next section (Client Behavior).

Regards

Jon

> From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
> Sent: 06 November 2019 15:52
> To: Jon Shallow; 'Valery Smyslov'; [email-masked]; [email-masked]
> Subject: Re: [Dots] WGLC on draft-ietf-dots-server-discovery-05
> 
> Hi Jon,
> 
> > I have read through draft-ietf-dots-server-discovery-05 and think that
it
> > is
> [Med] Hmm, that is possible given that an instance is designed to carry a
list
> of IP addresses.
> [Med] Considerations related to address selection (including HE) are not
> detailed here on purpose because this is not part of discovery.
> 
> >
> > Regards
> >
> > Jon
> >

---

From: <[email-masked]>
Date: Thu, 7 Nov 2019 06:49:09 +0000

Hi Jon, 

OK, thanks. 

In order to further make things clear, I suggest to add this NEW text in the introduction of Section 5:

   The list of the IP addresses returned by DHCP servers is typically
   used to fed the DOTS server selection procedure detailed in
   Section 4.3 of [I-D.ietf-dots-signal-channel] or to provide DOTS
   agents with primary and backup IP addresses of their peer DOTS
   agents.

Would that be OK? 

I'm not sure the text need to hint any priority order set by the server (backup case), though. The reason is that list will be ordered by the client following HE. 

Cheers,
Med

> De : Jon Shallow [mailto:[email-masked]]
> Envoyé : mercredi 6 novembre 2019 17:23
> À : BOUCADAIR Mohamed TGI/OLN; 'Valery Smyslov'; [email-masked]; dots-
> [email-masked]
> Objet : RE: [Dots] WGLC on draft-ietf-dots-server-discovery-05
> 
> Hi Med,
>

---

From: "Jon Shallow" <[email-masked]>
Date: Thu, 7 Nov 2019 08:48:14 -0000

Hi Med,

That suggestion works for me - thanks.  No need to reference HE.

Regards

Jon

> Sent: 07 November 2019 06:49
> In order to further make things clear, I suggest to add this NEW text in
the
> introduction of Section 5:
> 
> I'm not sure the text need to hint any priority order set by the server
> (backup case), though. The reason is that list will be ordered by the
client
> following HE.
> > > > However, in particular with DHCPv(4|6), it is only possible to use
the
> > > > first
> > > > is down / unavailable for whatever reason, it is not possible to
define
> > a
> > > > gives the possibility of backup IP addresses, but am not sure
whether
> > this
> > > > A/AAAA RR is allowed, or each can be tested until the first
non-failure
> > > > addresses and then the final IP preferentially chosen according to
the
> > RR

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Thu, 7 Nov 2019 08:55:41 +0000

We may want to add the following line to support the above lines:
[I-D.ietf-acme-ip] describes a new protocol that allows CA to issue certificates for IP addresses.

Cheers,
-Tiru

> From: Dots <[email-masked]> On Behalf Of
> Sent: Thursday, November 7, 2019 12:19 PM
> To: Jon Shallow <[email-masked]>; 'Valery Smyslov'
> <[email-masked]>; [email-masked]; [email-masked]
> CAUTION: External email. Do not click links or open attachments unless you
> recognize the sender and know the content is safe.
> 
> Hi Jon,
> 
> OK, thanks.
> 
> I'm not sure the text need to hint any priority order set by the server (backup
> case), though. The reason is that list will be ordered by the client following HE.
> 
> Cheers,
> Med
> 
> > Envoyé : mercredi 6 novembre 2019 17:23 À : BOUCADAIR Mohamed
> TGI/OLN;
> > 'Valery Smyslov'; [email-masked]; dots- [email-masked] Objet : RE:
> > [Dots] WGLC on draft-ietf-dots-server-discovery-05
> >
> > Hi Med,
> >
> > OPTION_Vx_DOTS_ADDRESS can contain multiple IP addresses - must have
> > glazed over the specific definition before hitting the "it MUST only
> > use the first instance" in the next section (Client Behavior).
> >
> > Regards
> >
> > Jon
> >
> > > > Envoyé : mercredi 6 novembre 2019 15:59 À : 'Valery Smyslov';
> > > > [email-masked]; [email-masked] Objet : Re: [Dots] WGLC on
> > > > draft-ietf-dots-server-discovery-05
> > > >
> > > > Hi All,
> > > >
> > > > the first OPTION_Vx_DOTS_ADDRESS (5.1.3, 5.2.3).
> > >
> > > [Med] Yes
> > >
> > > > backup IP address as a secondary entry.  Is it the intention to
> > > > not
> > allow
> > > > backup IP addresses?
> > >
> > > > holds true for implementations for other Resource Records.  If
> > > > backup addresses are to be allowed, the draft is unclear whether
> > > > only the
> > first
> > > > found, or whether happy-eyeballs it to be invoked against all of
> > > > the IP addresses and then the final IP preferentially chosen
> > > > according to the
> > RR
> > > > returned order.
> > >
> > > [Med] Considerations related to address selection (including HE) are
> > > not detailed here on purpose because this is not part of discovery.
> > >
> > > >
> > > > Regards
> > > >
> > > > Jon
> > > >
> > > > > From: Dots [mailto:[email-masked]] On Behalf
> > > > > Of
> > > Valery
> > > > > Smyslov

---

From: <[email-masked]>
Date: Thu, 7 Nov 2019 09:02:32 +0000

Re-,

Done in my local copy. Thanks. 

Cheers,
Med

> Envoyé : jeudi 7 novembre 2019 09:48
> À : BOUCADAIR Mohamed TGI/OLN; [email-masked]; [email-masked]; 'Valery
> Smyslov'
> > glazed
> backup
> IP

---

From: <[email-masked]>
Date: Thu, 7 Nov 2019 09:22:24 +0000

Hi Tiru, 

I'm not sure this reference is needed. We do already cite 6125 to mention that CAs already issue certificates based on IP addresses. 

Cheers,
Med

> De : Konda, Tirumaleswar Reddy [mailto:[email-masked]]
> Envoyé : jeudi 7 novembre 2019 09:56
> À : BOUCADAIR Mohamed TGI/OLN; Jon Shallow; 'Valery Smyslov';
> [email-masked]; [email-masked]
> (backup

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Thu, 7 Nov 2019 09:31:47 +0000

> From: [email-masked]
> <[email-masked]>
> Sent: Thursday, November 7, 2019 2:52 PM
> To: Konda, Tirumaleswar Reddy
> <[email-masked]>; Jon Shallow <supjps-
> [email-masked]>; 'Valery Smyslov' <[email-masked]>; [email-masked];
> [email-masked]
> Subject: RE: [Dots] WGLC on draft-ietf-dots-server-discovery-05
> 
> I'm not sure this reference is needed. We do already cite 6125 to mention
> that CAs already issue certificates based on IP addresses.

https://tools.ietf.org/html/rfc6125#section-1.7.2 says certificates based on IP addresses is out of scope.

Cheers,
-Tiru

> > De : Konda, Tirumaleswar Reddy
> > [mailto:[email-masked]]
> > [email-masked]; [email-masked] Objet : RE: [Dots] WGLC on
> > > CAUTION: External email. Do not click links or open attachments
> > > unless
> > you
> > > > Sorry - not thinking straight - yes, you are correct in that a
> > > > single OPTION_Vx_DOTS_ADDRESS can contain multiple IP addresses -
> > > > must have glazed over the specific definition before hitting the
> > > > "it MUST only use the first instance" in the next section (Client
> Behavior).
> > > >
> > > > Regards
> > > >
> > > > Jon
> > > >
> > > > > > De : Dots [mailto:[email-masked]] De la part de Jon
> > > > > > Shallow Envoyé : mercredi 6 novembre 2019 15:59 À : 'Valery
> > > > > > Smyslov'; [email-masked]; [email-masked] Objet : Re:
> > > > > > [Dots] WGLC on
> > > > > > However, in particular with DHCPv(4|6), it is only possible to
> > > > > > use the first OPTION_Vx_DOTS_ADDRESS (5.1.3, 5.2.3).
> > > > >
> > > > > [Med] Yes
> > > > >
> > > > > > is down / unavailable for whatever reason, it is not possible
> > > > > > to define
> > > > a
> > > > > > backup IP address as a secondary entry.  Is it the intention
> > > > > > to not
> > > > allow
> > > > > > backup IP addresses?
> > > > >
> > > > >    address(es) included in OPTION_V6_DOTS_ADDRESS are used to
> > > > > reach
> > > the
> > > > >    ^^^^^^^^^^
> > > > > > With DNS, I know that A/AAAA records can be presented
> > > > > > round-robin
> > > > > which
> > > > > > backup addresses are to be allowed, the draft is unclear
> > > > > > whether only the
> > > > first
> > > > > > found, or whether happy-eyeballs it to be invoked against all
> > > > > > of the IP addresses and then the final IP preferentially
> > > > > > chosen according to the
> > > > RR
> > > > > > returned order.
> > > > >
> > > > > [Med] Considerations related to address selection (including HE)
> > > > > are not detailed here on purpose because this is not part of discovery.
> > > > >
> > > > > >
> > > > > > Regards
> > > > > >
> > > > > > Jon
> > > > > >
> > > > > > > From: Dots [mailto:[email-masked]] On
> > > > > > > Behalf Of
> > > > > Valery
> > > > > > > Smyslov
> > > > > > > The WGLC will last for two weeks and will end on November
> > > > > > > the
> > 7th.

---

From: <[email-masked]>
Date: Thu, 7 Nov 2019 09:36:03 +0000

Yes, but I was referring to this part: 

      few certification authorities issue server certificates based on
          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
      IP addresses, but preliminary evidence indicates that such
      ^^^^^^^^^^^^
      certificates are a very small percentage (less than 1%) of issued
      certificates.

Cheers,
Med

> Envoyé : jeudi 7 novembre 2019 10:32

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Thu, 7 Nov 2019 09:40:01 +0000

> Sent: Thursday, November 7, 2019 3:06 PM

It is part of the out of scope section 1.2 but ACME will make it more common.

-Tiru

> > > I'm not sure this reference is needed. We do already cite 6125 to
> > > mention that CAs already issue certificates based on IP addresses.
> >
> > > > Envoyé : jeudi 7 novembre 2019 09:56 À : BOUCADAIR Mohamed
> > > > TGI/OLN; Jon Shallow; 'Valery Smyslov'; [email-masked];
> > > > [email-masked] Objet : RE: [Dots] WGLC on
> > > > > case), though. The reason is that list will be ordered by the
> > > > > client
> > > > following HE.
> > > > >
> > > > > Cheers,
> > > > > Med
> > > > >
> > > > > > single OPTION_Vx_DOTS_ADDRESS can contain multiple IP
> > > > > > addresses - must have glazed over the specific definition
> > > > > > before hitting the "it MUST only use the first instance" in
> > > > > > the next section (Client
> > > Behavior).
> > > > > >
> > > > > > Regards
> > > > > >
> > > > > > Jon
> > > > > >
> > > > > > > > -----Message d'origine----- De : Dots
> > > > > > > > [mailto:[email-masked]] De la part de Jon Shallow
> > > > > > > > Envoyé : mercredi 6 novembre 2019 15:59 À : 'Valery
> > > > > > > > However, in particular with DHCPv(4|6), it is only
> > > > > > > > possible to use the first OPTION_Vx_DOTS_ADDRESS (5.1.3,
> 5.2.3).
> > > > > > >
> > > > > > > [Med] Yes
> > > > > > >
> > > > > > > > is down / unavailable for whatever reason, it is not
> > > > > > > > possible to define
> > > > > > a
> > > > > > > > backup IP address as a secondary entry.  Is it the
> > > > > > > > intention to not
> > > > > > allow
> > > > > > > > backup IP addresses?
> > > > > > >
> > > > > > >    address(es) included in OPTION_V6_DOTS_ADDRESS are used
> > > > > > > to reach
> > > > > the
> > > > > > >    ^^^^^^^^^^
> > > > > > > > gives the possibility of backup IP addresses, but am not
> > > > > > > > sure whether
> > > > > > this
> > > > > > > > holds true for implementations for other Resource Records.
> > > > > > > > If backup addresses are to be allowed, the draft is
> > > > > > > > unclear whether only the
> > > > > > first
> > > > > > > > A/AAAA RR is allowed, or each can be tested until the
> > > > > > > > first non-failure
> > > > > > is
> > > > > > > > found, or whether happy-eyeballs it to be invoked against
> > > > > > > > all of the IP addresses and then the final IP
> > > > > > > > preferentially chosen according to the
> > > > > > RR
> > > > > > > > returned order.
> > > > > > >
> > > > > > > [Med] Considerations related to address selection (including
> > > > > > > HE) are not detailed here on purpose because this is not
> > > > > > > part of
> > discovery.
> > > > > > >
> > > > > > > >
> > > > > > > > Regards
> > > > > > > >
> > > > > > > > Jon
> > > > > > > >
> > > > > > > > > The WGLC will last for two weeks and will end on
> > > > > > > > > November the
> > > > 7th.

---

From: <[email-masked]>
Date: Thu, 7 Nov 2019 09:50:36 +0000

Re-,

Yeah. 

My point is adding that citation/information does not change the behavior nor the design in the draft.

Cheers,
Med

> Envoyé : jeudi 7 novembre 2019 10:40

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Thu, 7 Nov 2019 10:03:39 +0000

> Sent: Thursday, November 7, 2019 3:21 PM
> To: Konda, Tirumaleswar Redd

Okay.

-Tiru

> > > > Envoyé : jeudi 7 novembre 2019 10:32 À : BOUCADAIR Mohamed
> > > > > I'm not sure this reference is needed. We do already cite 6125
> > > > > to mention that CAs already issue certificates based on IP addresses.
> > > >
> > > > https://tools.ietf.org/html/rfc6125#section-1.7.2 says
> > > > certificates based on IP addresses is out of scope.
> > > >
> > > > Cheers,
> > > > -Tiru
> > > >
> > > > >
> > > > > Cheers,
> > > > > Med
> > > > >
> > > > > > > CAUTION: External email. Do not click links or open
> > > > > > > attachments unless
> > > > > > you
> > > > > > >    Section 4.3 of [I-D.ietf-dots-signal-channel] or to
> > > > > > > provide
> > DOTS
> > > > > > > case), though. The reason is that list will be ordered by
> > > > > > > the client
> > > > > > following HE.
> > > > > > >
> > > > > > > Cheers,
> > > > > > > Med
> > > > > > >
> > > > > > > > -----Message d'origine----- De : Jon Shallow
> > > > > > > > [mailto:[email-masked]]
> > > > > > > > Sorry - not thinking straight - yes, you are correct in
> > > > > > > > that a single OPTION_Vx_DOTS_ADDRESS can contain multiple
> > > > > > > > IP addresses - must have glazed over the specific
> > > > > > > > definition before hitting the "it MUST only use the first
> > > > > > > > > > [mailto:[email-masked]] De la part de Jon
> > > > > > > > > > Shallow Envoyé : mercredi 6 novembre 2019 15:59 À :
> > > > > > > > > > 'Valery Smyslov'; [email-masked]; [email-masked] Objet :
> Re:
> > > > > > > > > > [Dots] WGLC on
> > > > > > > > > > I have read through
> > > > > > > > > > and think that
> > > > > > > > >    If the DHCP client receives OPTION_V6_DOTS_ADDRESS
> > > > > > > > > only,
> > > the
> > > > > > > > >    address(es) included in OPTION_V6_DOTS_ADDRESS are
> > > > > > > > > used to reach
> > > > > > > the
> > > > > > > > >    ^^^^^^^^^^
> > > > > > > > >    peer DOTS agent.  In addition, these addresses can be
> > > > > > > > > used
> > as
> > > > > > > > > > gives the possibility of backup IP addresses, but am
> > > > > > > > > > not sure whether
> > > > > > > > this
> > > > > > > > > > found, or whether happy-eyeballs it to be invoked
> > > > > > > > > > against all of the IP addresses and then the final IP
> > > > > > > > > > > From: Dots
> > > > > > > > > > > [mailto:[email-masked]] On Behalf
> > > > > > > > > > > Of
> > > > > > > > > Valery
> > > > > > > > > > > Smyslov

---

From: <[email-masked]>
Date: Thu, 7 Nov 2019 12:37:30 +0000

Hi Valery, all, 

Is there any objection if we move I-D.ietf-dots-signal-call-home and I-D.ietf-dots-signal-channel to be informative references. 

We have listed I-D.ietf-dots-signal-channel as normative because we have this text in Section 8:

"DOTS agents must
   authenticate each other using (D)TLS before a DOTS session is
   considered valid according to the [I-D.ietf-dots-signal-channel]."

But I'm afraid this is not appropriate given that the above is not a NEW requirement but a reminder of the behavior in I-D.ietf-dots-signal-channel. We may call out this better by using this text: 

NEW:
  As a reminder, DOTS agents must
   authenticate each other using (D)TLS before a DOTS session is
   considered valid according to the [I-D.ietf-dots-signal-channel].

Any objections? 

Cheers,
Med

> De : Dots [mailto:[email-masked]] De la part de Valery Smyslov
> Envoyé : mercredi 23 octobre 2019 09:37
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Dots] WGLC on draft-ietf-dots-server-discovery-05
> 
> Hi,
> 
> this message starts a Work Group Last Call (WGLC) for draft-ietf-dots-
> server-discovery-05.
> The version to be reviewed is here: https://www.ietf.org/id/draft-ietf-
> dots-server-discovery-05.txt
>

---

From: "Valery Smyslov" <[email-masked]>
Date: Thu, 7 Nov 2019 16:15:08 +0300

Hi Med,

this makes sense for signal-call-home, but why signal-channel?
You currently directly reference it:

   The DOTS client (or the Call Home DOTS
   server) will then use the address selection specified in Section 4.3
   of [I-D.ietf-dots-signal-channel] to identify the IP address of the
   peer DOTS server (or Call Home Client).

Regards,
Valery.

> But I'm afraid this is not appropriate given that the above is not a NEW requirement but a reminder of the
> behavior in I-D.ietf-dots-signal-channel. We may call out this better by using this text:
> 
> NEW:

---

From: <[email-masked]>
Date: Thu, 7 Nov 2019 13:45:57 +0000

Re-,

Thank you, Valery.

As per the text you quoted, it should be put it its context:

   The design allows to terminate the base DOTS channels and DOTS Call
   Home on the same or distinct peer DOTS agents.  If distinct peer DOTS
   agents are deployed, the DHCP option can return, for example, a list
                                                  ^^^^^^^^^^^^^^ 
   of IP addresses to a requesting DOTS agent.  This list includes the
   IP address to be used for the base DOTS channels and the IP address
   for the DOTS Call Home.  The DOTS client (or the Call Home DOTS
   server) will then use the address selection specified in Section 4.3
   of [I-D.ietf-dots-signal-channel] to identify the IP address of the
   peer DOTS server (or Call Home Client).

It does only exemplify what an agent may do. The text you quoted does not use any normative language.

Cheers,
Med

> De : Valery Smyslov [mailto:[email-masked]]
> Envoyé : jeudi 7 novembre 2019 14:15
> À : BOUCADAIR Mohamed TGI/OLN; [email-masked]
> > Is there any objection if we move I-D.ietf-dots-signal-call-home and I-
> D.ietf-dots-signal-channel to be
> > informative references.
> >

---

From: "Valery Smyslov" <[email-masked]>
Date: Thu, 7 Nov 2019 17:26:34 +0300

Hi Med,

if you think that readers of this document are not required to read and understand 
signal-channel in order to implement this spec, then it's perfectly OK to make it Informative.

Regards,
Valery.

---

From: <[email-masked]>
Date: Thu, 7 Nov 2019 14:37:09 +0000

Re-,

I confirm. Thank you for looking into this.

I will proceed with the change unless there is objection. 

Cheers,
Med

> Envoyé : jeudi 7 novembre 2019 15:27
> > > > We have listed I-D.ietf-dots-signal-channel as normative because we
> have
> > > this text in Section 8:
> > > >
> > > > "DOTS agents must
> > > > But I'm afraid this is not appropriate given that the above is not a
> NEW
> > > requirement but a reminder of the
> > > > behavior in I-D.ietf-dots-signal-channel. We may call out this better
> by
> > > using this text:
> > > >
> > > > NEW:

---

From: "Valery Smyslov" <[email-masked]>
Date: Tue, 12 Nov 2019 10:24:07 +0300

Hi,

the WGLC period is over. We received no objection for publication of this
document.
There were few comments from WG participants suggesting text improvements, 
so a new version of the draft is needed. Once it is published (when the
submission
window opens), I'll start preparing shepherd write-up.

Regards,
Valery.

---

From: <[email-masked]>
Date: Mon, 18 Nov 2019 08:49:25 +0000

Hi Valery, 

The new version integrating the WGLC comments is now available online. 

Cheers,
Med

> Envoyé : mardi 12 novembre 2019 08:24
> À : [email-masked]

---

From: "Valery Smyslov" <[email-masked]>
Date: Mon, 18 Nov 2019 11:57:30 +0300

Hi Med,

thank you. I'll start preparing the write-up soon.

Regards,
Valery.

> > Envoyé : mardi 12 novembre 2019 08:24 À : [email-masked] Cc :
> > [email-masked] Objet : Re: [Dots] WGLC on
> > the WGLC period is over. We received no objection for publication of
> > this document.
> > There were few comments from WG participants suggesting text
> > improvements, so a new version of the draft is needed. Once it is
> > published (when the submission window opens), I'll start preparing
> > shepherd write-up.
> >
> > Regards,
> > Valery.
> >
> > > Hi,
> > >
> > > draft-ietf-dots- server-discovery-05.