Subject: Re: [Dots] [core] RFC 8768 on Constrained Application Protocol (CoAP) Hop-Limit Option

From: <[email-masked]>
Date: Mon, 23 Mar 2020 07:18:39 +0000

Hi Cartsen, 

Thank you Carsten and the core WG for helping to get this through. 

There was a point raised during the publication of this RFC: HTTP option encapsulating CoAP ones. I hope that someone can take that work. 

Cheers,
Med

> -----Message d'origine-----
> De : core [mailto:[email-masked]] De la part de Carsten Bormann
> Envoyé : samedi 21 mars 2020 08:34
> À : [email-masked] WG
> Objet : Re: [core] RFC 8768 on Constrained Application Protocol (CoAP)
> Hop-Limit Option
> 
> Congratulations for the publication of the 13th RFC from this WG!
> 
> The original -00 was submitted 2018-08-16, so it took a bit more than
> 1½ years to get this published (initial submission to approval was
> 2018-08-16 to 2019-11-26, so 1¼ years).
> 
> This CoRE RFC is notable in that it originated in a non-IoT WG, the
> DOTS WG (DDoS Open Threat Signaling).  I think there was some room for
> improvement in how we(*) handled this, but we did succeed, and in a
> time frame that is still quite reasonable.
> 
> Thanks to the authors for bringing this to the CoRE WG!
> 
> Grüße, Carsten
> 
> (*) I think I can say that because it’s mostly me that is to blame
> here, and I am optimistic the current chairs can be better than my
> contribution at the time was...
> 
> 
> > On 2020-03-21, at 05:21, [email-masked] wrote:
> >
> > A new Request for Comments is now available in online RFC libraries.
> >
> >
> >        RFC 8768
> >
> >        Title:      Constrained Application Protocol (CoAP)
> >                    Hop-Limit Option
> >        Author:     M. Boucadair,
> >                    T. Reddy.K,
> >                    J. Shallow
> >        Status:     Standards Track
> >        Stream:     IETF
> >        Date:       March 2020
> >        Mailbox:    [email-masked],
> >                    [email-masked],
> >                    [email-masked]
> >        Pages:      8
> >        Updates/Obsoletes/SeeAlso:   None
> >
> >        I-D Tag:    draft-ietf-core-hop-limit-07.txt
> >
> >        URL:        https://www.rfc-editor.org/info/rfc8768
> >
> >        DOI:        10.17487/RFC8768
> >
> > The presence of Constrained Application Protocol (CoAP) proxies may
> > lead to infinite forwarding loops, which is undesirable. To prevent
> > and detect such loops, this document specifies the Hop-Limit CoAP
> > option.
> >
> > This document is a product of the Constrained RESTful Environments
> Working Group of the IETF.
> >
> > This is now a Proposed Standard.
> >
> > STANDARDS TRACK: This document specifies an Internet Standards Track
> > protocol for the Internet community, and requests discussion and
> suggestions
> > for improvements.  Please refer to the current edition of the
> Official
> > Internet Protocol Standards (https://www.rfc-editor.org/standards)
> for the
> > standardization state and status of this protocol.  Distribution of
> this
> > memo is unlimited.
> >
> > This announcement is sent to the IETF-Announce and rfc-dist lists.
> > To subscribe or unsubscribe, see
> >  https://www.ietf.org/mailman/listinfo/ietf-announce
> >  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist
> >
> > For searching the RFC series, see https://www.rfc-editor.org/search
> > For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk
> >
> > Requests for special distribution should be addressed to either the
> > author of the RFC in question, or to [email-masked].
> Unless
> > specifically noted otherwise on the RFC itself, all RFCs are for
> > unlimited distribution.
> >
> >
> > The RFC Editor Team
> > Association Management Solutions, LLC
> >
> > _______________________________________________
> > IETF-Announce mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ietf-announce
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 23 Mar 2020 08:24:28 +0100

> There was a point raised during the publication of this RFC: HTTP option encapsulating CoAP ones. I hope that someone can take that work. 

It’s on my to-do list.

Anyone who wants to help?

Grüße, Carsten