Subject: [Dots] Call for adoption of draft-hayashi-dots-telemetry-use-cases-00

From: "Valery Smyslov" <[email-masked]>
Date: Thu, 27 Aug 2020 10:43:57 +0300

Hi,

after discussion with Yuhei we decided to issue a call for adoption 
of draft-hayashi-dots-telemetry-use-cases-00 as a WG document.

Note, that the chairs have an opinion, that the DOTS WG has
already published quite a lot of informational documents, 
describing DOTS requirements, architecture, use cases.
We think that having one more auxiliary document that
describes use cases only for an optional feature of DOTS
(telemetry) is not fully justified and it's probably better
to merge telemetry use cases draft with telemetry I-D. 
We think that for implementers it's generally easier to look into 
a single document, than to find a separate one
describing use cases. Another consideration is that 
if a separate document is adopted, then the processing of 
the telemetry I-D will probably have to be slow down until the telemetry use cases 
draft is ready, so that they are sent to publication together
(in this case the telemetry draft will  have a steady reference to RFC and
not to I-D).

On the other hand, discussion on last DOTS meeting and 
on the list indicated that quite a lot of people in the WG 
prefer to have telemetry use cases as a separate 
document, instead of merging it with the telemetry
draft. The concerns were expressed that telemetry
draft is already a long document and authors 
don't want to make it longer.

So, this message start a two weeks call for adoption of 
draft-hayashi-dots-telemetry-use-cases-00 that will end 11 September. 
Please, respond to the list with your preference among 2 options:

1. Adopt this draft as a separate document describing DOTS telemetry use cases.
2. Don't adopt this draft and merge its content into the draft-ietf-dots-telemetry instead.

We'll be very much appreciated if you also give reasoning for your choice.

Regards,
Frank & Valery.

---

From: <[email-masked]>
Date: Thu, 27 Aug 2020 09:44:42 +0000

Hi Valery, all, 

(1)

We do already have in the telemetry I-D some text to describe the main uses of the DOTS telemetry. Nevertheless, that text does not intend to be exhaustive nor to dive into more details to describe how to put the various pieces together. 

(2)

I do see a value in having a document that discusses in more details how to play with DOTS telemetry. draft-hayashi-*  can be such document. The document can be updated with pieces that are already in the telemetry draft. I support thus this draft to be adopted. 

(3)

As a support document (https://www.ietf.org/about/groups/iesg/statements/support-documents/), we don't need to publish it as an RFC. We can decide about that once the document is more mature.

(4)

>From the assessment shared by the authors of draft-hayashi-* in the past, I remember that they indicated that their use cases are met with the attributes specified in the telemetry I-D. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de Valery Smyslov
> Envoyé : jeudi 27 août 2020 09:44
> À : [email-masked]
> Cc : [email-masked]; H Y <[email-masked]>; draft-
> [email-masked]
> Objet : [Dots] Call for adoption of draft-hayashi-dots-telemetry-use-
> cases-00
> 
> Hi,
> 
> after discussion with Yuhei we decided to issue a call for adoption of
> draft-hayashi-dots-telemetry-use-cases-00 as a WG document.
> 
> Note, that the chairs have an opinion, that the DOTS WG has already
> published quite a lot of informational documents, describing DOTS
> requirements, architecture, use cases.
> We think that having one more auxiliary document that describes use
> cases only for an optional feature of DOTS
> (telemetry) is not fully justified and it's probably better to merge
> telemetry use cases draft with telemetry I-D.
> We think that for implementers it's generally easier to look into a
> single document, than to find a separate one describing use cases.
> Another consideration is that if a separate document is adopted, then
> the processing of the telemetry I-D will probably have to be slow down
> until the telemetry use cases draft is ready, so that they are sent to
> publication together (in this case the telemetry draft will  have a
> steady reference to RFC and not to I-D).
> 
> On the other hand, discussion on last DOTS meeting and on the list
> indicated that quite a lot of people in the WG prefer to have
> telemetry use cases as a separate document, instead of merging it with
> the telemetry draft. The concerns were expressed that telemetry draft
> is already a long document and authors don't want to make it longer.
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Meiling Chen" <[email-masked]>
Date: Fri, 28 Aug 2020 17:43:02 +0800

Hi all,
I do agree with med, telemetry use cases are met with the attributes specified in the telemetry I-D.
use case provide more practical considerations for the use of telemetry atrributes.

I support this draft to be adopted by WG and make it more mature.

Best,
Meiling.
 
From: [email-masked]
Date: 2020-08-27 17:44
To: Valery Smyslov; [email-masked]
CC: [email-masked]; H Y; [email-masked]
Subject: RE: [Dots] Call for adoption of draft-hayashi-dots-telemetry-use-cases-00
Hi Valery, all, 
 
(1)

(2)

(3)

(4)

Cheers,
Med

---

From: H Y <[email-masked]>
Date: Mon, 31 Aug 2020 09:52:27 +0900

Hi Med, all,

Thank you for your comments.

> As a support document (https://www.ietf.org/about/groups/iesg/statements/support-documents/), we don't need to publish it as an RFC. We can decide about that once the document is more mature.
IMO, it seems like a good option so far because the option relieves
the consideration or the concerns.

> Another consideration is that if a separate document is adopted, then the processing of the telemetry I-D will probably have to be slow down until the telemetry use cases draft is ready, so that they are sent to publication together (in this case the telemetry draft will  have a steady reference to RFC and not to I-D).

>The concerns were expressed that telemetry draft is already a long document and authors don't want to make it longer.

Thanks,
Yuhei

-- 
----------------------------------
Yuuhei HAYASHI
08065300884
[email-masked]
[email-masked]
----------------------------------